Schlage Connected Keypad Lever Door Lock (fe599nx)

Hello all.

About a month ago I had all of my zwave devices disappeared from the hub. I reset the hub, unpaired all of the zwave devices (smoke and co, switches, repeater plugs, outlets), and re-added them back in.

I ran into an issue with pairing all 3 of the Schlage fe599nx levers. I would unpair them and factory reset them (took out the batteries, hit the schlage button, waiting a little bit, insert new batteries, held down the schlage button until the green light appears). Then I would try to add them back into the hub. When pairing the green light flashes but nothing appears on smartthings to indicate the device is viewable. Note, when I paired them, the hub is less than a foot away from the lock. I did notice that the in the events there was a zwjoin. see below.

I manually created a device via the IDE. After I created the device and linked it to the correct id, it would appear on the smartthings app. I used the standard zwave lock DTH and things seem to work. I can lock and unlock the doors from the app. I can setup simple automations. I cannot use custom DTHs though (see #3 below).

  1. Has anyone recently run into pairing issues with the fe599nx?
  2. Was there a firmware update recently that could have caused the pairing issue where the device pairs but does not appear on the app/IDE list of devices?
  3. Another issue I’m running into is when I try to use a different DTH which helps configure some of the settings (autolock, lock and leave, beeper mode, etc), the DTH does not work because the zwave raw description/data isn’t available to parse.

I’ve contacted smartthings support twice already and there hasn’t been a response. Any help, ideas, or suggestions would greatly be appreciated.

General device exclusion? Also, never hurts to reboot your hub and run z-wave repair and then try to add your locks.

Hey jkp. Yes, when I say unpair, I mean that I did an exclusion of the locks. In addition, I’ve tried rebooting my hub and running a zwave repair. I’ve tried various permutations of all of the steps. The locks join the zwave network, they just don’t fully integrate into smartthings. I’m not sure why. I’ve had this setup/platform working for 2+ years with no real issues.

Same, I have Schlage lock that won’t pair even after exclusion, hub reboot. My lock doesn’t even work if I manually add device and add standard dth.

I have done zwave repairs and nothing.
Using default lock codes for now, so close to jumping to Hubitat…so many devices to move and automation rules but placed an order, waiting for it to arrive.

Contacted Smartthings email two weeks ago no response only generic email. What a joke support has become.

I have firmware

Maybe the firmware needs updating but who knows when the next update is getting push :confused:

Do either of you have custom DTH for locks in IDE? If yes, two options to consider:

  1. use ST stock device handlers and remove the custom DTH.
  2. open the custom DTH in IDE, (re)save/publish it.

Then exclude your lock again and try to pair it.

right now i’m using the stock z-wave lock DTH. i’ve tried the ones with codes and also a custom one. i don’t think the DTH is the main issue. the DTH wouldn’t cause the device to not display in the app / IDE. the zwjoin event proves that it pairs. i’m leaning towards a firmware issue.

when you try to pair the lock, do you see any zwjoin events in the logs? if you do, you should be able to create a device in the IDE and set the ID to the ID from the zwjoin. if it doesn’t even create zwjoin event, there’s not much you can do.

i’ve tried that as well. i started from scratch when all of the zwave devices disappeared. i’ve ruled out custom code causing the issue.

already did…

Responding to your PM. Try to reboot the hub after excluding it. As in physically power it down for a minute and then try to pair it after it reboots.

There was something about caching the id with the zwave controller that I had run into last year. It was a rare condition but the solution that was recommended by ST which worked was a physical reboot to clear the cache. In some cases it can take upto 24 hours to clear. Do reboot and wait for a day and then try to pair it.

I’ll give it a shot. I’ll unpair it and then do a physical reboot. For the physical reboot, do i need to have it completely powered down for 24 hours? Or can I power it down for a couple minutes and the start it back up, then come back in 24 hours to pair it?

You can use the hub after power cycling it. Just needed to wait for up to 24 hours for the cache to clear before trying to pair again.

RBoy. It worked! I waited 48 hours just to make sure. Thanks for the tip. @Smartphi, give it a shot.


Cool the 48 hour wait process worked! Added manually after finding joint event. It worked with ‘Zwave lock with codes’ with ‘cloud’ execution the first time. I also switch type to ‘zwave lock’ and ‘local’ execution is working.

@RBoy I switched to ‘universal zwave lock with alarm’ and no dice, no response and tiles are blank/missing. I switch back to either of the above dth types and lock works again. :confused:

1 Like

That means there is too much delay/latency between the hub and the platform. The platform and hub is probably timing out sending and processing z-wave responses. It’s been a very common issue we have heard from many folks for the past few weekends. I had commented about this earlier this week. The platform seems to running slow with high latency on weekends impacting apps and DTH’s running the cloud which include apps timing out, saving problems and slow responses. It usually fixes itself by Monday.

1 Like

ok so i have 2 fe599 locks and a smartthings hub. when i had my 2nd gen hub everything worked great. that hub died so i purchased a 3rd generation hub. i have never been able to get them to connect. i have also tried a different gen 3 hub and no luck. i have had a case open with smartthings for like 6 months and they have had me try things but nothing has worked. i can’t be the only one having issues with this. How can i troubleshoot this. any ideas would be great