Schema connector developer mode for multiple accounts

Is it possible to have other people test my schema connector without giving out my account login details?

I have an account that is in an organization. I want someone to help me test. They are also in the organization. They enabled developer mode and they can see the test device. My project was created in the organization.

When they try to add the device, after I send a discoveryResponse I get the following error:

{“errorEnum”:“BAD-REQUEST”,“detail”:“profileId: Profile xxxx is not owned by location member!”}

Adding devices works fine on my account, since I am the project owner. Is this a bug on my end or on SmartThings’ end?

Tagging @nayelyz

Hello @stav,

In order for the other members of the organization to use the device profile you created, its status must be “published” instead of “development”.

You can publish it by setting up the SmartThings CLI and running the command:
smartthings deviceprofiles:publish <device_profile_id>

To get the current configuration of the device profile, use this command:
smartthings deviceprofiles <device_profile_id> -j

Take into consideration that once the device profile is published, it cannot be modified, you would need to create a new one by copying the configuration (you can use the CLI for this too).

Please, let me know if you have any questions.

Can this be done through the API as well?

I tried setting up the CLI but authentication is giving me an error. It takes me to the browser and when logging in it gives me the following error:

[2020-10-08T10:07:32.993] [ERROR] login-authenticator - received “server_error” error when trying to authenticate
[2020-10-08T10:07:32.993] [ERROR] login-authenticator - Unexpected server error.

Hello @stav,

This error can appear because the config.yaml file is missing or its content is not correct.
An alternative is to add the --token parameter in the command and input your Personal Access Token. For example:
smartthings deviceprofiles:publish <device_profile_id> --token=xxxx-xxx-xxxx

If this answers your question, can you please mark it as solved? If not, let me know what’s going on and I can dig in further.

1 Like

Creating the config file did it! Thank you.

1 Like