Schalge Connect Z-Wave with new Aeotec Hub

Hey everyone. I’m unfortunately having some issues with my Schlage Connect door lock, that hopefully someone might have the answer to.

I am unfortunately one of the people affected by the phase out of the ADT SmartThings Hub, and therefore ordered one of the new Aeotec Hubs. I’ve been slowly trying to move over some of my devices to the Aeotec Hub, but am having issues with one device. The Schlage Connect Z-Wave door lock.

Obviously reading through other thread posts, it is apparent that people have issues getting this device to pair correctly to their Hubs, but I have followed the guidance out there, and have tried every variation I can think of and unfortunately it does not pair to my new Aeotec Hub. To hopefully help condence my post/question, below are the details to my issue:

*The Schlage properly deletes from my ADT ST Hub on the ST app. Following that I do a general exclusion (which is successful and shows 1 device deleted) from my Aeotec Hub. Then I reboot the Aeotec Hub, and perform a Schlage factory reset. Following that I attempt to add the lock using the ST app (with the Hub less than 1’ away from the lock) . The lock never successfully pairs to the Hub, the Schlage lock indicates failure pairing, and the ST app stays in the attempting to add the device screen until I manually cancel it within the app.

*Sometimes after doing this, a generic Z-Wave device will show added within the ST app, and IDE; but, it is unresponsive, even if I change the Device Handler to Door Lock.

*After excluding, and resetting the lock, I am able to pair the Schlage lock back to my ADT Hub no problem. It adds within seconds, and actually pairs up with the ADT Hub that is mounted on a wall about 20’ away. It is actually surprising how easily is pairs with the ADT Hub.

*I currently have no custom Device Handlers on IDE, and I have factory reset the Aeotec Hub once already. Unfortunately it hasn’t made a difference. Also, I paired a Z-Wave GE/Jasco light switch no problem to the Aeotec Hub. This issue is specifically with just this Schlage lock.

If anyone has any ideas I appreciate it. I am wondering whether there is a firmware incompatibility with the latest v3 firmware…or perhaps am hoping it is that since that might mean it can be resolved eventually. Has anyone who has recently received their Aeotec Hub, been able to pair a Schlage Connect lock? I realize that is a long shot since the Hub is fairly new, although if it is just the Samsung v3 Hub, then perhaps someone with a Schlage lock has paired to that and can give some input.

Thanks again everyone…long post I know.

1 Like

tagging @RBoy the lock expert


This is common issue and usually indicates either a mesh problem or a latency issue. The pairing fails to complete in a timely fashion or some information may be lost in the mesh while pairing which is what causes the device to eventually show up with the wrong device handler, complete information and renders it inoperable.

In addition to what you’re doing, you may want to try these steps: [RELEASE] Universal Enhanced Z-Wave Lock Device Handler for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung - #1464 by RBoy

It also helps to search your mesh for any ghost devices and get rid of them: FAQ: How to remove ghost devices from your z-wave and zigbee networks

If you have a newer Z-Wave Plus module like the BE469ZP model, you should use S2 pairing (using the Generic Z-Wave device option) from the ST mobile app.

1 Like

Thank you for sharing your info on hopefully resolving my issue. Unfortunately it is still having issues this afternoon as I went through another shot of following the steps outlines in your linked post.

I do have the newer Z-Wave Plus model, so this time I went ahead and gave it a shot using the Generic Z-Wave device option as you recommended. Unfortunately the pairing process still timed out, and the ST app reported a problem. In IDE it added a generic Door Lock (Type: Z-Wave Lock).

|Data|* networkSecurityLevel: ZWAVE_S2_FAILED|

|Raw Description|zw:F type:4003 mfr:0000 prod:0000 model:0000 ver:0.00 zwv:0.00 lib:00 cc:5E,98,9F,55,6C,8A,22|

As usual, after removing the generic Z-Wave device, and excluding the lock, it paired without issue to my ADT ST Hub.

Is there any reason to suspect that having 2 Hubs active at one location in the ST app could cause issues? Honestly I don’t see why, but I am at a loss on why this device is the only one giving me so much trouble moving over to the Aeotec Hub.

Thanks again.

The S2 failed along with the 0’s indicate that there is packet loss during the communication with the lock. Since you’re using the ZP lock try pressing the zwave pairing button on the lock to pair it with the hub.

I’ve tried using both the programming code, and the manual enroll/disenroll button on the device. Unfortunately both result in the same outcome.

Also for reference, I swapped my Schlage Connect lock with another one just to rule out a device issue…unfortunately it didn’t make a difference either.

I am so happy to see that the issue have been solved. Keep sharing this type of info. I am looking for the same issue.


If it’s attempting S2 pairing, is there any point where the app asks to scan a bar code or enter a code manually? This information from the lock will be needed for successful s2 pairing.

If you’re attempting initial pairing only a foot away it’s hard to imagine a mesh issue. I did have to literally put my zwave Kwikset lock on the hub to get it to pair though. These locks usually need some close “whisper” pairing mode to initially connect, then will work normally in their final location .

No, it doesn’t ever ask for any code. Essentially the ST App add device screen (once you start the search) eventually times out and says something went wrong, try again. The Schlage Lock itself, beeps and flashes the red light indicating failed pairing.

Yeah, I’ve tried it multiple times with the Hub less than a foot away. Unfortunately no change. Like said, it pairs no problem to my old ADT ST Hub…but everything tried so far hasn’t worked trying to get it over to the Aeotec Hub.

Is there a qr code on the device or paperwork to scan?

If it’s an s2 device there should be. Then under the add device screen you can click “scan qr code” and scan it to add it.

I dont know much about the ADT hub, and @JDRoberts can correct me if I’m wrong, but I dont believe it supports S2 zwave security.

The V3 hub does support S2 security, which includes additional steps at pairing to secure the connection with a barcode or key code. I believe that is the difference between the two hubs. The new hub will try s2 encryption first, then eventually time out and connect with downgraded security.

Either the lock is giving up during this extra time, or the lock is seeing s2 security as an option and insisting on it, and something is going wrong with the s2 pairing.

Adding the s2 device by giving it the barcode first speeds up the pairing and it doesn’t have to stop in the middle to ask for the code. I’ve found it to be more successful to scan the code first when adding an s2 device.

I wonder if there is an issue with the fallback to S0 security… even though the Schlage is the Z-Wave Plus model with S2. I’ll check again, but as far as I can see Schlage did not put a barcode/QR on the device.

At least that makes sense that this might be an S2 security issue as to why it isn’t pairing correctly.

Yeah, that’s correct. And perhaps that is why it pairs so easily. In IDE it shows the S0_FALLBACK when paired to the ADT ST Hub.

1 Like

I’m not sure how to do an S2 inclusion without a QR code. If someone has this lock working on a V3 hub it definitely would be good to hear how it worked.

It’s definitely not just you a lot of people have trouble with these schlage locks pairing to all different hubs. On Hubitat, somene said they literally duck taped the lock to the hub to get it to pair. I know it’s a different hub but you can take a look at this thread for some possible other ideas Schlage be469 - Support - Hubitat

1 Like

Tagging @rboy , who is an expert on locks. :sunglasses:

(He offers a library of very sophisticated code which is behind a pay wall on his site and is very popular, so if he recommends any code it’s probably from that library, but he gives a lot of free advice here as well. )

Thanks I appreciate the help and tips on it. Yeah the Schlage lock definitely seems finicky in getting paired.

Just a quick update, I found the security QR code on the lock’s paperwork that came with it…odd that they didn’t put the code on a device sticker as well, oh well I guess. Unfortunately though, even after attempting to add it using the QR code, it still fails. One thing to note, when attempting to add it the first time after it being excluded and reset, the Hub and the Schlage lock stay in pairing mode for more than a minute, as opposed to failing quickly.

1 Like

If I knew that his DTH would resolve this issue, I’d definitely pay for access just to be done with this headache haha. This lock is getting closer and closer to be swapped for a Yale Assure with Z-Wave.

1 Like

Cool. I hate when they do it this way though. Most people don’t keep that paperwork. Fortunately you did so I would keep trying with scanning that code first .

Also make sure it is excluded from the ADT hub first, and the ADT hub is unplugged and off when you try and pair to the new hub.

The rboy lock dth is very nice and I use it and highly recommend it, but unfortunately it does you no good if you can’t get the lock to pair first.

Many of the lock manufacturers doit this way because they use the same case And they have interchangeable radio modules for zigbee, Z wave, Bluetooth, HomeKit, etc. in fact, for professional installs the cases are often bought separately.

I do think They should give you a sticker, though.

1 Like

That makes sense. I suppose it’s more secure to not have it on the device too. I just remember seeing that barcode when I first bought devices and had no idea what it was for. Fortunately my switches had the separate paper and the barcode on the switch. I have those papers still but have no idea which one goes to which switch. Now that I know more about zwave security I see how important it is to have that code.

You could complete the inclusion using S0 (use the scan nearby option) or click the cancel option when asked to enter the QR code to fall back to S2 unauthenticated.
I would also recommend checking the steps here which usually helps: