Scenes with single device

Do scenes only work with multiple devices?
I have a scene with only one device in it and it won’t do anything when I run it.
I’ve tried a single device scene because my recently added Xiaomi button only triggers scenes, doesn’t trigger individual devices. And I’m trying to figure out a solution for this. Maybe the button has the wrong handler (wrong firmware) don’t know.
P.S. I have Smartthings Hub V3 and the new app.

Thank you.

Based on your other post, are you saying you’re trying to use a zigbee button, paired to SmartThings, to control meross plugs? Just trying to get the full picture.

Yes, exactly that. And it works, but it only triggers scenes, if I add a single device to the automation settings, in this case a meross plug, it won’t work, if I add a scene it works, and turns the scene on and off.
The scenes are a set of the plugs.

Can you post a screenshot of both devices and how you’re trying to setup the button to control just one device, and not a scene?

Here they are. Hope you can understand, as they are in Portuguese.

Thank you. When you go into your button device, can you click where it says momentary and add in what the button controls? Like this:

This is how I have mine setup to control devices by themselves, not through Automations. I don’t see any reason why your method wouldn’t work, but this is worth a try. You can also try through the Smart Lighting SmartApp. What device do you want to control, the tv plug, and what do you want the trigger to be, the button. See if either of those methods give you a better result.

Ok, thanks.
Well, I’m not at home right now to check the light, but I clicked the “Momentary” small circle and It didn’t open no edit like you show. All it does is triggering the “click” event, meaning, it changes from “Standby” to “Pressed” and out of curiosity I opened the Meross app and the plug was ‘ON’, so I’m guessing the other way arround is the one not working, meaning, actually pressing the button.
Someone told me on another thread that for the new app the handlers might not work correctyl yet. May be because of that no?

If you login to IDE, what DTH is listed for the button?

Does this help?

Oh okay, you’re using his handler. Could be a problem with that handler in the new app. You could try in classic where I know his handler works better. Also… Could you create a scene just controlling the one device like you want? Just trying to think of a way it could work for you.

Well, I tried on a scene that only has that one device, and it does nothing. Even triggering the scene directly on the ST app console (clicking on it) it doesn’t trigger the device, simply doesn’t do anything. So that’s why I originaly asked if a single device scene won’t work. :wink:

You’re right, my mistake. 5 am here :upside_down_face: anyways, I would say to try your luck in the classic app. You might have better luck.

1 Like

A single device in a scene should work. Similarly a Xiaomi button should be able to activate a single device, not just a scene. There is something else happening. I don’t know what. Everything that follows is just background information about buttons …

In the ‘Classic’ environment, the button capability only defined ‘pressed’ and ‘held’, so if you wanted to handle things like multiple button devices or double clicks the typical approach was to add data such as a button number. So if the button was ‘pressed’ you could additionally check the button number to get more precise information (e.g button 1 means it was just a single click, button 2 a double click). That requires the app handling automations to know what is going on. WebCoRE knows this. I believe Smart Lighting does too. The Automation creator doesn’t. However it will still respond to a simple single press just fine.

In the ‘new’ environment, the button capability has been extended to understand multiple clicks. The automation creator knows this. I haven’t seen a button device handler that does and I don’t think Smart Lighting does either. WebCoRE can be made to understand by piston trickery.

The Xiaomi Button handler invents a ‘buttonStatus’ attribute for display purposes in the Classic app, so you can see if it was double clicked, for example, and you could also use it in webCoRE if you wanted. The new app can’t deal with that at the moment as custom capabilities haven’t been released yet.

The new app does understand composite buttons though. So if the device handler defines component child devices, it know how to work with them. The handler for IKEA buttons and remotes covers both bases by using button numbers and child components. The Xiaomi button handler doesn’t, probably because none of this stuff has been documented.

Generally speaking the issue with custom handlers and the new app is to do with the user interface being defined differently, and the odd quirk here and there in the settings. If you don’t need to use the new app to control a device, there is nothing to worry about.


:smiley: OK, no problem.
Thanks a lot man.
I’ll give it a try then :wink: Cheers.

1 Like

OK, thank you very much.
Something is wrong then. I have 4 scenes, two with 2 devices and two with only one, the devices are the same on all these scenes.
The devices are Meross smart plugs. And when I click on the scenes with multiple they execute what they are supposed to, when I click on the single ones nothing happens.
I might add that I think I’m having problems with the Meross / ST integration. It’s not working quite well.