Scene to change lightbulb color and turn off

Right now I use the smartthings home monitor. When it trips (which it does a lot due to GPS not updating I’m back) it turns a good amount of my lights on and red. After dismissing the alert my lights are still on and red. I’ve created a scene in the classic app that allows me to set the color temperature and turn the bulb off. I believe this is a glitch however it does work. In the new SmartThings app it does not allow me to do this moreover if I edit the scene in the new app it removes the color temperature. It also locks me out of the classic app of editing the scene since it’s now been upgraded. is there a way to do this in the new app since the classic app is going away?

Here is a screenshot of the classic app allowing me to set the color and turn the bulbs off.

“Color Temperature“ and “Color” are two different things. Color temperature is from warm white to cool white. Color is actual colors like red, green, blue. So the first thing is to make sure that you are using the right parameters.

You are correct. The classic app also does not allow you to change color and turn off. I’m cheating by setting the temperature. Basically I want my bulbs to reset to some form of white and shut off.

1 Like

You’ll need to sequence a couple scenes to do this.

  1. create a virtual switch l, lets call it security-reset
  2. create a scene that sets all of the bubs to the correct colors/temp. Also include that new virtual switch. And turn it on.
  3. create a second scene that turns off all the bulbs and the virtual switch.
  4. create an automation that when security-reset turns on it runs the scene instep 3 above.

So what happens is your first scene will set all the bulbs, and turn on the v switch which triggers the automation to then turn iff all the bulbs and the V-switch resetting it for next time.


Oh SmartThings sometimes you are so dumb. Sounds like SmartThings needs to be able to sequence scenes now that would be awesome.

I had to modify your solution just slightly. If I include the virtual switch in the scene in step 3. I could not use the scene in the automation because it conflicted with the if. So I removed the virtual switch out of the off scene and added it separately.