Samsung Speaker integration with ST Help

I’m not sure, but TTS (text to speech) was broken for all smartthings users for about a month, and they only said it was fixed about a week ago. It’s possible that there is still some left over issue with that.

Or as others have said it may have to do with the Samsung speaker integration itself, as there have been some issues with that.

My suggestion would be to get in touch with support and see what they say. This may be an issue beyond your control. Let us know what they say.

https://support.smartthings.com/hc/en-us

@slagle

Thanks @Jnick .Yes I’m still having issues with the my R7 & HW-J7500 speakers. Still no luck after having tried all options suggested in this community. I also reported the issue to the support team as well. If you see the screenshots i have attached, the ST is triggering the events correctly but I’m not getting any sound or TTS in my speakers.

Thanks @Mike_Maxwell I have been testing this integration from the beginning with the ST smartapp “Notify with sound” but no luck till now. I dont see the “Big Talker” app on my list.

Big talker is a community smart app, you have to publish it for your self.
Might be wise to see if TTS is even working on the platform currently, at least one of my TTS events didn’t announce yesterday, so it could be down for all I know.

2 Likes

Thanks @Mike_Maxwell . I will check with the support team to find out if there is an issue with TTS.

1 Like

@rajank11, No problem. There are a couple of “Gotchas” I found with the R-series. Unfortunately, I do not know if these apply to the HW-J7500 as I never used that. However, like I said, I do have a bunch of experience with the R1 & R3.

  1. Give the speaker a static IP via a DHCP reservation in your router. This is very important. It appears that there is something iffy with the integration with the Samsung MultiRoom speakers. Everytime the speaker gets a new IP (if left to standard DHCP), it shows up as a new speaker. Using the Samsung MultiRoom app, you can get the MAC address of the speaker, and then key it into your router with a DHCP reservation. This will ensure that the speaker always gets the same IP from DHCP, which will save you headaches in the long run.

  2. When looking at your speakers, chances are that you will see more speakers than you have (re: above). In my case, when I got my first R3 and attempted to pair it, it showed FOUR different samsung speakers. There are only two things that identify the correct speaker: The IP address (re: above) and the speaker status (paused vs stopped). You want to make sure you are selecting the speaker that reads “Stopped”. This is the correct and active speaker. All of the speakers that read “paused” on the list, in my experience, will never play audio.

  3. The samsung speaker has three modes, iirc. WiFi, Bluetooth, TV Bluetooth (or something like that). It is imperative that the R7 be on WiFi. The speaker essentially acts as a mini receiver. Think of each mode as an input because…well, they are. If you are using the R7 as a bluetooth speaker through your phone, you will never hear ST TTS come through. It doesn’t automatically switch inputs. The speaker must be in WiFi mode in order for it to output the audio from ST TTS. It’s very possible that everything is currently setup correctly on your end, but it’s just on the wrong input.

Because of #3, I wound up buying two speakers. an R1 for ST TTS and kept the R3 as a bluetooth speaker for my Echo Dot’s and other various devices. It appears that if you want Samsung MultiRoom speakers to always be available for ST TTS, you need to buy dedicated speakers for that purpose. They are not dynamic enough to switch inputs when an event occurs.

Again, these are my findings. They may not be the only way to skin the cat, but this is how I have set it up in the past and it is still working today. :grin:

Hopefully this helps you! If you need anything else, just tag me in a post.

[EDIT] It is to also be noted that I am using BigTalker for all of my TTS; amazing app! I do not use the ‘Notify with Sound’ SA. I can also confirm that TTS is working on this end. Everything seemed to be back in order once the support team sent out the “All clear” message.

[EDIT2] Tagging @sam_alian because the first three pieces may help him as well.

3 Likes

@Jnick , Thanks for your detail explanation on this issue. This really helps. I feel some of these points should be added as a reference for any new users like me who had brought/planning to buy samsung speakers to integrate with ST. This will save lot of time for many people by educating the limitations.

I gave up on the ST “Notify with sound” SA & it never worked on both of my speakers. Finally as per you and @Mike_Maxwell advice i installed the “Big Talker” and tested out the TTS. I was happy to hear the TTS on my speaker finally. It works flawlessly. :slight_smile:

During my 2 weeks of playing with the speakers i have also noticed your point # 2 and #3. I have not tried #1. I will assign a static IP for my speakers.

Thanks @Jnick and @Mike_Maxwell for helping me out on my issues and answering all my questions. Thanks for your time.

4 Likes

@rajank11, no problem! Glad you got it working!

I just got an r3 on clearance for 120 because I heard they have been officially integrated. I can connect with Bluetooth and it seems to find my tv with WiFi but I can’t get ST to recognize the speaker. I’m adding through the marketplace under speakers and nothing. I tried pushing the grey button on the bottom and nothing. It was an open box item so I’m not sure if I need to un pair anything. Any advice before I take it back. I just kind of wanted it for a portable backyard patio or office speaker.

@Cody_Farmer Just got one too. I ran in to a little trouble as well. What I think worked was that I pressed the mode button until it said “wifi” and then ST saw it. I don’t know if it mattered but I also installed the Multiroom app. I think the button at the bottom is for pairing with other speakers.

Liquid is correct. The speaker must be in WiFi mode in order for SmartThings to detect it. That goes hand in hand with the fact of the static IPs being required to have less headaches.

I had one R1 and paired it with ST (although not right away). I then got a second speaker and tried pairing it. Didn’t work. Now I foolishly removed the first speaker. What I left now with is two R1 speakers and no matter what I do they would not pair. I reset router, and hub and did all kind of things. No luck. So the question is can we add speakers to ST directly from IDE? or some other way?

And also, can you guys look into your IDE and see what kind of network ids your speakers have?

I Just got an R1. Following the footsteps of others I made sure I could connect to the speaker through the Samsung app, I am on the latest firmware and I even assigned a static IP address.

Still nothing. Any other ideas?

It is super tricky. I currently don’t use it anymore but if I can find the time I’ll try to set it back to factory and re-pair it. Hopefully, @JDogg016, you’ve figured it out already.

No. I’ve even moved the speaker closer to the hub with no luck

Sorry @JDogg016, I thought you were having an issue connecting at all. So you want to have the Smartthings app see it? So you can use the speaker normally right?

Yes, but cannot use it in ST as ST will not recognize it.

My ST integration has been solid close to an year now except for one occasion. Main problem I used to face with this is the Samsung App not detecting them from time to time forcing me to add it to the app manually multiple times. I suspect the WiFi strength is an issue even though I have other equipments much further from this working perfectly.

On the ST side, just clean everything out and try fresh following the posted process. Hopefully it should work. Check in the IDE if the DH is proper “SamsungAudio”.

1 Like

I am still seeing this issue.
Any advise?
Support was not good saying the Samsung Speakers are not supported.

There may be options, if you are using the Classic App and a Samsung WiFi speaker or soundbar.- depending on the speaker model. WHAT speaker / soundbar model are you using? There is a custom solution at

This integration supports all the Radiant speakers plus (by design), the following soundbars:
HW-MS650
HW-MS6500
HW-MS750
HW-MS7500
HW-J8500
HW-J7500
HW-J650
HW-H750
HW-K650