Samsung SmartCam: SNH-P6410BN, SNH-E6440BN and SNH-1011ND (+WWW Digest auth) (tested and working)

That sucks …wasn’t the case when we bought them … so no way to gey static jog snapshots any.longer. wonder if they’d take returns

@Matt_LeVan that post was super helpful as I had been pulling my hair out trying to figure why all the stream links that I’ve found for the HD Pro weren’t working for me.

In order to get this working with MJPEG I’ve found that VLC will transcode the RTSP stream and present it to other applications as an MJPEG stream. Check it out here: SmartTiles: Video Camera Compatibility

Got it to work with Samsung SNH-E6413BN from Costco.
Note for everyone:

  1. use the code provided from :
  2. /cgi-bin/video.cgi?msubmenu=jpg&resolution=2 (use this as the path, resolution=2 will make the image smaller and easily to upload to Amazon S3 cloud)

I got it to work, please refer this post.

I can not find where to go through steps 6 and 7. Can someone help out a fist timer?

Immediately after adding the device, click on the “Edit” link next to the “Preferences” entry in the table.
7.Populate settings: a) Camera IP Address (192.168, 172.1x or 10.x.x.x works fine too) b) Camera Port (usually 80, but can be anything you like) c) Camera Path to Image, when it comes to SNH-P6410BN, use: “/cgi-bin/video.cgi?msubmenu=jpg&resolution=2”.

tl;dr: if stw-cgi/video.cgi is still working for you and you don’t want to lose it - do not upgrade your camera. I’ve checked SNH-P6410BN only, but most likely other models will follow that path very soon.

I’ve checked their most recent firmware - 1.07. Unfortunately, they have removed all of the www access to the camera. However, the firmware still has the files, but it’s not available via www. lighttpd is pointed to www/htdocs, but htdocs is symlinked to htdocs_weboff. There is also additional htdocs_webon folder with all of the content and pages that we are familiar with from previous versions, but it’s not accessible via web.

There is one mysterious url/file that I’m inspecting: www/kxmzoa11/xpzmdnls09woskxm20/dnpqtjqltm . Looks like random set of strings, so I’m curious what they are trying to hide. :wink: It may be just upnp client that camera listens on, but it’s not a standard one as far as I can see. For example, it has SetWebServiceMode method/variable that potentially produces “======== Change Webservice Mode %d, %s ========” output. It’s possible this is used by developers to debug and switch back to the htdocs_webon folder, but actual probability of it is very low.

Here are all of the available urls as of now if you want to play with it (version: 1.07_151030).

note: default username and password is: admin/4321


… and SmarTthings RESTful api endpoints …

In short: if stw-cgi/video.cgi is still working for you and you don’t want to lose it - do not upgrade your camera. I hope they will revert this change as a lot of users are already complaining giving pretty negative comments at amazon for this camera.

Another option would be to build a custom firmware for this thing. I know how to do it, just don’t have enough time as of now.


When you “add a new device”, once you finished adding, if you go into the device that you just added, you will see Preferences on the page.

Hi Greko6,

I own 6 of these cameras and were using them with my Synology NAS Surveillance Station. Unfortunately I updated all camera’s to v1.07 firmware and lost local IP access.

I tried to contact Samsung customer care but their reply is not helping in any way:
“regrettably, due to the new firmware for the smart cam, the ability to
use the Synology NAS system or access them via IP address has been
removed & even so, once a firmware has been upgraded & installed, the
ability to revert to a previous version is not applicable”

“Again, we apologize for this mishap but the feature of the local ip
access for the smart cams has been removed & there are no ongoing
discussions to revert back or re-implement this feature.
Additionally, the option to revert back to a previous version of a
firmware is not applicable as well”

I would appreciate your help if you can think of any way to return to the previous firmware or modify the existing firmware to access existing www files.

That’s pretty sad…

Can you switch Synology NAS Surveillance Station to use rtsp protocol? If so, there is a way for you to get the video stream.

I can use manual camera configuration and use RTSP profile path (/profile5/media.smp) but I loose voice.

Also any control of framerate for liveview, recording and mobile are lost. All these parameters are based on their specific Samsung api implementation that is lost with latest firmware.

I desperately need to downgrade the firmware or hack it :frowning:

1 Like

My SNH-E6440BN (outdoor camera) is still at firmware v1.00 so it still has the local access page, but I can’t get these links to work. I am trying to disable/enable the motion sensor, but It just gives me a bunch of warnings like:

Warning: unpack() [function.unpack]: Type A: not enough input, need 1807, have 547 in /work/www/htdocs/cgi-bin/adv/va.class on line 29
Warning: unpack() [function.unpack]: Type A: not enough input, need 5, have 0 in /work/www/htdocs/cgi-bin/adv/va.class on line 124
Warning: Invalid argument supplied for foreach() in /work/www/htdocs/cgi-bin/adv/ on line 209

I’m guessing there’s more that needs to be included in the request? Like maybe sensitivity level?

FWIW, there are several other links/APIs that appear to work fine. For example, I can get information from:

  • /information
  • /users
  • /device
  • /device/network
  • /device/network/aplist

if I do /cgi-bin/event.cgi?msubmenu=analysis, I get the NG response. Not sure what this means?

Anyone have any luck changing motion sensor settings with these URLs?

Has anyone had any luck getting the SN-V6414BN working? Purchased from Costco the other day to give it a try. Camera works great using SmartCam app, but I can’t get V2 to see the device. Suggestions??

I just bought the same camera please let me know if you figure it out

How were you able to get into this firmware to poke around? Also, do you have a copy you could share?

I have the SN-V6413BN from Costco and can’t get it to work with ST either. At one point I was able to get a partial picture through ST (top 1/3 of the pic would show up when I hit “take”), but now it doesn’t seem to be working at all even though I haven’t changed anything since it partially worked.

I have noticed the same thing. I’ve been unable to get a picture from my Costco camera for the last couple of months. I haven’t really looked much into it. My other two older Costco cameras still work fine with the same device type code. And the software version on the new camera seems to be unchanged. Maybe time for a hard reset on the camera…

So, it seems like the SNH-E6413BN Smartcam’s just dont work on Smartthings V2. Please let us know if this is true.

Does anyone have any tips for getting IP based access back for the SNH-E6410BN? Either a way to roll back to the 1.06 firmware or to hack the 1.07 to restore the functionality? I’d be happy to give it a go - but firmware isn’t something I have experience with…

Unfortunately I could not figure out any way to downgrade the firmware. I saw some hacks in YouTube to get root access to the camera but it does not work with the latest firmware.

I am also desperately looking for a solution to roll back the firmware but could not figure it out yet.

Can you send some screen shots of the configuration page? I tried this config with the SNH-E6414BN form Costco and it did not work.