Samsung S7 Edge as presence senor


(Mitch Turner) #1

Hi All,

im not sure if this thread has been mentioned before, but im having problems on a weekly basis with the Samsung Phone. My Wife has the Samsung S7 Edge, and on a regular basis the Smart Things still thinks she is present and therefore it does not activate some of my routines i.e. away or Back.

Now the strange thing is I have the Iphone 6 which works flawlessly all the time, in fact so good that its never had the above problem. My mum also owns the Iphone 5c which again works perfectly. Is there some setting in the Samsung which im not aware of? If anyone can point me in the right direction will be great.

Find it weird that and Iphone works better with a Samsung product than a samsung!!!


#2

My S6 has never worked. It apparently arrived on the 17th September when I set the system up, and hasn’t left.

Im at work, looking at the smartthings app on my phone, and it says my phone is present at home. Location services are on.


(Mitch Turner) #3

Why is this on the Samsung device, I wonder what is different. Pretty much makes it unusable presence sensor really.


(Jerz Dude) #4

I have the Samsung Galaxy Note 5 (released about a year ago) and it works flawlessly. I also have the girlfriend setup on life360 (or Friend Locator I think is what it’s called now) and that works great on her iphone so she didn’t need to run smartthings app.


(Stephan H.) #5

I have the S7 Edge and it works perfectly. I did have issues with my wife Note 5 once. I believe I fixed the issue by uninstalling the ST app from her phone…Removing the mobile presence sensor from ST… Reinstalling the app and re-adding her presence sensor. It has worked flawlessly for the both of us since.


(Dan P Parker) #6

Ditto. I did have to drop and re-add the phone device when I upgraded from my old S4 to the S7E, but no problems since then.


(Bob) #7

Disable battery optimisation.
Worked for me.


(Jason "The Enabler" as deemed so by @Smart) #8

You can adjust try life360, that’s been so much better for me.


#9

You can use a connected fire-and-smoke detector as a proximity sensor for the Samsung S7. :sparkler:


(Kevin) #10

That would be a Samsung Note7 with the exploding battery issue… http://i1-news.softpedia-static.com/images/news2/explosive-start-for-samsung-galaxy-note-7-more-phones-catch-fire-while-charging-507793-2.jpg


#11

@bobbles did you disable battery optimization completely? Or just for SmartThings app?

Haven’t tried uninstalling/reinstalling the ST app yet. Worried I’ll have to redo my configs.


(Bob) #12

I just disabled it for everything.
It hasn’t impacted on my battery life.


(Donovan ) #13

I have the same problem with my S7. I’ve tried everything and still not working correctly. It opens my garage in the middle of the night thinking I left two or three times a night. Had to undo that routine from that phone. Hooked it up to another phone and it works perfect. So I don’t have a clue… Thinking it is a S7 issue…


#14

Unfortunately this is an issue with the Samsung Android OS memory management, which is a core OS level problem.

See my post here.

I’ve tried everything except rooting and nothing fixed the issue.

My ultimate solution was moving to iPhone 7 Plus. Rock solid so far from day one, not just for ST presence but for all my geofencing apps, which was never the case for any of the recent Galaxy phones I’ve owned.


#15

Extremely annoying issue for sure, which is why I followed the advice of several forum posters to start using Life360 and since doing so, presence has worked much better.


(Donovan ) #16

Ok I might have fixed this issue for the S7. This seems to be working so far. pull down the setting screen long press the location and you will see Improve accuracy. press that and you will see Wi-Fi scanning and Bluetooth scanning turn both of those off… This has nothing to do with you connect to your Wi-Fi at your home you can still connect via Wi-Fi. This is working for me so far give it a try and let me know if it works for anyone else.

Good Luck!!!


#17

I tried this and the issue came back after couple days. Hopefully you have better luck than I did.


(Donovan ) #18

Just like clockwork, a few days went by and it did it again… This time I made my Geo fence a little bigger so I will update in a few days.


(Stephen Crescenti) #19

I am having the same problem with my Galaxy S7. Has anyone with the issue found the right fix yet?

This is what my phone looked like over the past 12 hours:

Arrived - 5:09pm
Left - 5:32pm
Arrived - 6:38pm
Left - 6:50pm
Arrived - 7:21pm
Left - 7:27pm
Arrived - 7:32pm
Left - 7:41pm
Arrived - 10:44pm
Left - 4:03am
Arrived - 5:01am

I just updated my settings to remove wifi and Bluetooth scanning and will update shortly.


#20

Well, at least I know I’m not the only one. Will try bluetooth and wifi scanning off in location settings and if that doesn’t work I’ll try Life360 I guess. This is ridiculous. My S5 never did this. Do HTC or LG phones have this issue? If not I know where I might be going next.