Samsung Multipurpose Sensor STS-MLT-250 not pairing

I purchased two of these Samsung Multipurpose Sensors. They showed up in what looked to be Samsung boxes. They have an odd part number. STS-MLT-250 while googleing the problem it seem s the P/N should be a US-MLT2 or something to that effect. Are the MLT-250 new? I tried doing like the directions say to pair, I first brought the sensor within 3-4 feet of the HUB and used my app to turn on the pairing more. While it started to search I pulled the piece of paper out. I waited about 2-3 minutes and nothing showed up. I also tried to remove the battery, and reinstall it. According to the directions it says to hold the button until it turns red. The light only blinks blue. If I hold the button down and install the battery the light turns yellow for about 2-3 seconds then flashes blue again. I don’t even think it blinks red at all. Do I have bad directions? I find it hard to believe I have two DOA units.

Hello - I have the same problem with the same model device that I just ordered about a week ago. Did you find a solution?

Sometimes the light will blink green. It may blink blue or green to start with, then switch to green. I’ve tried removing the battery and starting over. I’ve tried various permutations of the instructions. Nothing has worked.

Any ideas would be appreciated.

Sorry been on vacation. I think I ended up removing the battery and holding the button down then inserting the battery. Took me a couple of tries but got it. In the end I returned these because they did not work with Samsungs own laundry smart app.

Posting here for the benefit of anyone else having this issue. What I ended up doing was contact smartthings support chat ( and they checked my hub v1. Apparently it’s Zigbee firmware was out of date, which apparently the hub firmware and the Zigbee firmware on the hub are separate, and there’s no way for the user to check the Zigbee firmware. Support however was able to push a Zigbee firmware update to my hub, and then pairing worked just fine, as documented here:

You’re welcome.


I have a V2 hub. Not sure what Khalid has.