S90C TV SmartThings Hub capabilities? Can't get Matter to work over Thread or Wi-Fi

Hello! I recently bought a S90C TV, and it apparently has the ability to act like a SmartThings Hub. However, it doesn’t work as expected for me. When I “install” the Hub on the TV, the description says the following:

IoT devices (such as lighting, outlets, door locks, sensors, etc.) can be used with SmartThings Hub. In the SmartThings app on your mobile device, you can connect IoT devices. It also supports Matter standards, so you can connect various Matter-compatible IoT devices together.

If you sign in to the SmartThings app on your mobile device with your Samsung account registered to SmartThings Hub, you can check the device connected to TV.

Wi-Fi, Zigbee and Thread Module Available

This suggests that the TV should be able to connect to Matter devices over both Wi-Fi and Thread.

However, when I try to add my Matter-over-WiFi outlets to the hub via the SmartThings app, the app tells me that:

Your hub in My home doesn’t support this device.

And it does the same thing with my Matter-over-Thread outlets.

When I look up details for the hub via my.smartthings.com, it gives me the following metadata:

  • Firmware 000.047.00011
  • matterAvailability = Available
  • threadAvailability = Unavailable
  • threadRequiresExternalHardware = false
  • zigbeeAvailability = Available
  • zigbeeRequiresExternalHardware = false
  • zwaveAvailability = Unsupported

But in the Thread section, it says “This hub does not support Thread.” That’s confusing: why is threadAvailability “Unavailable” instead of “Unsupported” like Z-Wave? And if Thread is actually unsupported, then why is threadRequiresExternalHardware set to false? I feel like there’s a software issue somewhere. Like, did somebody forget to enable the Matter/Thread config for the TV’s hub firmware?

And another thing: this Samsung page certainly implies that this 2023 TV should have Matter and Thread support without using a SmartThings Dongle, though it’s not 100% clear.

Anyway, I’m confused. Based on what I’ve read, the hub should at least support Matter, and it should probably support Thread; but I can’t get it to work with any Matter devices, Thread or Wi-Fi. Anyone have any luck in this area?

First, I just want to let you know I’m not a developer or someone more technical savy with the whole SmartThings ecosystem like many others on this community. But I think I can help a little bit.

I have the S95C the next step up from the S90C and it also has this built in hub capability and I just tried to add a Matter device to it. It is only a Wi-Fi Matter device, but it did add it. I had to add it via the scan function though as it then asked for the hub I wanted to add it to and worked. Just trying to add via the “Ask to add new devices” pop-up option didn’t work as it didn’t allow me to connect to the hub.

I did have a thread device a few weeks ago that I added, but to a different built in hub (Refridgerator w/Family Hub and I added the SmartThings Dongle for Zigbee devices). Sadly the thread device died in less than 24 hours, so it got returned to Amazon. It was my first ever Matter and/or Thread Device as I’ve never used Matter or Thread before.

I did check like you though, as I have 3 devices with built in hubs. The Refridgerator, the TV and the HW-Q990C Soundbar and all have the 000.047.00011 firmware. The TV is the only one without thread capabilities, but I think the “Unavailable” vs “Unsupported” means that it just hasn’t had the update yet to enable thread. But I could be wrong and others within this community know more about this than me.

P.S. Once when I had to reset my Refridgerator hub due to connection issues due to a driver causing my hub to disconnect, after I reset it, it had the Z-Wave logo pop-up within the SmartThings App when I looked at the hub. None of the built in hubs are supposed to support that protocol. So I have seen bugs in the SmartThings app give false info before as well. So just a heads up.

1 Like

Thanks for the anecdote! Odd that it works for you but fails for me. Just in case, I tried adding my Kasa outlets using a different phone and still get the same error message.

Could you check what drivers your S95C SmartThings Hub has installed? On iOS, SmartThings app → tap on hub → 3 dots in corner → Driver. Is there anything Matter-related on that list?

What model Kasa outlets? I’m just curious. I can’t really help diagnosis based on model or anything, but I added the Kasa Outlet model KP125M. So I wondered if you have the same model it should work in my opinion. I’m on Android though not iOS, the driver wasn’t installed on the hub until I tried/succeeded to add the Matter device. Anyway here is a screenshot of the Matter Switch Driver installed on the hub:

1 Like

Thanks. Yes, I have the same model, KP125M. My hub does not have any Matter drivers listed; wonder if there’s some way I can install this one manually. Also, if I try to scan the QR code with the outlet unplugged, it gives the same error message. So perhaps it never even tries to connect? An iOS app issue?

Maybe I’ll try with my roommate’s Android device tomorrow.

My other hub (soundbar) doesn’t have the driver so I do know it installs it while adding it. I didn’t scan the QR Code though I enter the numerical code manually as where it was located I couldn’t get my camera in the right angle to scan it. I would try that as a possible solution. Do you have more than one outlet to try? I’m wondering especially if you got a multi pack if they put the wrong code on the wrong outlet. So If you had say a 2 pack maybe try the to plug in the original one you had and then scan the other code or input the other numerical value manually. I had an error at first when I did it, but it said something about this is the incorrect device please check your number and try again. Not the exact same error you had where it said your hub doesn’t support this device. I wonder if this is possibly the same error just worded different due to you having an iOS device and I having an Android one. I do know even though it’s the same app it’s coded differently and has some other differences between the 2 OS’s. One of these differences is many Android users have a problem with device limits even Samsung owners, which SmartThings is a part of Samsung; where iOS owners can have almost unlimited devices.

1 Like

OK, I’ve now tried:

  • Adding the code manually. No dice.
  • Going to the Kasa app and using the code for one of my Kasa-paired outlets via “Matter Setup Code”. Nope.
  • Joining the “SmartThings Drivers (Beta)” channel and installing the “Matter Switch” driver manually(!!). Still the same error!

Needless to say, very frustrating. If only the error said something more useful. There’s a section in the app for “Offline diagnostics” but it seems to have nothing in it.

For posterity, an error report can be generated in the SmartThings app like so:

(Menu->Contact Us->Error Reports->Tap on the “Error Reports” heading 10 times. when ‘Create a log?’ appears tap OK.) This will generate a log file which can be directly attached and sent via email.

The offline diagnostics is for devices that are within SmartThings that have lost connect (say your TV loses Wi-Fi you’ll find it here till you get it reconnected). If the outlet is not install you won’t see it there. I just did a test though. I added the plug successfully and then deleted it. Then I tried to add it again without resetting the plug and got an error (see screenshot below). I then reset the plug and tried again and it re-added it. So, I think it maybe a case of it already being setup (especially if you have it setup with the Kasa App already) it won’t pair with another app. I don’t have the Kasa App setup yet and I think SmartThings has to be the first App you are using if setting it via a SmartThings hub, but don’t quote me on that I’m not sure if this is correct, it’s just my opinion. If you don’t have anything important setup within the Kasa App and are willing to reset the plug (keep in mind SmartThings doesn’t allow for the energy monitoring of this plug) reset the plug by holding the power button until it “Fast Flashes” not slow and then try to add it to the hub. As for that Beta Driver you downloaded, from what I can see you seems more defunct now for the average user, especially since the main SmartThings developers have a driver that is no longer in beta. I would just delete that driver as it probably doesn’t serve a purpose anymore.

P.S. The “Contact Us” error report doesn’t usually get me anywhere. You can try it, but I always just get a reply from low level aka tier 1 outsourced tech support that has you do the stupid; uninstall the app and reinstall, did you restart your phone, etc. thatbis of no help and just a waste of time.

1 Like

Thank you for the help so far! Very useful, haven’t found anyone else going through this flow.

To be clear, I tried to add two outlets: one unpaired one, and one that was already paired in the Kasa app. Will try again in “fast flashes” mode.

The support person I’m talking to seems to at least be gathering system logs (which is where I got that tip), so maybe they’ll actually figure it out. Fingers crossed… (though I’m gonna go poke around in the logs myself)

Your Welcome. Hope you get it working. Just saw your post and I never see many others on here talking about actual Samsung devices much and have dealt with them, especially the TV as I have a similar model. One note if you use the TV SmartThings App not the Phone version make sure your HOME, DEVICES, and ROUTINE names don’t have an apostrophe in them like I had at first “Michael’s TV”. The apostrophe breaks the SmartThings routines and device control within the TV version of the app. I had to change it to “Michaels TV” without the apostrophe; same with all my other homes, devices, and routines. This is one error report I sent in to the “Contact Us” and at first all they said to do all the basic stupid steps. I replied with another update when I found out it was a syntax error within their program and all they said is; well if it works without the apostrophe just don’t use the apostrophe. We aren’t going to go through our code and fix it as it isn’t an issue now is it.


From a cursory, non-expert look at the logs, it seems like things might be failing because:

2023-10-24 21:47:54.641 [com.apple.main-thread:16448544] I HubUtil(23):pairedDeviceId(_:) - [ST] can not find pairedDevice, hubHardwareId: Optional("D052A8C5A0E40001")
2023-10-24 21:47:54.642 [OnboardingEntrance:16557110] E OnboardingEntrance(535):beginInitiator(preparation:completion:) - [OnboardingEntrance] error: singleUnsupportedHubIn("My home")

It can’t find my hub? Which is weird, because I can tap on the hub under Devices, check out its settings, etc.

A few last things you could do are one reboot your hub via SmartThings Web Interface, two hard reset the TV (not factory reset, you can do this 2 ways. One by unplugging the TV waiting 30+ seconds and replug it in or two you can also do this by turning on your TV then hold the power button till you see the OLED logo. You won’t lose anything it just reconnects it to Wi-Fi and reboots the Apps) or if you don’t have anything else on your hub, you can delete the hub from SmartThings and re-add it. It may have corrupted during setup. I’ve had this happen multiple times on my soundbar and resetting it by deleting it and then re-addeding it fixed the issue. But I only have the Philips Hue Beta Edge Driver installed and don’t have many devices to re-add. Again do this last thing as a last resort.

1 Like

Yeah, I’ve already tried all these things. :frowning_face:

Maybe I’ll try deleting and reinstalling the hub on the TV a few more times…

I would have to say it is probably the Phone App then; I can’t say for sure. I’d try like you said your friends Android phone and see if that works. It could also be something that just hasn’t got fixed yet on iOS. The Android App just got updated this week. So iOS maybe updated soon if this is the issue and that fix will be included. Hope you the best in getting this situated.

Funny side note: after reinstalling the TV’s hub module, I went to check back on it in http://my.smartthings.com… and now its threadAvailability is set to Available, and there’s a Thread network named ST-TIZEN. Firmware is still 000.047.00011. Er. I guess Thread is supported after all…???

It could also be something that just hasn’t got fixed yet on iOS.

I wonder if this is the answer. The app hasn’t been updated in a month on iOS, and there’s stuff in the logs about 404 error responses to requests to e.g. https://client.smartthings.com/amigo/tariffs. Hmm…

Anyways, time to sleep. Hopefully something will work tomorrow.

probably not a good idea to keep resetting the hub. Generally when there is an issue for the user - a reset will not resolve the underlying issue. Plus, if you are working with support, you are wiping out logs that could help them diagnose the issue. :slight_smile:

That’s fair — although in this case resetting the hub apparently gave me Thread support, somehow. :sweat_smile:

1 Like

Update: tried with an Android device and it worked! So there’s gotta be a bug in the iOS software.

1 Like

Glad to see you got your Hub to accept your Smart Plug, but I got a question for you now. You said at first you didn’t have Thread availability; you said that your hub said it was Unavailable and saw a message at in the Thread section that said, “This hub does not support Thread.”. I was wondering since you readded your hub and got Thread to finally work has it stayed that way; do you still have Thread capabilities still to this day. I ask as I did the same as you and uninstalled my Hub and Reinstall my TV’s hub module and I got Thread to show up as Available. I had nothing at all on my TV’s Hub, I just want it within SmartThings for Firmware upgrades and in case I were to use it in the future, so I didn’t lose anything by deleting it (other than possible logs).

The problem I’m having is after a short while (random each time), when I go to check it again it has lost the Thread network, and it doesn’t selfheal like Thread is supposed to do. The only way I can get the Thread network back is to Uninstall and Reinstall my TV’s hub module over and over again. This seems to be only affecting my TV’s hub module, as I haven’t had one problem with my Soundbar losing its Thread capabilities and if my Refrigerator loses its Thread capabilities, I just have to reboot the Family Hub’s Screen and it comes back online.

The other issue I seem to have, and this is a problem with all 3 IoT Built in Hubs; the “Reboot” Hub feature within the SmartThings Web Interface doesn’t seem to work for these style hubs. I don’t know if this is by design or if it’s a bug. But will probably start another topic about it later.

1 Like