Routine vs Scene running on hub

So recently (maybe when edge transition happened?) some of my routines started showing up with the little house logo with the check mark. There was a footnote saying these routines run on the hub and not the cloud….bla bla bla.

Awesome feature.

I have a bunch of light switches that all do the same things at the same times. I did have each light have its own routine……and all routines had this house check mark logo.

I decided to do some spring cleaning and combine some of these routines into scenes. In doing so I reduced like 15 individual routines into 3 scenes.

HOWEVER….these scenes don’t have the house check mark logo. Does that mean my spring cleaning is now forcing my light switches to be controlled via the cloud rather than directly from the hub???

1 Like

I don’t think the house logo is being used for Scenes yet. None of mine show it in the app yet in the API they are all flagged as executing locally.

Although Scenes can run locally in the hub, I don’t think the Rules action to execute them does.

Update: I am going to qualify my first statement. My Scenes all have the executionLocation property set to Local and that was the basis of my claim, but the metadata section has an executingLocally property and that is set to false. Make of that what you will.


As a test I could make a routine like: “if switch is on, run scene xxx”.

Then unplug my internet modem and flip said switch.

This would tell me if it is locally run or cloud run….right?


look at your scenes in Advanced Web App (Scenes) :slight_smile:


Thanks for the tip. Added one light controlled by c2c and it reverted to cloud. Took it out, reverted to local. finally! for scenes local execution!

1 Like

The problem is we can’t be entirely certain that it is full local, since if I set a local routine itself triggering a local scene, it still marks as cloud [for the routine]?

If it runs when you’re not connected to the Internet, it’s local. :wink:

1 Like

true, but can’t test this at the moment…

1 Like

Just tried. unfortunately it is cloud. Had disconnected the modem ethernet cable to test. Also tried with a device; device did work, but not the scene.

I created some virtual switch momentary buttons to use as “scenes” instead of using scenes so I could have local operation. Then I just made a Room called “Scenes” to keep them in. Perhaps that is a solution for you.

1 Like