Routine to turn on the wind free AC unit doesn’t work

I have created two routines as a test to turn the AC unit to heat when the temperature falls below x temp and and turn it off when the temperature falls below y.

The routine to turn on the unit if the temp falls below a set threshold doesn’t work. I tried a number of conditions. Here’s a sample:

The routine to turn the unit off when the temp threshold is reached works fine, but of course only triggers after I turn the unit on manually as the routine to turn it on doesn’t work.

Am I doing something wrong?

Is the temperature above 23 C when you save the routine?

1 Like

No it’s below it. Which is where I’m aiming it to turn on. And as it’s an automated routine, I’d expect it to run repeatedly really

I believe the ‘equal to or below’ condition in Routines is set to only trigger the Routine on false to true transitions. Also the ‘For 1 minute’ may not be latching (which I believe means it only returns true once). So it might be that the Routines aren’t behaving how you expect them to and you have to initialise things yourself.

I’m not so sure about the “equals or below” but equals or above definitely doesn’t work on change. As even if the current temp say is 25 and the condition is 24 or above when I enable the routine, it works. Unless it’s just the “equals and below” specifically that works differently.

I’ll see if I can reduce the temp by opening a window to make it transition into the condition and see if it works

Another troubleshooting step I do when Routines don’t seem to be working right is to add a Notification to the Routine. That way if I get the Notification, then I know the Routine conditions triggered and that it is something in the Action I’m setting that isn’t doing what I want.

I had a thermostat in the past that would occasionally not take multiple settings every time. So I had to split the Thermostat settings into multiple Actions to make that thermostat set all of the settings I wanted every time. Nowadays with my current Thermostat, I leave the Temperature set and the Fan in Auto since that’s the default anyway and I just set the Mode setting to either Off, Cool, or Heat (my Thermostat doesn’t have an On mode).

Have you reviewed the history for the Indoor Temperatures sensor to insure it is transitioning from above 23 deg to equal to or below for at least 1 minute

My house thermostat most of the time takes a long time (several minutes if not more) to display to actual temperature in SmartThings.

Well… I don’t believe the Samsung AC has any viewable temperature history viewable in the smart things app…

It just shows the current temp:

I also played with lower temperatures and tried lowering the temperature in the room to make it transition and remove the 1 minute wait. Nothing happens. It’s like it… just doesn’t work.

Examples with thermostats sound as if people are using temp readings outside of the AC unit itself. I don’t want to do that. I polled the api and the readings return for the current temp… so it’s as if this smart things app routine thing is… not working. Maybe I should just program it myself in Python as at this point with the amount of time spent trying to make it work natively…

You might be able to see the history in the global history. Select Menu in the app and the select history. Hopefully the history is being recorded there.

Thanks - just had a look. Clearly it hasn’t been getting activated since I last ran it manually even though it was left enabled all weekend :disappointed:

Annoying I tried setting up the same automation via HA and it isn’t working either. Thus I still wonder if there’s a flaw in my logic somewhere.