Rinnai Water heater now integrated with Smartthings! (Question...)

Everyone still connected? If so I’m looking to buy one of these…

So I should keep using the old app until they get the firmware corrected which could be March? Thanks!

I’m only going by what they told me. As of right now, the old app is working for me and the 2.0 app shows the water heater as disconnected. Also, in the 2.0 app, when I click on the heater on the “control-R info” menu item, the app crashes.

With the old app and the Alexa control-r skill, I can start recirc, set temp, etc via voice.

I have a new heater with the new app. The iOS app crashes regularly, the SmartThings app seems to disconnect regularly. ActionTiles seems to work for setting the temperature, but not starting recalculations. SmartThings Homebridge V2 seems to not expose the temperature settings to Homekit. All in all, not working very well yet, but it is working maybe well-enough.

So, I have an update and story regarding the Control-R to Control-r 2.0 app migration.

Last week while I was traveling, my water heater went offline. When I got home, I found that it was trying to connect to Wifi (flashing red/blue) and would never connect. It had been previously working fine, so something must have changed. I later found out that a new version of firmware had been pushed to the Control-R unit. Since it wasn’t connecting, I did a factory reset in an attempt to reconnect to the wifi. With the old Control-R app, it continually failed indicating that it couldn’t find “Rinnai networks”.

At this point, since it was dead in the water anyway, I decided to try it with the new Control-r 2.0 app. I intentionally differentiate using capital “R” vs lower “r” because that is how support refers to them. With the new app, I was able to get connected to the controller’s configuration wifi, however, it got continually stuck in the “Software needs to be upgraded” loop even though I went through the upgrade process several times. I could never get to the point where I would select/enter my wifi information and password.

Called support the next day and they provided me with an alternate way to configure the wifi network and password outside of the app using a web browser. With that, I was able to get the controller on the wifi and they were able to push version 2.27 to the unit (which is the latest).

One thing to note is that if your water heater was previously registered to your account in the older app, it should appear in the new Control-r 2.0 app right away after using the alternate config method. However, if you are setting up your water heater for the first time (or managed to delete it from your account somehow) and have gotten stuck in the upgrade loop and used the alternate method to configure wifi, support will need to MANUALLY associate your water heater with your email address/account once your controller has connected to the Internet.

Now, that being said, here is how things are working with ver 2.27:

  • Able to adjust water temp using the app and it stays the temp I set
  • Able to manually start recirc using the predefined time intervals using the app
  • Able to see flow/temp information in the system status page
  • Able to add recirc schedules HOWEVER, they don’t appear to be executing as configured
  • Able to add the Control-r 2.0 skill to Alexa and voice trigger manual recirc
  • Able to create an Alexa routine using custom actions to remap voice command from “Alexa, tell control r I need hot water” to simply “Alexa, I need hot water”. You could shorten it even more if you like or make it something completely off the wall :slight_smile:

I haven’t tried any ST integrations such as triggering recirc using motion, a contact, or a switch status. It’s not clear in the ST integration whether the On/Off options in ST are for turning the unit on/off or recirc on/off. There is also something called “Refresh” with no explanation for what that means (maybe recirc?).

Lastly, I’m using the Control-r 2.0 app on a Samsung Note 10+ 5G on Android 11. And for what it’s worth, I’m slightly more sympathetic to Rinnai knowing that they have a 3rd party that developed the new firmware and app. And knowing who that 3rd party is, I’d would have expected a better result (and likely so did Rinnai).

What’s the way though the webbrowser? previously there was a few pages i found that present a .json file of values but this appears to be gone. Just curious if more information is displayed on this webpage that could be parsed for more information.

This version of the software does not expose any accessible values or services. From looking at the communication, the app does not talk directly to the Control-R unit, but instead the unit connects to the cloud and that serves as the intermediary between the app and the wifi unit.

I’ll DM you the directions for configuring wifi via a web browser. It will only help you to get the unit online assuming you are stuck in the endless software upgrade loop. Once you have it online, contact support for them to push version 2.27 to your device.

Thanks h0ckeysk8er,

My Control-R started acting up a couple weeks ago and then could not connect to my wifi network. I then tried the Control-r 2.0 app and got into the infinite upgrade loop cycle. After fixing the issue over the phone with Rinnai support a couple weeks ago, the module seems to maintain a stable connection to my wifi network now.

I also have tested the Smartthings integration for the last 10 days or so and while the authentication expiration problem appears to be resolved, there are some quirks with the integration. For example, if I trigger a recirc from the Smartthings app or from a Smartthings button, it takes about 3 minutes for the recirc at the Rinnai tankless heater to actually start. Based on my testing, I believe the recirc continues for a long time and so I’ve set an automation to turn off the recirc in Smartthings after 5 minutes. Due to the delays in the Rinnai <-> Smartthings integration, the time between turning the recirc on and off can vary.

Starting the recirc through the proprietary Rinnai Module-R button is immediate and so is much more useable for me. We press the button for a recirc about 5 minutes before taking a shower or before using the sink in the morning. Unfortunately, this button costs almost $100 and I bit bullet last year since I couldn’t wait any longer for the Rinnai <-> Smartthings integration to work. Overall, I’m pleased that the integration is progressing but I think more tweaks still need to be made.

Thanks for sharing your experience bulletdodger. I was hoping the ST integration would get worked out and resisted buying the expensive Rinnai devices. When I learned that they were just Zigbee switches and motion sensors, I decided to try a $13 Bosch motion sensor that I had. Even though it paired with the Rinnai controller, it wouldn’t activate the re circulation pump. I ended buying the Rinnai button and motion sensor from a retailer (Big Frog Supply) that sells them for $45 and $176, respectively. Still a lot of money but much cheaper than any other retailer I’ve checked. I could use a 2nd motion sensor and thought I’d wait until the ST integration was worked out. However, given the activation delay you described, I may just buy a 2nd Rinnai button and see if I can add on a PIR sensor to, effectively, push the button when motion is sensed.

If you have any Alexa enabled device, you can use voice command to activate recirc. We use that outside of our scheduled recirc windows.

Thanks. I am aware of that Alexa Skill and have had it enabled since day 1 after having the Rinnai installed. Unfortunately, it’s not a convenient way of getting hot water to the master bath (unless you remember to tell her on the way to that bathroom!). It is, however, pretty convenient for the kitchen and we use it daily. However, we found that Alexa periodically responds that the Rinnai is offline and can not carry out the command. Sure enough, I found that the phone app shows it to be offline during those times but the Rinnai button and motion detector work fine during those periods, making me think that the local options are the only reasonable way of making this work reliably.

Can you set the temperature above 40C using Alexa? With SmartThings scenes I can only get to 40C. My goal is to have some way to set the bath temperature to 108F without using their clunky app.

It worked for me. The command I used was: “Alexa, tell Rinnai to set water temperature to 108 degrees.” I was watching the Rinnai phone app when I said this and it changed from 125 to 108.

You can also use custom actions to create shorter versions of the Rinnai commands. For example, I have a routine where I say “Alexa, I need hot water” and the custom action is “Tell control r I need hot water”.

I have tried to get this working with new Rinnai firmware and it does not work … fails when trying to add Rinnai in Smartthings app. Contacted Smartthings, who told me it is a Rinnai issue. Contacted Rinnai and got following response … sounds like no working integration until later this year … only Alexa for now.

I’m sorry for the trouble.

Currently, Our software developer is working with Samsung to complete integration of Smart Things and Google Home integration but these are not on line at the moment. It is currently set up for Alexa, and we are hoping to finalize Smart Things and Google Home this year. Keep an eye out for Firmware updates and app version updates. The integration will come with an update in the future. Again, my apologies. Thank you!

The issue linking Rinnai and SmartThings is resolved. Let us know if you’re still having issues.

The Rinnai linked service still disconnects for me within 24 hours. Once I link, it works great at least for a few hours, but it never lasts for more than a day. Any ideas on this?

@Brad_ST any updates on the disconnects mentioned above? Integration doesn’t work unless you re-link every day, which is a huge pain.

I gave up and built a homebridge plugin for anyone interested. I’m not sure how Rinnai is getting away with falsely advertising that it works with ST.

Does anyone know what the latest version of the SmartThings side Rinnai controller is?
I’m showing 2.2.13-9