Rinnai Water heater now integrated with Smartthings! (Question...)

I have a Control-R controller for my Rinnai tankless water heater that controls my recirculation pump, temp, etc.

Control-R Module

And according to this article they are now integrated with Smartthings…

Smartthings Water Heater Category

This is awesome as I will now be able to really fine tune the times when the recirc pump runs. My question is the article says the Rinnai water heaters are listed under the “new Water Heater Category”. I don’t see said category in my app (Android Classic app).

Does anyone have any idea how to connect the Rinnai Control-R module with Smartthings like the article states?

Thanks!

You have to use the new app and look in the water heater category.

1 Like

yup, use the new app. Choose add device and then choose the Rinnai brand.

Interesting. I have one of these water heaters and have been looking for a solution. Even though this is WiFi, this perked my interest:

I’d like to see what that “connect” button on the controller really does.

Looks like I have a new project.

2 Likes

it looks like their motion sensor and button connect to the Control-R module via zigbee.

3 Likes

Yeah but if their controller connects to smartthings then you could control it via ecobee motion sensors, schlage door locks, zwave remote buttons, etc. This could really help save money on the recirculation line.

I’ll try to connect it to the app when I get home.

Yeah I bet that’s what they’re using it for. I’m really curious to see what capabilities this has when connected to ST. Right now my water heater is on a metering outlet so I can monitor power consumption and know when it’s used, but I’d love to have the ability to monitor temperature and control it.

1 Like

Exactly!

I found Rinnai America on the Smartthings app (not classic). I got all the way to the last step in the process of connecting the Control-R module to the app then I got the following screen…

"Authorize rinnaiwh would like to

All Devices
List this device

Allow
Deny"

I taped “Allow” and got the following error…

“Network or server error occurred. Try again later.”

I tried it multiple times and got the same error. I have a feeling this was the last step.

Any ideas on how to get past this error?

Thanks!

Probably going to have to contact support about that one. Sounds like a bugin the cloud to cloud connection process.

I did contact them. Their customer support is very nice and helpful but the Smartthings integration is so new the guy wasn’t able to help. He did say tomorrow he would be able to ask some of his coworkers that may have a better idea then call me back.

I’m pretty excited about this. Fast hot water to every faucet and minimize the gas bill is going to be great.

Hats off for Rinnai for leading the way. They now have their hot water heaters with recirc pumps connected to Alexa, Google Home, and now Smartthings.

1 Like

Did you try SmartThings support?

No. Sorry I wasnt very clear. I contacted the Rinnai customer service

I’d try SmartThings support too

Ever get this working? I want to buy but only if it works with smartthings, otherwise get something cheapet

I have to reconnect it to smartthings every 12 hours or so. I got tired. So now the recirculation runs for 30 minutes every 4 hours or so daily using the Rinnai app for scheduling and not linked via smartthings. Otherwise, I’d have the recirculation run for 5 minutes when bathroom and kitchen Motion sensors were activated… Alas… They goofed up. Well, these are my findings. I’d love to hear others thoughts. (ps., the water heater is great! But without recirculation, you’re waiting on hot water to reach the tap.)

Regards, shree

1 Like

I think I’ll still get it and hope for good integration later, either way I’ll try it, mine will be 20’ from the hub.

Distance from the hub won’t matter since this is a cloud to cloud integration.

Still worth a shot I guess

Yes, I think it’s probably cloud to cloud integration. I wished it stayed in the app and worked the way it should… Would’ve been great!

I only see Rinnai Korea in the list. How did you guys find America?

I went to Add > New Device

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.