Anyone able to make Rinnai Water Heater integration work (Control-R wifi to ST)?

I am about to replace my old Rinnai tankless water heater with a new one. The new ones have the optional Control-R wifi module that Rinnai touts as having SmartThings integration capabilities. Doing some searching it doesn’t seem like many have been able to make it work (and remain connected to SmartThings). Anyone have this integration with Rinnai working successfully?

If you have it working does it let SmartThings control the schedule of the recirculation pump OR is it limited to just requesting the pump turn on (ex. as part of a routine)? In a perfect world I would like to use it to only have the recirc pump enabled when we are home AND it is within a set schedule (daytime hours). No need to have it recirculating while we are away from home or while we are asleep!

My other thought was to just have the plumber put the external recirculation pump on its own outlet that I can control with a SmartThings switch so I can have the combination of being home and within a certain time window energize the pump (the pump would be hardwired to a temp sensor so it only runs when the water temp in the line has fallen too low).

Maybe others have had more luck but the Rinnai app is very buggy. I’m not sure if it is smartthings or Rinnai bit I have not been able to turn my water circulator on or off via smart things. Temperature changes do work.

I should have bought an external circulator

Check out this thread

Thanks but I don’t see anything new here. Am I missing something? I still can’t time mine to the smart things hub. I wish I could it would save a lot of recirculation time and money. Thanks again!

this integration is completely useless, if anyone has had any luck other than just turning the temperature up and down let me know as the whole reason i bought it was for the smartthings integration and recirc option

It looks like you can now have Alexa execute custom commands in Routines. In my case, I’ve created a routine that maps “Alexa, hot water” to the more tedious “Alexa, ask Rinnai to start recirculation on hot water heater.” Similarly, I’ve created routine that will start recirculation when motion is detected. The annoying part is that Alexa announces “starting recirculation on hot water heater” every time there is motion. You can select which Echo that this is announced from though, so I suppose you could buy the cheapest possible Echo (flex is $9.99), hide it somewhere, mute it, and turn the volume all the way down.

Not a great workaround, but it’s the best one I’ve found across any platform so far.

Thanks dustindclark!

I’ve been waiting for Alexa to offer custom commands in routines for handling this.

If you want to take this a step further, you can create a Virtual Switch in Smartthings that will register in Alexa. This will allow you to use Smartthings’s more robust automations to trigger the virtual device. Then you set Alexa to monitor the Virtual Device and run the “Ask Rinnai to start recirculation” based on the Virtual Device’s status.

My example:

  • Virtual Device named “Water Heater”
  • Smartthings Automation to trigger “Water Heater” on when any Bathroom light or Kitchen Motion Sensor is activated.
  • Smartthings Automation to turn “Water Heater” to off after 1 minute of being turned on.
  • Alexa Automation to “Ask Rinnai to turn on recirculation” when “Water Heater” is turned on.

Works perfectly!

The announcements are annoying, so I have an Echo Flex on the way and will plug it in the garage on the same outlet the water heater is plugged into.

Kicking this thread back up.

I have recently installed the control-r unit and tried SmartThings integration.
I am seeing 3 general parameters in SmartThigns: On/Off, Temp, Auto (looks like this is the circulation mode?).

Changing the temp does seem to work and it does seem to circulate the water. When I tinkered a bit with the system the heater stopped responding. Talking to Rennai tech support I was told the heaters themselves can be set to 2 modes: Echo, and comfort. Comfort mode will delay the pump response (once activated) by 5 minutes, Eco mode by -18- minutes. This is a good thing to keep in mind when testing these systems.

What I haven’t been able to figure out is what the on/off function is referring to. Does anyone have an idea? I’d love to be able to kick off the pump without needing to reset the temperature.

Update:
I managed to get the pump kicked off by toggling on the “on” button.
Though I wasn’t able to turn the device “off” using webcore.
Anyone manage to get this working?

Can circulation be activated with Smartthings now? I would like to use an existing motion sensor, but I don’t think it’s working for me. Is the power button supposed to be circulation? What does auto mode mean? It doesn’t seem like it can be changed. It doesn’t seem to shut the unit off or start circulation for me, so I’m guessing it’s not working correctly. Alexa seems to work okay, but it isn’t clear how long the circulation is active.

The Rinnai app works fine at my house, but the SmartThings integration does not work for me at all. It’s just completely useless. I guess Rinnai wants to keep selling their $300 motion sensors and having an effective SmartThings integration will put a stop to that. I was planning on hacking into one of their $40 push buttons with a device that I can control via SmartThings, but now that I have read this thread I guess I will learn how to use Alexa.