Ring Floodlight Cam

@phil6 figued out a way to get the light controlled through ST, which I am using until that happens. It is in this thread.

1 Like

Hi Kirk. Read the post your referenced but I see its for the Ring Spotlight. Would it work for the Ring Floodlight? Also, and if the code works, can you direct me to where I may find it and instructions?

Check out that thread. That is where the information is located.

Link/Instructions are in this post in the other thread. You’ll need to get a copy of the POSTMAN app and spend some time reading to suss it all out. All you get is ability to control the lights on the camera…and no status from the camera itself, so it’s half a loaf (which is better than none, but not terribly useful).

Still nice. I can hardwire power I have inside the house and use the switch location that was previously there as a scene controller now which manually turns on the light, giving it more traditional functionality in addition to “smart” functionality.

Agree with @bmmiller - I just installed one of these last weekend and manual “wall-mounted” control of the lights was a sticking point.

Are other folks doing something similar? I wasn’t sure if there was a SmartThings compatible switch that could pass the electricity from “line” to “load” without interrupting it. But then maybe all I need to do is wire hardwire that part (without the switch in the way) and then power the switch by itself… but not sure how that works if there’s no load?

I haven’t done it yet, still need to buy, install, etc, but this is my plan. You use a scene controller like mentioned in this thread.

@bmiller - thanks for the pointer. Sounds kinda pricey, but looks like you could build in some cool functionality with that thing. I have a couple of spare GE (Jasco) dimmers and 3-way switch - was hoping to re-use one of those for this use…

That’s not a bad idea actually. Just power it and don’t put anything on the load at all. Still would need to use webcore or something to hook it all up, but that’ll work and is much cheaper.

Good ideas…

Just got this working and everything worked perfectly. Couldn’t be happier short of full on Camera integration or something which we know isn’t happening, ever.

I have a standard Zwave switch, just powered up, no wire on Load. Then have the Ring Floodlight Cam wired up to power and functioning. Using Smart Lighting (because locally processed) I just tie the light to the switch. Just like the plan that was discussed.

1 Like

I’ve got 2 Ring Floodlights, 2 Ring Spotlights and a Ring Doorbell coming on Friday. I am relatively new to the whole home automation and ST world. What would you suggest is the best way to use all of these? Should I get a GE Switch for each one and hook it up through that? Can I use the motion detector through that? @bmmiller Could you by chance give me a detailed explanation of how you did your thing with the floodlight? I am researching this pretty heavily, but for some reason it is just not ‘clicking’ just yet. Suggestions or resources??

You want to constant power all of this. You do not want to run it through a switch. We are all waiting for “official” integration but @phil6 put together a great work-around to use the lights with Smartthings on this thread and I use it:

The direct link is here:

@bmmiller - Exactly which Zwave switch did you end up using?

The spare Zwave dimmer switches I have on hand warn that “some amount of load is required to operate properly”. In your wiring did you just connect the line and neutral wires to the switch, then wired load wires (that go to the floodlight cam) directly to line, bypassing the switch? Just want to make sure I’m not breaking code :slight_smile:

I didn’t have any spares so I just bought this guy new. https://www.amazon.com/gp/product/B01M1AHC3R

I have the switch powered, and the floodlight cam powered and that’s it. There is nothing wired into the load on the switch at all. I’m having a hard time understanding why a switch needs “some amount of load” unless it is a dimmer, or you really mean line. Either way, my switch is acting perfectly fine.

Also not sure how this would violate code anywhere. There’s no magic, 2 devices are wired up to 120v and the switch is basically a scene controller at this point. If you were worried about code though, an actual scene controller that is perhaps more obviously “not a switch” might fit the bill then and serve the same purpose. I was actually purposefully trying to go for the “normal” look and didn’t want a goofy looking scene controller on the wall when everything I have in the vicinity is all paddle switches.

There is still at least a full 1-2 second delay between pushing the switch and the light going on or off. This was expected though since it has to talk to the Ring cloud to get it done so I wasn’t surprised.

@bmmiller - thanks. Just got this setup. You were right on the money: my spare switches were actually dimmers. Ended up getting a regular on-off switch and now it’s working. Thanks for the idea about using “Smart Lighting” so it would locally process. Now the switch can control multiple lights as needed :slight_smile:

1 Like

Smartthings your support is really wack!!! Pull your finger out and get Ring Floodlight Cam intergrated!!! It been over a year now and still no support for a great product! You updated your stupid app for Smartthings classic and rave on about the new Smartthings app… why don’t you provide useful integrations first instead of wasting time updating the app!

Ring are going to be on the market with their own hub soon… can’t wait to switch over to them… I know their support is better for sure!

Works great with wink

I cannot think SmartThings is too far behind, then.

Unfortunately for me Smartthings is too far behind on several things. I was going to switch from Wink2 but,

Ring Spotlight Camera - no support
Nest- no support “officially” - have to install some workaround that I couldnt get to work
Lutron light switches - no native support - have to use lutron smartbridge hub
Lutron connected bulb remotes - no support that i can find
GE Link Bulbs - no support or I just couldnt get it to work.

The only thing that the smartthings hub can control that my wink2 doesnt is my wemo plugs.