Ring doorbell 2 error

So I just got the v2 hub and I am using the new app not the classic and it is fully updated. I was able to add my AV receiver, TV, and door lock but for some reason I cannot add the Ring 2 doorbell.

It gives me an error shown in the photo attached. The ring is on the wifi and I can connect to it using the ring app. I have tried 2 different wifi networks that I have but it was a no go.

Any ideas?

Even though you’re not using the Classic app yet, try setting up through there?

Yep tried it and this is the screen I get.

Ok, I just tried viewing my Ring via ST and live stream failed. I then opened the Ring app and did a live view successfully. I then tried ST again and it worked. Perhaps try that to see if that helps you?

I did the live view via the Ring app and it was fine. Tried both ST apps and still the same error.

Well crap. You’ve done everything I can think of. Aside from emailing support and waiting for a long time, I’m not sure what you can do. Perhaps remove the app from ST and try again later? Sorry that I’ve got nothing else for you.

Add Doorbell2 through Classic, and change in device type to Pro. You get this in Classic:

And this one in Smartthings new app:

1 Like

That’s the thing, I cant get it past the error on either classic or the new ST app. I tried both pro and regular.

Tried clearing the cache on both apps and still the same.

Try removing doorbell in both apps and IDE, and than adding it through classic, and changing it to pro in ide. BTW it needs to be hardwired not on battery.

Well I guess I can forget about it then as I cannot hardwire it. Lennar decided that my new home did not need wires for doorbells hence the reason for the ring 2. Oh well.

So guess what! There must be a big in the android app as I used my wife’s phone, added her to the hub account, and then was able to add the ring through the iPhone app. Go figure!

Ok so I was able to get it added. Now here is what I get from IDE. What do I need to change? When I go to the live view it gives me a network error.



Device type is correct “Pro”, but as I stated to have video connected doorbell needs to be hardwired.

Arg! Well crap. Why is that? Is it because of power requirements as the video does not run through the wire but is wireless?

Maybe Chime Pro would fix that. Not sure, as don’t have that one, just regular chime, and hardwired.

I think my issue is quite the same. I’m using the v2 hub and Ring’s second-generation wireless doorbell. I tried everything and didn’t workout. I’m thinking of calling Ring to have this solved.

If anyone has solved this, help would be much appreciated. A tutorial video would be really nice.