REST API does not accept some commands/options

Hi, this is my first post

I have two Samsung HVAC and I want to manage them from my domoticz system
My models are Samsung Windfree AR**TXFCAWKNEU
I have integrated them with several options/commands sent with the REST API

But I have a problem with one specific mode, the “Quiet” command

This mode can be enabled with the remote and also with the ST Android app.

But when I try with the API, it does not work.

I’m testing with postman with this body:


And also with the OCF command:

{“commands”:[{“component”:“main”,“capability”:“execute”,“command”:“execute”,“arguments”:[“mode/convenient/vs/0”, {“”:[“Quiet”]}]}]}

But the json response for both commands is ACCEPTED instead of COMPLETED

If I check the capabilities of the HVAC with the status command, I can see that “quiet” is not included.

“custom.airConditionerOptionalMode”: {
“supportedAcOptionalMode”: {
“value”: [

But if I send the command with the app or the remote, the status shows that the mode “quiet” has been processed:

“acOptionalMode”: {
“value”: “quiet”,
“timestamp”: “2023-02-13T20:57:23.765Z”

So, I can´t understand what is happening.

Does the ACCEPTED response means that the command is correct but not implemented?
Is a lack in the API or the firmware of my HVAC?

Thanks in advance for your help

I’ll tag @nayelyz from Developer Support here to make sure she sees your query.

I seem to remember that device commands are now asynchronous so the immediate response is ACCEPTED.

As for the supported modes, I think that is a case of the supported modes not actually being enforced in all integration types so inconsistencies are possible.

1 Like

Thank you for the fast response, Graham

Respect to the inmmediate answer, I can understand what you mean.
But in fact, the other symptom that I see is the lack of the typical ‘beep’ that the HVAC emits when receives a command from any source (remote, app, API…)

I will wait for nayelyz answer

Hi, @Javier_Civera
@orangebucket is right about the response from the API, you’ll get “ACCEPTED” but this doesn’t mean the event was processed, this is to avoid blocking other incoming events if the first hasn’t been completed.

About the commands for that specific mode. Something special about OCF devices is that they don’t work at the API level but at the application level, this means there can be inconsistencies with commands directly from the API but there are no problems when commands are sent from the ST App. Here are some details about that.

It depends on whether the device handler support this kind of event or not and based on the value of “supportedModes” shown in the status (which is also set by the device handler), it’s highly possible that the command handler also accepts only those options.
I can open a report about this to see if we can get more info about it…

Hello @nayelyz, @orangebucket
Have you got any news related to the supported modes by the handler or any other information about this limitation?

Thans in advance

Hi, @Javier_Civera

To open a report I need the following information:

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Share the device’s name
  2. Share the last timestamp when you tried to execute the command (Eg. 17:00 CST) to see if the team can see if there’s an issue registered about that. If it has been a long time since you did, it would be best to try again to get a more recent log.

Hello @nayelyz

In response to your request, here you have the data:

1 - I confirm you that my email account is the same than the used for the forum
2 - I have allowed the ST Account data access for unlimited time.
3 - The device name for tests is “Salón”
4 - Using postman I send two different commands at the time I’m writing this post

command1 - {“commands”:[{“component”:“main”,“capability”:“custom.airConditionerOptionalMode”,“command”:“setAcOptionalMode”,“arguments”:[“quiet”]}]}

response1 - “id”: “279a8140-f1e7-404e-ad17-0685722bd454”, “status”: “ACCEPTED”
time1 - 2023-03-02T12:12Z (approximated)

command2 - {“commands”:[{“component”:“main”,“capability”:“execute”,“command”:“execute”,“arguments”:[“mode/convenient/vs/0”, {“”:[“Quiet”]}]}]}

response2 - “id”: “e2fb2e2e-b510-4080-bd5e-99771406f6b5”, “status”: “ACCEPTED”
time2 - 2023-03-02T12:19Z (approximated)

I hope this information can be enough to open the report and obtain any conclusion

Thank you very much for your support

Hello @nayelyz

Is there any result or news related to my last post?
Was the provided information useful to the support team?

Thanks in advance

Hi, @Javier_Civera
Sorry for the delay, there is no news about this yet, I pinged the team again.
Once they provide more info, I’ll let you know.

Hello nayelyz

My last topic in the forum was about one month, asking for some news about my post
Your response was to “ping” the suport team
I would like to know if there was any investigation related to it, because I left open the access to my account according to your instructions.
If there is no plan to investigate my problem, I will close the access to it.
I expect your reply to proceed according the news.


En viernes, 17 de marzo de 2023, 15:40:35 CET, Developer Support Team via SmartThings Community escribió:

| nayelyz Developer Support Team SmartThings Partner
March 17 |

  • | - |


Is there any result or news related to my last post?
Was the provided information useful to the support team?

Hi, @Javier_Civera
Sorry for the delay, there is no news about this yet, I pinged the team again.
Once they provide more info, I’ll let you know.

Hi, @Javier_Civera
Sorry for the delay, there was no response from the team, so, you can go ahead and disable the access, in case they need it again, we’ll let you know.

I have the same problem. :slightly_frowning_face:

{"commands": [{"component":"main", "capability":"custom.airConditionerOptionalMode", "command":"setAcOptionalMode", "arguments":["quiet"]}]}

Arguments “off”, “windFree” and “speed” work and give the response status “COMPLETED”. :white_check_mark:
But argument “quiet” does not work and gives response status “ACCEPTED”. :x:

It works through the Smart Things Android app and the IR remote control, but not through the API.

@Bluebrain Are you trying to send the command using Smartthings CLI or Do you observe the same behavior?

I’m using the API.
Even though I didn’t expect any different results, I still tried using the Smartthings CLI and it doesn’t work with that either.

smartthings devices:commands ********-****-****-****-************ "custom.airConditionerOptionalMode:setAcOptionalMode(\"quiet\")" --token ********-****-****-****-************

Command executed successfully

… but nothing happens.

@Bluebrain For the behavior and capabilities, it appears to be a device that is controlled directly with the mobile, like OCF. Unfortunately, this type of device doesn’t work like hub-connected or Cloud-to-Cloud devices. In this case, the manufacturer only knows how the device receives the commands and the valid arguments, so that is the possible reason why the API accepts the command but is not reflected on the device.

1 Like

The parameters and values should be correct, as they are the same that are transmitted by the API in the event webhook notification. (when quiet mode is activated with the SmartThings smartphone app)

@Bluebrain let me check it with the team, I will send you a direct message to ask for some information.

1 Like


Have you made any progress on this issue please?

It is quite frustrating not being able to run a “Quiet” command.