Resolved: Core gives unexpected error on all pistons (Needed to set timezone)


#1

Hello everyone, I downloaded the latest smartthings app and refreshed CORE from BitHub.

When I try to save any piston I get an unexpected error.

Any ideas?


#2

Sorry actually the error is “Error saving page” when trying to save any piston.

When trying to display the core dashboard I get an unexpected error.


(Sam Roza) #3

I am new to CoRE, but have found that saving a piston usually gives me this error. Re-saving usually works, but I did have to try ~3-4 times, once.


(Robin) #4

Could be a poor internet connection?

Error accessing dashboard could be oAuth… Needs to turned on via the IDE.


#5

Internet connection seems to be fine. I’ve tried it with the phone running CORE on multiple networks.

I’ve tried uninstalling and reinstalling many times with the same results. Even tried android and Apple phones, no change.

Really wish I could get this working. I have programming experience so would love CORE.


#6

I tried resaving 10 times, didn’t change : (


#7

Check the live logging in IDE and see if you get errors/line numbers, might give us a clue where to start.


(Robin) #8

Have you enabled oAuth in the IDE?


#9

oAuth is enabled. I’ll try to get error messages.


#10

Here are the logs:
Clear
bc637972-939c-4c61-b24e-ea87de16cb64 7:36:01 AM: debug params: [ts:1484659590050, stateID:1480191888310, _:1484658826854, appId:bc637972-939c-4c61-b24e-ea87de16cb64, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi, access_token:XXX-XXX]
85b117cc-f788-4001-8014-e78094cff436 7:36:01 AM: error java.lang.NullPointerException @ line 8629
cff0c88b-ece9-4f7d-8b67-fc06ff239964 7:36:00 AM: debug params: [ts:1484628364161, stateID:1479951611829, _:1484659982865, appId:cff0c88b-ece9-4f7d-8b67-fc06ff239964, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi, access_token:XXX-XXX]
85b117cc-f788-4001-8014-e78094cff436 7:35:55 AM: error java.lang.NullPointerException @ line 8629
bc637972-939c-4c61-b24e-ea87de16cb64 7:35:31 AM: debug params: [ts:1484659590050, stateID:1480191888310, _:1484658826853, appId:bc637972-939c-4c61-b24e-ea87de16cb64, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi, access_token:XXX-XXX]
cff0c88b-ece9-4f7d-8b67-fc06ff239964 7:35:29 AM: debug params: [ts:1484628364161, stateID:1479951611829, _:1484659982864, appId:cff0c88b-ece9-4f7d-8b67-fc06ff239964, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi, access_token:XXX-XXX]
bc637972-939c-4c61-b24e-ea87de16cb64 7:35:01 AM: debug params: [ts:1484659590050, stateID:1480191888310, _:1484658826852, appId:bc637972-939c-4c61-b24e-ea87de16cb64, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi, access_token:XXX-XXX]


#11


#12

That line looks like it’s related to the time zone some have been having issues with. Look in the IDE what you have for the time zone settings, if incorrect, move your geofence and set it back to your correct location.

Edit: It usually affects the time based pistons.


#13

Thank you for the reply, you are correct I do not have a time zone set in my location.

However, I can’t find where I can edit the timezone?

Any suggestions on how to set the timezone?


#14

Contacted support, they had me move my location out of my timezone and then back. That set the timezone and allows CORE to run.

Thanks!!!


(Dennis Tegenbosch) #15

This also solved my problem!

To add, you can do this without contacting support:

  • Go to your hub settings where you see the location mapped of your hub (The menu on the left and then the gear icon to access settings)

  • Zoom that map out till you see china appear on the map (or a other far away country, which is a other timezone).

  • Then zoom in to that place like china for example and pick that as your location.

  • Save

  • Wait 1 minute and then change the location back to your real location.

Then the time zone problem is solved :slight_smile: