Reset app data on IOS app

Hi i accidently reset the app data while trying to troubleshoot something, unknowingly after i do so , and i re-login, all my devices of 200+ are gone including the smarthings hub device

I went to my smartthings ide and all my devices are still there.

How can i restore my devices onto my ios smartthings app?? Please help, thanks

Try signing out and signing in again. If that fails… uninstall:reinstall. If using presence location, I imagine you would need to enable it and edit any Routines that may have used it,

@jkp i done all these, log out, remove app, reinstall but still the same

Not just my ios smartthings app , android app is showing the same.

Remove the app, reboot your phone, login to the advanced web app and make sure phone is not listed as a device, if it is… remove it, reinstall app and login. I am not confident this will resolve it.

Contac ST support if still having the issue.

It is definitely unusual. I almost started to try it a few back … glad I didn’t now.

Did what u listed but still the same issue.

Not sure what happened…

Also send email to support

@nayelyz can u help look into this. I have sent an email to you on this too……

Anyone have done this reset and able to get the devices back on the app? Its werid because the reset indicate it should not remove all devices… now i cannot load the devices at all on the app. Its still on my web base dashboard but not able to load on the app both on android and ios

Prior to this i was trying to add my wife via the invite button to grant access but there was some issues and i try to reset the app. All devices gone in the app after reset

All devices are working still