Repeated signon requests when using Chrome 52?


(Jim Newman) #1

When I use the SmartThings IDE the past few days, I am repeatedly sent to the SmartThings login screen. This started happening right about the time I upgraded Chrome to v52, so I suspect that’s related, but has anyone else encountered this problem? Either the repeated logins happening with something OTHER than Chrome 52, or you’re using Chrome 52 with no problems?


#2

(Jim Newman) #3

This pretty much describes what I’m encountering. What browser & version are you using?


(Jim Newman) #4

Sounds like it might be a SmartThings API issue; I’ve had problems with SmartTiles suddenly throwing a “not authorized” screen after I’ve been away from it for a few minutes.


#5

It’s always been true that if you have two tabs open that both use sign on authorization, such as a dashboard and the IDE, you will keep getting signed out. I don’t know if your updating chrome is now causing something similar, or if you also had a second tab open. Or if you’ve run into something completely different.

Read the other thread for details. (The title is a clickable link.) there are some people there using chrome, so they may be able to say more.


(Jim Newman) #6

Seems to fit 100%. Thanks.


#7

I am observing exact same thing when I am trying to run Smart Tiles and CoRE dashboard side by side. They bump each other out.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

This problem is resolved in next generation SmartTiles V6 which no longer uses local SmartThings IDE login sessions.