[RELEASE] Zooz Outdoor Motion Sensor - VER 2.0 (ZSE29)

This is a DTH for the Zooz Outdoor Motion Sensor VER 2.0 (ZSE29).

This DTH only works with VER 2.0 (and above) so if you purchased the device prior to 12/10/2019, you’ll need to use my other handler for this device.


I got mine about a week ago, so going to use this one. I think this was actually out prior to Black Friday, IIRC. Or is this an even newer one?

Open the device in the IDE and check the “Raw Description” field. It should include “ver: 2.0” if you have the latest model.

1 Like

Big bummer, mine is V 1.4. I just checked and I ordered it on 12/1. :frowning:

I reverted my DH. I did at least learn how to check firmware versions! :slight_smile:

Anyone having trouble with smartthings picking up motion on these outdoor motion sensors? I can get the sensor to pair, lux works, tamper seems to work but it won’t pick up motion. I know the sensor is picking it up from the red light coming on.

Tried removing and re-adding a few times with no luck. Also tried the default Z-wave motion handler…still nothing.

Edit: Figured it out the base needs to be on and tight. Just holding the tamper sensor down with your finger doesn’t work.

@krlaframboise… Hi Kevin, I have confirmed that I have a v2 model and I’m not having much luck with the Motion Cleared Delay setting. I’m using 5 seconds to override the knob setting but it’s taking much longer than 5 seconds to reset. Do you have any thoughts on this? Thanks!

Are you sure the settings have been applied? The tamper switch doesn’t wake it up so you have to either pull the batteries or wait until the next time it wakes up which is probably every 3 or 12 hours.

@krlaframboise… Ah okay, so I’d prefer to override both the knobs and use 5 second delay and always trigger motion without considering lux. So I should make those changes and then save them. Once saved, take the cover off, remove batteries and replace and the new settings should be in effect? Thanks

Edit: I just tried what I said above and it didn’t work.

Your screenshot shows that param 5 is set to 5 so it should be working as expected.

Open live logging, trigger motion, wait until it reports inactive and post the results.

Make sure that motion is only triggered once because the delay timer gets reset every time there’s motion.

Here’s the recent activity. Notice how it was active and never returned to inactive? I thought that was odd. Then the next motion event triggered as active and then reset to inactive as it should have.

I need to see the live logging results after testing, not the recent activity…

Here you go, I did a quick walkaround and it looks okay. Not sure why it didn’t reset to inactive yesterday after that one event. Thanks!

Really appreciate this DTH. I now have 4 of these and it works great. I’d like to know if it’s possible for it to trigger without the red light? It would save battery a bit and not be noticeable at night. Thanks!

My settings screen for this device is showing only “[Object Object]” in the list of settings values for every parameter. The device is otherwise working (motion, illumination, tamper, etc.).

I did try excluding the device and then doing a factory reset before joining it to the Z-Wave network again. Same result.

Can anyone point me at what I may be doing wrong?

ST recently made a change to the new mobile app that broke the settings screen even worse than it was before. Until they release the documentation for the new mobile app that’s probably going to keep happening so at this point, I’m not wasting time troubleshooting any issues in the new mobile app.

Once they release the new documentation I’ll make the necessary changes to get everything to work, but until then you need to use the classic mobile app to change the settings.

Thank you. I just checked the old classic app and your DTH indeed works fine there. Thanks for the contribution.

Zooz mentioned that there was an issue with the status in the new mobile app so while using the new app did you happen to notice any other issues, like it not changing the motion state or reporting as offline?

I hardly have any devices connected to ST anymore so I can’t easily check these types of things…

I just posted a new version that works around this bug in the new mobile app, but let me know if you’re still having issues with it.

The fix appears to work for me. Thank you.

1 Like

I’m having a similar problem to one mentioned by @162884 above. At times, the sensor will become active and never reset to inactive. As far as I can tell, this happens when the sensor is almost out of range of my hub and perhaps the inactive signal is not received. And even though subsequent communications are received, the activity status doesn’t get updated. See attached history. Sensor never shows inactive, even though subsequent lux measurements are reported.