[RELEASE] Zooz 4-in-1 Sensor

Ok, I think I figured it out. When I tap the recessed button with a paperclip on the sensor, I watch the log update everything and then the bottom tile on my app appears blank. The update tile is also updated with the current date time of the manual update. If I press the Refresh tile on the app, then the ‘7 change(s) pending’ appears in the bottom tile. That was throwing me off because I had not made any new changes. I guess I don’t really understand what the purpose of the Refresh tile is but I think I am good. Thanks again for all your assistance.

That means that the settings were successfully applied and you don’t have to do anything else.

The main thing to keep in mind is that this device sleeps so any action you perform, including tapping the Refresh tile, won’t send or retrieve anything from the device until the next time it wakes up.

The Refresh button does 3 different things:

  1. If you open the device and the Tamper tile is active, tapping the Refresh button will immediately change it back to “clear”.

  2. If the Tamper tile is clear, tapping the Refresh tile will set a flag that tells it to request the motion, temp, humidity, and light values the next time it wakes up. This isn’t necessary, but it allows you to see changes that haven’t been automatically sent because they were within the Change Trigger. There’s no visual indication that this flag has been set which is something I should probably change.

  3. If you tap the Refresh tile a second time it forces all of the settings to get re-sent to the device the next time it wakes up.

  • Repeatedly sending the settings to the device drains the battery so when the DTH sends a change it has the device send the current value back and it stores it. The next time it wakes up it compares the specified settings against the stored settings and only sends the settings that have changed.

  • The only time you need to re-send all the settings to the device is if the stored settings become out of sync with the device’s settings.
    The stored settings being out of sync with the device settings typically happens by switching to another DTH, changing settings and then switching back to my DTH.

I’m seeing the below in my logs. Looks like it’s always trying to change the LED mode. I haven’t done anything during that time frame.

00000000000-42cc-b421-e03a8e9dac90 8:41:30 AM: debug LED Indicator Mode [1-4]
(1 - Temperature Off / Motion Off)
(2 - Temperature Pulse / Motion Flash)
(3 - Temperature Flash / Motion Flash)
(4 - Temperature Off / Motion Flash)(#7) = 1
00000000000-42cc-b421-e03a8e9dac90 8:41:28 AM: debug ledIndicatorMode(#7): changing 1 to 4
00000000000-42cc-b421-e03a8e9dac90 8:41:28 AM: debug Device Checked In
00000000000-42cc-b421-e03a8e9dac90 8:35:09 AM: debug Illuminance is 0.62lx
00000000000-42cc-b421-e03a8e9dac90 8:35:09 AM: debug Humidity is 49.53%
00000000000-42cc-b421-e03a8e9dac90 8:35:09 AM: debug Temperature is 70.75F
00000000000-42cc-b421-e03a8e9dac90 8:15:14 AM: debug Illuminance is 0.39lx
00000000000-42cc-b421-e03a8e9dac90 8:15:14 AM: debug Humidity is 48.39%
00000000000-42cc-b421-e03a8e9dac90 8:15:13 AM: debug Temperature is 71.12F
00000000000-42cc-b421-e03a8e9dac90 7:40:17 AM: debug LED Indicator Mode [1-4]
(1 - Temperature Off / Motion Off)
(2 - Temperature Pulse / Motion Flash)
(3 - Temperature Flash / Motion Flash)
(4 - Temperature Off / Motion Flash)(#7) = 1
00000000000-42cc-b421-e03a8e9dac90 7:40:16 AM: debug ledIndicatorMode(#7): changing 1 to 4
00000000000-42cc-b421-e03a8e9dac90 7:40:16 AM: debug Device Checked In
00000000000-42cc-b421-e03a8e9dac90 6:39:09 AM: debug ledIndicatorMode(#7): changing 1 to 4

Option # 4 was added in a later firmware version so the device must be ignoring the change.

I just released a new version that displays a warning when #4 is selected for a device that doesn’t support it instead of trying to change the value.

Thanks, loading it now

Hi Kevin,
1st off thank you so much for creating this handler. I am using it on the monoprice and everything is working great but only
issue i have is that the battery status is not updating , its just showing 2 lines – in its place.
I installed it and set it up about 8hrs ago so will it update at some point?
i did change the battery reporting interval to 1 to see if i can get it update but no luck so far.
also it shows 8 pending changes , so used a paper clip to wake it up and below is a screenshot from my logs

any help you can provide will be greatly appreciated.

Sometimes it can take a while to update, wait for upto 24 hours. If that still doesn’t work try using the official device handler for Monoprice. The device behaves a little differently from the ZooZ device.

and where can i get the official handler from?

You can also search the forum for Official Monoprice and see the results. If you already have access to RBoy Apps you can visit the website and download it.

are you talking about the paid handler you guys are selling ?
if so i wonder something, did monoprice or who ever created this device never make an official handler for it?

Yes, that is the official monoprice approved handler. Lets take the discussion offline, feel free to PM me with any question about the monoprice device.

You can pay him for it…or you can just wake the device up which will solve the problem you’re having with this DTH.

The device sleeps so any setting related change you make won’t get applied until the next time the device wakes up.

You can force the device to wake up by using a paperclip to push the recessed button on the bottom of the device.

I set this all up today and all of the tiles will update and respond except for the motion tile. Is there something that I missing?

Disregard that, it finally kicked in :slight_smile:


I’m looking for a replacement for my Zigbee Iris motion sensors. They work well until the battery drops some, but even when it still shows 100% (such as measuring 3.03V instead of higher when battery is brand new) I have issues with it like it remains in the Active state even long after motion stops. It’s like it fails to properly report its Motion status.

So anyway I’m looking at this Zooz device because it seems to be highly rated and it is Zwave, which tends to work more reliably in my set up than Zigbee. In other threads some people have said that the Zwave devices do not report their motion becoming Active as fast as Zigbee devices. Can anyone speak to whether that’s really an issue?

Also this page https://www.thesmartesthouse.com/collections/motion-sensors/products/zooz-z-wave-plus-4-in-1-sensor-zse40 says the ZSE40 is out of stock because a new version is coming 10/30/17. Anyone know how the new version will be different?


Tagging @TheSmartestHouse, can you say anything about the new product yet?!

The zooz 4-in-1 dies a little bit below 3v and goes through batteries faster than most, but it takes 2 AAA’s which are cheaper than 3v batteries. The device won’t work with rechaeble batteries unless the batteries are new and still able to hold a 1.5v charge.

Motion sensors don’t report inactive immediately after the motion stops. They usually take somewhere between 10 seconds and 3 Minutes, but some devices allow you to adjust that setting. If the motion sensor is in a room with a lot of traffic, setting it to 10 seconds will drain the battery.

With the current firmware it takes at least 1 minute for the Zooz 4-in-1 to report inactive.

I’m not sure how fast the IRIS sensors are, but the SmartThings Zigbee motion sensors report motion faster than any of my z-wave motion sensors and the zooz 4-in-1 sensor is not my fastest.

If a new version is coming out then everything might change.

The Zooz motion/light mini sensor is one of my fastest z-wave motion sensors, it can report inactive after 10 seconds, and it’s only $30.

1 Like

It’s frustrating that the ST app reports the battery is at 100% when the battery is measuring 3.03V. Perhaps anything above 3.0V is considered 100%. However it seems some devices, and especially the Iris motion sensors, are not reliable when the voltage gets down to 3.03V, yet the battery is still considered 100%. It would be great if there was a way to set the scale so I could get a notice when the battery was dropping. Instead I’ll have to manually check the batteries every x months without any warning from the app, it seems?

Thanks, however I’m reporting that there is an issue with ti getting “stuck” knowing the above already. The iris report Inactive after 30 seconds of no motion. That’s perfect for my needs. However, in these times when it gets stuck in the Active state, it stays that way long after there has been no motion. For instance it’ll say Active even after an hour of no motion whatsoever when it gets in this state. My theory is that as the battery approaches 3.0V it cannot properly transmit the Inactive state back to the hub sometimes, perhaps because its signal is too weak, I’m not sure. So the device thinks it reports Inactive but the report is never seen. Later when you walk by it and it now thinks it has gone Active again, it may succeed the next time in reporting Inactive. It’s a bit hit or miss when the batteries get low.

I don’t mind just putting in fresh batteries. But what I do mind is not knowing when it is time to do so. I’d rather get an alert from the device or be able to check the battery status in the app to know to change the batteries, rather than just having to check them or replace them every x months on a set schedule. Because otherwise it messes up my automation when the devices get stuck on Active. But because of what I wrote above in this post about the battery %, it looks like a set schedule is required.

That’s a little long for my needs. Can this be adjusted?

The fast detection possible is really important in my application. What reliable Zigbee motion sensor would you say is the fastest from your experience with them?

That sounds great. Is the inactive reporting period of 10 seconds adjustable? Sounds like it may be worth testing out if so, but I would only be able to keep it if it is just as fast as reporting motion compared to the ZWave Iris device.

Thanks for all the great information!

If the device takes a 3v battery then it shouldn’t/can’t require more than 3v to function because not all 3v batteries are capable of producing more than 3v. Is there a message near the battery that says it requires a specific brand?

I think most Zigbee devices report the battery in volts and the DTH performs the calculation to determine the battery level. If that’s the case with the DTH your IRIS motion sensors are using you should be able to easily adjust that calculation.

Have you looked at my Simple Device Viewer SmartApp? It can send you notifications if the battery drops below the threshold you set and it can also send notifications if it hasn’t checked in with ST for a specified amount of time or SmartThings marks it as offline.

It has also allows you to see the battery level of all your devices from a single screen.

That SmartApp won’t help if the device is still reporting 100% when it dies, but it worked great for the ST Motion sensors that used to die while showing 60%.

I purchased some ST Motion Sensors when I got the hub, but all of my other motion sensors are z-wave and I no longer purchase zigbee devices.

They occasionally report false motion events and 2 of them stopped reporting motion after about a year so now they’re just temperature sensors.

Yes, 10 seconds is the lowest, but you can set it a lot higher.

Thank you Kevin. I’ll definitely check out your SmartApp later today - sounds great, didn’t know about it.

I just noticed that the Zooz and alternatives to the Iris motion sensor are considerably larger in size. For my particular needs it is very important that the device I use has a small footprint - smaller the better. This is one very nice advantage of the Iris.

The SmartThings made motion sensor is also fairly small, although larger than the Iris one. I’m wondering if you or anyone has done a comparison between the SmartThings motion sensor versus the Iris?