[RELEASE] Zooz 4-in-1 Sensor

3v power adapter. Positive to positive battery post. Negative to negative. Drilled a little hole and ran the wire to the attic. Plug was already up there. I have 5 devices connected to this one adapter. It’s 1 AMP so it has plenty of power.

I’m primarily using for motion and secondary lux. Temp and humidity are not used and I have increased those to max triggers. I just noticed in comparison to some of the other motion sensors I have these ones seems to eat batteries.

You might be able to extend the battery life a little bit by setting:

  • LED Indicator Mode to 1
  • Light Change Interval to at least 10
  • Minimum Check-in Interval to at least 4

The battery life is worse than most other sensors, but from a cost perspective it’s not as bad as it seems because it uses 2 AAA batteries which can replaced twice for almost the same price as replacing a CR123A once.

LED off, light change 10, check in 12

I just loaded your handler a few days ago so I’ll see how it goes. Wish mine were in a spot that I could hard wire! That would make it really easy.

Also, just as an FYI, some of the fields don’t have descriptions. Some are obvious, 76.28 is temp, etc. but others are not. Looks like Humidity, Temp, Light, Motion and Tamper aren’t showing.

One of the last updates for the Android mobile app introduced a bug that renders values like that if you don’t put a space before a line break.

SmartThings should fix that bug in the mobile app, but I’ll release a new version of the DTH tonight.

First, thanks for the software! I’ve set my primary sensor to temperature in the app but it’s still saying 0 on the tile (believe maybe still using default sensor? lux or motion?). Any thoughts how to get that to change?

The device sleeps so most of the changes you make won’t be applied until the next time the device wakes up.

To force the device to wake up immediately you can use the paperclip the device came with to push the hidden button on the bottom of the device.

Pushing the button doesn’t always make it wake up, but you’ll be able to tell by the date and time shown in the bottom right tile.

Let me know if that doesn’t resolve the problem.

I just had to be patient. It just updated. Thanks again :slight_smile:

1 Like

@krlaframboise I just noticed something when using your DTH for the ZooZ sensor:

On the Recently tab, all motion events show up with “No motion” beside them regardless of whether the sensor is reporting active or inactive. Could you take a look? Or is there something I missed somewhere.

Also, right now the main icon on the device page is the motion sensor icon, but it remains gray whether or not motion is active or inactive. Is there a way that could be made dynamic?

I just released a new version that should fix some issues users have reported.

  • The Recently tab show the correct value next to motion and tamper events.

  • Main tile shows motion/no motion and changes color when Primary Status is set to motion.

Changing Settings

When you make changes to the settings screen a new tile will show the number of pending changes.

Those changes will be sent to the device the next time it wakes up, but you can force it to wake up immediately by pressing the recessed button on the bottom with a paperclip.

Within 10 seconds of waking up the pending changes message should change to “Updating Settings” and then disappear once the device has confirmed the changes.

If the message didn’t change or the number of pending changes went down, but didn’t disappear, you will need to wake it up again.


  • If you tap the Refresh tile once it will request the battery level and other values the next time it wakes up.

  • If you tap the Refresh tile twice it will change all settings to pending and they’ll be sent to the device the next time it wakes up.


  • Changing the primary status doesn’t change the main tile immediately. It will change the next time the attribute you selected changes.

  • LED option #4 wasn’t in the first version of the firmware so you can’t use it if the device details screen in the IDE shows firmwareVersion 5.1.

1 Like

I have about 15 sensors mostly to control lights using motion and lux in Core. There is a random delay to detect the motion. Sometimes it’s really fast, sometimes it takes 5-8-10 seconds before motion is reported to the hub.
Anyone has a idea where this could come from?


I installed a second z-wave 4 in 1 and upgraded the handler and everything seems to work properly except the LED option. I have it set to 1 (for no LED) but it is still flashing every few minutes on both sensors. Any thoughts?

Is the bottom center tile empty or does it show the number of pending changes?

They both show ‘7 change(s) pending’.

This device sleeps so after making changes you have to wake it up.

To wake the device up, use a paperclip to push the recessed button on the bottom of the device.

I thought I already did that. I will try it again. Thanks for your help.

So I pushed the recessed button last night to wake up the devices but no change. When I woke up this morning I checked and I believe the led is behaving correctly now. The bottom tile still says ‘7 change(s) pending’ but I haven’t made any new changes in the past 24 hours. So I pushed the button again this morning, the led flashed red, but no changes to that tile. Also, the last update tile shows 11 hours ago. Am I doing something wrong? One more thing, on the ‘Recently’ tab on one of them, the last reported activity was 11:00 PM. Then there are only 2 active and 2 inactive reports from then until now. Prior to that, there are constant report items of temp, rh, and Illuminance every hour.

It sounds like you’ve been tapping the Refresh button. If you tap it once it tells the device to refresh the values the next time it wakes up, but if you tap it twice it clears the cached settings. Clearing the cached settings causes it to display 7 changes pending and all of the settings will get resent to the device the next time it wakes up.

The default wake up interval is 12 hours so if you haven’t changed that setting the pending changes tile should clear on its own within a few hours.

The device takes measurements every 3 minutes and if the new values exceeds its Change Trigger the device will report the change to SmartThings. If that was occurring hourly it was just a coincidence because the device doesn’t have options for interval based reporting.

What do you have the Change Trigger settings set to?

FYI,if you enable the debug logging option in the settings and open live logging in the IDE before pressing the recessed button, it should log the setting changes that were sent to the device and confirmed. If nothing gets within 30 seconds of pushing the recessed button then you should try again because the device didn’t wake up the first time.

My Change Triggers are set to 10 for temp and rh and 50 for light. Motion retrigger is set to 255 (don’t use it). Check in interval is set to 12. Debug logging is enabled.I just tapped the button again, red led flash, no change to the tiles. Still ‘7 Changes Pending’ and the Update tile now says 8:33AM which is over an hour ago. I am getting activities reported in the recently tab though. I feel like I am missing something. You are being super helpful and I really appreciate it. I know you are probably swamped and have a million other things to do but is there a chance we could chat real time?