[RELEASE] Monoprice/Linear/GoControl WAPIRZ-1 Motion Sensor with Temperature and Battery Device Type (Updated)

Per #2) I see if I take the back cover on and off I see the ‘TAM-PER’ icon come and go. So I’m all set on this one.

1 Like

The device will report the battery status between 24 and 72 hours. So just wait for it to happen. Alternatively you can hit the request update button and the next time it wakes up (typically 6 hours) it will request an update on all key parameters.

You’ve figured out the tamper notification. Opening and closing the device resets it.

Battery level is still showing 1%. Tapping the ‘Request update’ button on the bottom of the screen doesn’t seem to do anything.

Seems crazy that the battery percentage isn’t updated more frequently.

As with all Z-Wave devices the battery notifications are pushed by the
device to the hub or polled when requested. In this case the device seems
to be reporting 1% even when polled.

Try to remove the battery and reinsert it into the device. Are you using a
standard LiIon battery? Sometimes it can take a day or so to update, seen
it happen with locks also - probably a firmware quirk.

I’ve removed the two alkaline AAA batteries from the both of my motion detectors (and reinserted them) and it doesn’t seem to help.

On a third unit I did ‘Remove’ and reinstall the 15902 motion detector from my setup and that move the battery level on that one from 1% to 100%, but that is kind of a pain.

Kind of makes me wonder where the 1% battery level is stored. Must be in the HUB? Maybe I’ll go pull power (and the batteries) on my HUB and see if that works.

1 Like

So I edited the MAIN line to show motion instead of temperature and it works nicely when I select the device. However, in my list of THINGS I get a big blue MOTION text and it doesnt change whether there is or isnt motion reported.

Can you help setup the code to make the motion primary for both when the device is selected and when the seen from the list of things?

Here is a snapshot of what I mean and keep in mind the device shows a grey No Motion status when I select it:

That’s an ST app bug, please report it to ST support, its’ working fine there on our test devices. There’s nothing in the code to control the behavior of things apart from telling it what the primary attribute it (motion or temperature), which you have done (as described here [RELEASE] Monoprice/Linear/GoControl WAPIRZ-1 Motion Sensor with Temperature and Battery Device Type (Updated)).

The app isn’t updating the value from the platform, try this scroll to the top and pull it down to refresh the page and it should force it to get the latest value from the platform.

Unfortunately, no change upon refresh. I will report the bug. Thanks.

Hello @RBoy

I got a few zwave plus devices from monoprice recently. I was looking for a solution to use them with ST but so far I haven’t been so lucky. Would your app/device handler enable mono price sensors (15902, 15270, 15271) to work with ST’s first gen hub? Also, would your annual license expire after a year or is it about app updates/new release?

You timing couldn’t have been better. We will be making an announcement in the coming weeks about a partnership with Monoprice. We are in the final stages of releasing custom device handlers for many of their products including the ones you mentioned above. Keep your eyes peeled :slight_smile:

1 Like

Hopefully they will work better than the 3 units I just returned. @RBoy was using your device drivers and the battery level would never go back above 1% after changing batteries and the motion detection was marginal at best. Units I had were the 15902.

Looking forward to it. Would it work with first gen hub as well?

Thanks.

Linear/GoControl WAPIRZ-1 Motion Sensor with Temperature and Battery Device Type - Version 02.03.00

  • Added a setting to allow users to select the Primary sensor to show in the ‘Things’ page (Temperature or Motion)
1 Like

We now have an official partnership with Monoprice, for the Monoprice Motion Sensor with Temperature device handler (v1 and v2) check out this thread:

We will continue this thread for the GoControl / Linear Motion Sensor with Temperature Sensor

Linear/GoControl WAPIRZ-1 Motion Sensor with Temperature and Battery Device Type - Version 02.04.03

  • Patch for firmware issue which can cause reporting negative temperature under certain circumstances
  • Improved tile layout for updated SmartThings mobile app
  • Added tamper alerts and improved reporting after initial pairing

I just used your handler thinking itll solve my problem of pairing this motion sensor to the hub. But im still unable to pair it.

I accidentally removed this device without excluding it and now i am unable to pair it back.

I have tried everything ive read including a 1 sec. Tamper switch pres which you and the manual suggests; i have also tried 3 pinhole presses with the same outcome. I have attempted these after excluding, rebooting the hub.

Thanks in advance.

Hi there. If you’ve accidentally removed the device without excluding it first you won’t be able to pair it again without first excluding and resetting it.

See this article on how to put the hub into exclusion mode using the Classic app and then follow the instructions in the first post to exclude the device (keep it close to the hub).

After excluding it reset the device as described in the manual and then proceed to pair it. After pairing use the pin to push the button to force an update it should start working fine.
Not pairing typically means that the exclusion wasn’t successful and you may need to try more than once to exclude it until SmartThings confirms that the device was excluded.

Hope this helps.

1 Like

Does this run Local or in the cloud?

hi there,
i just migrated from wink to samsung smartthing v3 hub.
I have 4 of gocontrol wapirz 1 motion sensors but I cannot find in the ST app anything that matches these devices when i go and add a device, the brand is not there. In fact none of Linear, monoprice or gocontrol, nordic are there. Plz help

If you’ve already installed the device handler, you just need to pair the device with the hub.
For Z-Wave and ZigBee device you don’t need to select any brand. Open the new ST app, click on +, Click on Devices and at the bottom click on Scan nearby. Now put the device into pairing mode as explained in the first post and it should find and setup the device for you.