[RELEASE] Lennox iComfort Thermostat

So that is why it says it is off, I will try that. Did you ever get it working while in program mode? Mine is always in program mode.

Anyone else having an issue with the mobile app UI in 2.14.0?
I’m able to add all of my devices to rooms except for the device setup with this handler. As a result, I can’t see it in my favorites or in things.

Another Noob here. I have set this up and I can control my icomfort with the ST app. But I’ll having some issues with controlling it from my Google Home.
If I ask the current temperature, it response with something like “It is currently 21C, and the thermostat is currently off”. So the thermostat is connected and communicating one way at least. But I have not been able to control the temperature at all. If I tell it to “Raise the thermostat temperature” or “Set the Heatingsetpoint on the thermostat to 20 degrees” It just responses saying that is not supported. I have tried wording it in every possible way I can think of.
Am I missing something here? Anyone have a suggestion for something I should try?
Thanks

does anyone know if this works for the new iComfort S30 WiFi thermostat?

I don’t think so.

Ok so I’ve found for Armstrong Thermostats the API is Https://services.mycomfortsync.com. I was able to login and it saw my 2 thermostats. It fails when adding a thermostat with the error:

“groovyx.net.http.HttpResponseException: Not Found @line 243 (apiGet)”

In my Things list it shows the newly added thermostats as missing tiles. I am also unable to remove these devices, the log say:

" groovy.lang.MissingMethodException: No signature of method: script_dth_b12b0d28ec69871c7ceb017b16db296d89d5f9e84f93f7494582e5520a96b075.getAllChildDevices() is applicable for argument types: () values: []
Possible solutions: getChildDevices() @line 79 (uninstalled)"

Does anyone know how to add the tiles or force them to be deleted? I have also tried through the IDE as well.

Homekit Integration hits the S30’s in the next 3 weeks. I’m running a beta version and using homebridge to give my smart things hub control of my 3 S30’s and my 1 E30. Working like a charm as long as Lennox’s could site stays stable.

2 Likes

FYI, for people who are messing with this, I just had a new thermostat installed today and it came with the iComfort Wi-Fi Thermostat. I just set it up, and setup the copy-ninja smartthings device, and it works flawlessly. I already have it integrated into my Core pistons! Thanks!

Unfortunately I have no idea if this works with newer iComfort thermostats, I only have access to the Wi-Fi thermostat with the white bezel. Unless they changed the api/access I would assume it should still work.

as an aside, Lennox has some server issues, it took me a while to register, and then I haven’t been able to use their app either. I was shocked this thing worked. I was disappointed leaving my ecobee but probably won’t miss it as long as this can talk with smartthings.

Came here to ask about the S30. I see several others have had the same question but I haven’t seen any real answers: Has anyone made any progress integrating with the S30?

I get the same response. I can use the app in the ST classic app. It shows as disconnected in the New ST app. I have a v3 hub. Does anyone know if smartapps are working with the v3 hub?

I also just got the ICOMFORT WI-FI with my new units. Where do I find the info to integrate it with my ST?

The Homebridge solution referenced above seems to be the only option for now. The iComfort S30 only works with Alexa and HomeKit for now. I haven’t done it yet but I think wiring up the ST hack to talk to Homekit will get this thermostat into the system. On a parallel track I have a call into Lennox to see if they can help me install my old Ecobee onto this new piece of crap furnace. I like the furnace- I just hate the required thermostat with non standard wiring.

Can you provide some detail for how you have this set up? Should I just follow the Homebridge install directions? Has the Homekit integration been released?

I’m having problems getting into the server that supports the Lennox thermostats. I added some debug statements to verify where this is happening and it is right when I hit “Save” when adding the Smartapp on my phone (android). Not sure the phone type matters here because this is failing a simple authentication check via HTTP to Lennox Server. I’ve attached debug listing from the web IDE.

Can anyone confirm if the Lennox servers are up? Do they still accept basic authentication? I can’t find any Lennox documentation on their API server. By the way, I am using the credentials that work perfectly from the Lennox website and the Lennox android app.

Thanks in advance,
Jeff

I realize this post is 2 years old. Did you get any volunteers? Was anyone able to make any progress towards integrating with the S30?

Just thought I’d update this thread for all those who are trying to use this. It’s January 1st 2019 and i was able to successfully implement these Thermostat controls for the Lennox iComfort.

Using v3 ST hub with Android ST Classic App. Only couple things to note:

  1. On instruction #3 instead of copying code to “My Device Type” (which doesn’t exist anymore) you copy it to “My Device Handlers.”

  2. After completing step #3 log out of your mobile app and log back in.

Should be good to go!

And just to clarify, you got an iComfort connected not the iComfort S30?

Yes, Correct!

Hey Brian,

Just looking back on this thread and saw your exciting post. Could you clarify which instructions you were referring to?

Are there other instructions than the original from OP?

"
Installation:

  1. Load [iComfort Service Manager ](h t t p s://raw.githubusercontent.com/copy-ninja/SmartThings_iComfort/master/iComfort.ServiceManager.SmartApp.groovy) in [SmartApp ](h t t p s://graph.api.smartthings.com/ide/apps) section
  2. Load [iComfort Thermostat ](h t t p s://raw.githubusercontent.com/copy-ninja/SmartThings_iComfort/master/iComfort.Thermostat.SmartDevice.groovy) in [SmartDevice ](h t t p s://graph.api.smartthings.com/ide/devices) section
  3. Publish all of the above
  4. In your mobile app, tap the “+”, go to “My Apps”, furnish your log in details, and a list of devices will be available for you to pick
    "

I was referring to the instructions on Github which are more or less the same:

1 Like