[RELEASE] Homebridge SmartThings v2.0

Only if you want to control from wan, yes those are the Apple rules.

1 Like

Can you elaborate on how you set this up? I’ve been looking for a cleaner integration of Ring Alarm w ST.

Thanks.

Hey Mike, it isn’t exactly clean, but I don’t have to set up any Lambda function/API gateway config. I’m using @tonesto7’s plugin in conjunction with homebridge-ring. I created a virtual switch for each Ring alarm mode (disarmed, armed stay, armed away) as the automation options on the Homekit side are limited. In the ST Homebridge SmartApp, I added the virtual switches to make them available in Homebridge. Then I used webcore to change the state of these switches based on SHM monitor state changes. Once all of that was set up, I have an old iPad acting as a home hub and set up automation in Homekit to switch the Ring Alarm status based on the virtual switch changes. Now if I change the state of SHM, it will trigger the virtual switch and then Ring Alarm.

Again, not clean by any stretch, but it works.

Good solution!
I have ring alarm and SmartThings SHM linked and synced in the Apple Home app.
Disadvantage is that I can not control Smartthings and Ring alarm independently (through Smartthings). Advantage is that I have less switches and rules to worry about.

1 Like

Would anyone be willing to share what their final config.json file looks like?

And any idea what I’ve got going on here? I followed these instructions here:

And this is what’s happening in the terminal repeatedly until I cancel out…

Another question is the config.json came up like this on top but how do I combine that with what the smartapp gives me?

The config generated by the app is pretty much a final

Just edited my comments would you mind looking that over if you get the chance?

@GRClark

Looking at the logs it’s an issue with the config-ui-x plugin.

I think it’s related to the nodejs version on the system:

Dec 20 14:07:53 PECAN homebridge[26109]: was compiled against a different Node.js version using
Dec 20 14:07:53 PECAN homebridge[26109]: NODE_MODULE_VERSION 64. This version of Node.js requires
Dec 20 14:07:53 PECAN homebridge[26109]: NODE_MODULE_VERSION 72. Please try re-compiling or re-installing
Dec 20 14:07:53 PECAN homebridge[26109]: the module (for instance, using `npm rebuild` or `npm install`).

If you run node -v in the terminal what version does it show? Also what distribution of linux are you running?

On my Raspberry Pi 3B+ it says v12.14.0
Tried on my workstation too running Linux and says v8.11.1

What should it be?

definitely v10+

Well my Pi meets that requirement. I’m going to try finding how to completely remove HomeBridge and start over again.

@tonesto7 I was able to get it working using the Docker image method. My question for you is the config.json it’s got by default looks like this:

https://drive.google.com/file/d/1gTgylEVLBMeZw50KaBuZlgsNkskgBOxN/view?usp=drivesdk

The SmartThings one from your smart app looks like this:

Do I completely get rid of what’s there already or do I combine the two together?

I can only generate the chunk for the platforms block but not the whole config.

Here is how it should be formatted:

{
    "bridge": {
        "name": "Homebridge",
        "username": "CB:22:3D:E2:CE:31",
        "port": 51826,
        "pin": "033-44-254"
    },
    "accessories": [],
    "platforms": [{
            "name": "Config",
            "port": 8000,
            "auth": "form",
            "restart": "sudo -n systemctl restart homebridge",
            "sudo": true,
            "log": {
                "method": "systemd"
            },
            "platform": "config"
        },
        {
            "platform": "SmartThings-v2",
            "name": "SmartThings-v2",
            "app_url": "https://graph.api.smartthings.com:443/api/smartapps/installations/",
            "app_id": "APP ID HERE",
            "access_token": "ACCESS TOKEN HERE",
            "direct": true,
            "direct_port": 8000,
            "excluded_capabilities": {
                "SMARTTHINGS-DEVICE-ID-1": [
                    "Switch",
                    "Temperature Measurement"
                ]
            },
            "logConfig": {
                "debug": false,
                "showChanges": true,
                "hideTimestamp": false,
                "hideNamePrefix": false,
                "file": {
                    "enabled": true,
                    "level": "good"
                }
            }
        }
    ]
}

Thanks so much for the new Homebridge 2.0 Smartapp and plug-in. Now I can use my Apple iWatch in controlling SmartThings lights and switches.

BTW if anyone is having problems in installing, updating or configuring Homebridge on a Raspberry Pi here’s an excellent link on getting everything working; https://github.com/nfarina/homebridge/wiki/Install-Homebridge-on-Raspbian.

1 Like

In the classic app, just installed this new smart app.

I cannot find this:

" * app_url & app_id & access_token Required
To get this information, open Homebridge (SmartThings) SmartApp in your SmartThings Classic Mobile App, and tap on “View Configuration Data for Homebridge”
Notice: The app_url in the example will be different for you."

Specifically: “View Configuration Data for Homebridge”

Where is this?

Which I may have found where the render config.json file is.

In HOOBS web interface, though, the V2 install has been running for 22 minutes, and not finishing, so not sure whats next…I would almost think I need it to finish to add config in this web interface.

For this using HOOBS, I just went into Advanced, and copy/paste the required items into the JSON file.

Watched football and came back 7 mn later, and all smartthings that I defined were in Home app in iOS. Freaking sorcery, man.

@tonesto7 in case this helps others, I will note there is this error in the log in HOOBS (but everything seems to function):

Cannot find module ‘/src/index.js’. Please verify that the package.json has a valid “main” entry
Unable to determine plugin type for “homebridge-smartthings-v2”

I could have missed something but I am just sharing for those wanting to try out this incredible integration that is helping me “bridge” to complete HomeKit for the House for the family/kids to use with Siri.

2 Likes

How can I get the device ID and what is the attribute for smoke? Some of my locks have a smoke and door contact lol?

Also, the virtual switches for controlling routines stopped working for me on the older version (they don’t run the routine when turned on ) so I deleted everything and started over with v2.0. But the same issue persists on v2.0. Anyone else with this issue?

UPDATE: I turned off “Send HomeKit Commands Locally” on the SmartApp, restarted homebridge and it started to work again. Any idea why I can’t send local commands to the hub anymore?

Sorry about that but The local commands will be resolved in version 2.1.

Hopefully, release right after the new year

1 Like