HomeKit Integration Video Tutorial (Unofficial Integration Using Homebridge)

requires_server
homekit

(MacTechGenius) #1

I made a quick video tutorial on integrating SmartThings with Siri:

Makes controlling SmartThing’s so much easier, I got tired of dealing with the slow iOS app. Takes 40 seconds to load!

Instructions for Raspberry Pi Homebridge Install: https://www.mactechgenius.com/2017/06/07/smartthings-homekit-integration/


Everything is down? (Major Cloud outage affecting different accounts differently) April 13-14 2017
Homekit Software Authentication Finally Coming
Smartthings, gocontrol/linear garage controller and siri
#2

There is a current active discussion thread for this integration. I’m sure people there would be interested in the video.

I know you mentioned this in the video, but you didn’t in your post, so we should mention here that this entire method depends on the use of the Phillips hue bridge simulator in a way that violates the terms of service for Phillips developers.

(It is not supposed to be used for anything other than testing Phillips hue projects.)

So people may find this code on the Internet from someone who did violate those terms of service. Then install it for themselves.

This is the equivalent of receiving a stolen car as a gift. You aren’t necessarily guilty of the theft, but the legal owner might come take it away from you at any time.

Which is to say, there’s no telling how long Phillips hue is going to allow this method to work. So if you choose to base your home automation on it, be aware that it is an unauthorized method.

There is currently no official SmartThings/HomeKit integration. For discussions of why not and what might be available in the future, see the following thread:


(MacTechGenius) #3

I hope Phillips doesn’t eliminate this integration, so much easier sliding up and turning on a light or asking Siri. My SmartThings app takes 40 seconds to open and the UI is super slow and outdated, I hope this integration remains and SmartThings improves their app.


#4

No way to know for sure, but it would definitely be nice to have smartthings/HomeKit integration. :sunglasses:


(Jam Dawz) #5

Unfortunately, I was not able to configure the JSON Complete API smartapp after installing from the IDE. The app does not respond. I ended up with 3 installations because I wasn’t sure if it was installing at all. Now, it gives the spinning progress star then quits. Is this method dead?


Any help is greatly appreciated!


(MacTechGenius) #6

Can you post a screenshot of your smartapps page?


(Jam Dawz) #7

I apologize for the hasty post. I had forgotten to enable OATH in the IDE. My apologies. I will carry on with the installation. @Kamran Thank you for the quick response!


(MacTechGenius) #8

No problem, I will also note this on the video


(Joe D) #9

This works great, thank you for this integration.


(JBrown) #10

Did you get it working?


(Jam Dawz) #11

Yes, I had to enable OAUTH through the IDE! Works like a champ now!


(Jam Dawz) #12

Oops, spoke too soon!!

@Kamran As of last night, Homebridge and SmartThings are not communicating.
Homebridge is still running on my Mac Mini. The app id and access token haven’t changed in the smartapp.
I restarted the Mac Mini and homebridge.
Each device in the Home app shows “No Response” and the scenes “Failed”.

I haven’t changed anything! Did SmartThings changed something?


(MacTechGenius) #13

It still works for me


(Jam Dawz) #14

Wonderful for you. Any suggestions to re-establish connection with HomeKit?


(MacTechGenius) #15

Is the json API working fine?


(Jam Dawz) #16

I believe so…


(MacTechGenius) #17

What is your devices app showing? Did you recently add anew accessory?


(Jam Dawz) #18

[quote=“kamran, post:17, topic:59963”]
Did you recently add anew accessory?
[/quote]

No


(MacTechGenius) #19

Did you download the devices app from the AppStore? You should have used it to setup homebridge initially


(Jam Dawz) #20

I’m not sure I know what you mean. I’ve been using the iOS 10 “Home” app with Homebridge for the last 3 weeks and haven’t had a single problem until last night.