Homebridge-smartthings not working for me


(Blair Dee) #1

I have been using homebridge with homebridge-smartthings (https://github.com/pdlove/homebridge-smartthings) for a while now and it has worked well. unfortunately a few days ago I noticed that most of my devices were missing from the home app on my ios device.

I found that there were updates available to the homebridge-smartthings plugin/smartapp so I updated it. now I still cant seem to get it to work correctly.

I followed the steps here:

First I tried to just update it, and when that didnt work I tried removing and reinstalling the smartapp.

one thing I noticed is that it says if it is installed properly you shoudl se the following when you launch homebridge in the terminal:
[1/29/2017, 8:28:45 AM] Homebridge is running on port 51826.
[1/29/2017, 8:28:45 AM] [SmartThings] Direct Connect Is Listening On 192.168.0.49:8000
[1/29/2017, 8:28:45 AM] [SmartThings] SmartThings Hub Communication Established

but when I run homebridge I only get the first two lines. I do NOT get:
[1/29/2017, 8:28:45 AM] Homebridge is running on port 51826.
[1/29/2017, 8:28:45 AM] [SmartThings] Direct Connect Is Listening On 192.168.1.3:8000
[1/29/2017, 8:28:45 AM] [SmartThings] SmartThings Hub Communication Established

I did have to specify the ip address of my machine (Mac Mini) in the config file as 192.168.1.3 because if I dont, then it tries to run on 10.96.10.6.

any ideas why it doesn’t seem to be start up and running correctly - or even how to troubleshoot further?


(Jg506) #2

You need to update the smart app too (Complete JSON something)


(Blair Dee) #3

thanks for the reply. I did update the smartapp to the latest version as well.


(Jg506) #4

fwiw I don;t get line this line but all is working well. Your post is bit confusing as to what is shown in your log and what isn’t


(Jg506) #5

Update - I was bothered why I do not get this line as well (although everything was working well, strange…). My problem was related to docker and I had to specify the IP of the host in the config file explicitly (just like you did), and then the missing line appeared. Anyway, if yours found different IP on totally different subnet it could be because you are running it as virtual machine or container. If that is the case you should be using bridge or host mode for networking and not NAT. Other possibility is that port 8000 is blocked on that computer because of firewall. Using fing for iOS run services scan your computer IP and verify port 8000 is open. If fing cannot see it your ST hub also can’t.


(Blair Dee) #6

Thanks for the reply!

so I am just running homebridge on my mac mini - its not in a docker or virtual machine or anything so I am stumped about why it seems to want to run on a different ip on a different subnet.

what weird is that once homebridge is running, I can go into the home app on my iphone and add the homebridge. But for some reason, none of my Smartthings devices show up. just the bridge.

I did go into the JSON Complete API smartapp in smartthings on my iphone and check off all the devices i want to use.

and I just used fing (thanks for the tip there - nice tool) to confirm that port 8000 is open.

it seems like for some reason homebridge is just not communicating with smartthings to pull over the devices.


(Blair Dee) #7

so I also just noticed this in the terminal on startup of homebridge
[2/21/2017, 9:37:27 PM] [SmartThings] Fetching Smart Things devices.
[2/21/2017, 9:37:28 PM] [SmartThings] Error received type undefined - undefined
[2/21/2017, 9:37:28 PM] [SmartThings] Unknown Capabilities: []

for reference, my config file looks liek this:
{
“bridge”: {
“name”: “Homebridge”,
“username”: “CD:22:3D:E3:CE:30”,
“port”: 51826,
“pin”: “031-45-154”
},

      "description": "JSON API",
      "platforms": [
          {
             "platform": "homebridge-smartthings.SmartThings",
             "name": "SmartThings",
             "app_url": "https://graph.api.smartthings.com:443/api/smartapps/installations/",
             "app_id": "9529a948-d81c-4c19-ba20-03eea466c2bb",
             "access_token": "66f808d0-3522-425d-bc7e-6a9b67b7fa01",
             "update_method": "direct",
             "direct_ip": "192.168.1.3"
          }
      ]
  }

(Jg506) #8

Looks like a problem with the smartapp or the first device. Have you published the smartapp after updating? It is not enough just to update to latest using git integration
Other troubleshooting step you could try is removing all devices from the smartapp and exposing just one simple switch first so if you have problematic device you can isolate it.


(Blair Dee) #9

thanks for the suggestions. I definitely published the smart app. I was able to see a different icon for the smart app in my smartthings app so i know the changes got published.

I tried unchecking all the devices except one switch and then stopped and started homebridge on my mac mini and still no accessories are showing up at all in my home app :frowning:


(Blair Dee) #10

I am also seeing this when i start homebridge on my mac mini

[2/26/2017, 9:08:22 AM] [SmartThings] Fetching Smart Things devices.
[2/26/2017, 9:08:23 AM] [SmartThings] Error received type undefined - undefined
[2/26/2017, 9:08:23 AM] [SmartThings] Unknown Capabilities: []
Scan this code with your HomeKit App on your iOS device to pair wit


(Dan) #11

After seeing this posted, I checked my Homebridge today. It was blank. I ended up going into the JSON SmartApp and simply clicking “Done” and then restarted my Raspberry Pi. Everything came back after that. Just restarting the Pi did NOT do the trick.

Unfortunately, all of my devices are now back in the “default room”. This is about the 3rd time this has happened. I really don’t even use Homekit… Not sure why I bother… :frowning: