[RELEASE] Homebridge SmartThings v2.0

I used to have v1.0 on a raspberry pi zero, but I messed something up and used v2.0–much easier to setup (prebuilt pi image) and update. I would say that if yours is working fine, then don’t change it.

I upgraded a while back using the provided instructions to the letter. All went smoothly for me and the response is very good. In fact I think it’s faster to use the Home app that the new ST app. Also make sure you install the Homebridge Config UI X plugin. It makes monitoring and updates a breeze.

I am having issues with some custom DTHs for Jasco/GE dimmers and switches that @mwav3 created.

They can be found here: https://github.com/mwav3/smartthingscode

For whatever reason, the switches/dimmers are seen in the Homebridge SmartApp and I classify them as lights appropriately. In HOOBS, however, they have zero function.

I have zero control over them. If I switch to the stock Z-Wave Dimmer DTH in SmartThings, the functionality works. Any ideas on what is missing from the DTHs that could potentially limit functionality in Homebridge/HOOBS?

I had this working with ST Classic…when I changed to the new Smarthings App - I am unable to add more sensors/switches. Does anybody else have this problem?

I decided to upgrade to version 2. I brought my node.js/npm/homebridge software up from the dark ages to the latest releases. I couldn’t update the tonesto7 plugin as I got permission errors. It worked from the command line using sudo, but homebridge is still saying it’s out of date. So, it’s time to move to the new version. Reading through this thread, it’s no long smartthings v2 just homebridge SmartThings. Homebridge shows that as verified.

There are a few different sets of instructions for someone updating from an old version. They all say

  • delete hub from the home app
  • delete plugin from homebridge

What I’m not sure about is in SmartThings. Do I delete tonesto7 from My Smart Apps using the web browser interface to my hub and/or delete the smartapp from (in my case) the iOS app. The GitHub instructions mention looking for v2 when installing the new app. I don’t see that in the add smartapp list, just “Homebridge (SmartThings)”. I presume this is the correct one. Is GitHub repository the best place for the latest instructions? I use the interface everyday and don’t want to break it by doing something stupid.

For Homebridge installation instructions go here:

You can install the Smartthings plugin via the GUI.

For the SmartThings Smartapp it’s enough if you delete the old Smartapp in the SmartThings app.

Then it is easiest if you use the ST-Community-Installer app to install the new “Homebridge v2” Smartapp.

You then use the new appID and token from the Homebridge Smartapp and enter it in the config of the Homebridge plugin.

After that everything should sync!

1 Like

I had the same problem that started with the migration to the new Smartthings app. Homebridge was still working but I was no longer able to add or remove devices.

It was due to my Nest thermostats that I integrated into Smartthings via MyNextManager. Once I removed them from the Smartthings plugin it started syncing again. I am now using the Nest plugin to connect nest to Homebridge.

A long time ago a Schlage lock caused the same problem but that was fixed in the plugin code.

1 Like

Shoot…how am I to know which one is causing a problem!

The device is probably not functioning in Home. Also, I would start testing by excluding the ones that have custom DTHs first.

I finally got v2 installed. I ran into a few problems. I thought I would share in case others have the same issues.

The first was that I couldn’t uninstall the old tonesto7 plugin using the homebridge web interface. It gave me permission errors. I ran the same command in a terminal app (macOS) adding sudo. That run without errors, but didn’t remove the plugin from the web interface even after restart. The fix was to add -g to the command:

sudo npm uninstall -g homebridge-smartthings-tonesto7

I then went on to install the st-community-installer. It installed but wouldn’t allow me to add a new repository in settings under My SmartApps in the ST web interface to the hub. I fixed that problem by disconnecting and reconnecting to GitHub. My original connection was years old.

My final issue was getting homebridge to see the devices. This was probably me not reading all the instructions and assuming the community installer would have done everything for me. What I missed was copying the raw data from smartapp in ST to the config file in homebridge just like I did back in the olden days. My homekit/homebridge/smartthings/home-assistant chain is now back up.


I’ve had Smartthings working on Homebridge for the past couple of months with no issue, however today I’m trying to remove a device and add a new device through the SmartApp and it doesn’t seem to be working. When I look in the Homebridge logs I get the following:

[10/9/2020, 6:05:24 pm] [SmartThings-v2] INFO: SmartThings-v2 Hub Sent Preference Updates
[10/9/2020, 6:05:24 pm] [SmartThings-v2] INFO: SmartThings-v2 Updated Hub IP Preference | Before: undefined | Now: xxx.xxx.xxx.xxx
[10/9/2020, 6:05:24 pm] [SmartThings-v2] NOTICE: Updating Global Values | HubIP: xxx.xxx.xxx.xxx | UseLocal: false
[10/9/2020, 6:05:26 pm] [SmartThings-v2] GOOD: Received request from SmartThings-v2 to refresh devices
[10/9/2020, 6:05:26 pm] [SmartThings-v2] GOOD: Refreshing All Device Data | Source: (ST Requested)
[10/9/2020, 6:05:36 pm] [SmartThings-v2] ERROR: getDevices Error: undefined | Message: timeout of 10000ms exceeded
[10/9/2020, 6:05:36 pm] [SmartThings-v2] ALERT: Total Initialization Time: (10 seconds)
[10/9/2020, 6:05:36 pm] [SmartThings-v2] NOTICE: Unknown Capabilities: [“Holdable Button”,“Voltage Measurement”,“Outlet”]
[10/9/2020, 6:05:36 pm] [SmartThings-v2] INFO: SmartThings DeviceCache Size: (89)
[10/9/2020, 6:05:36 pm] [SmartThings-v2] INFO: Checking Package Version for Updates…
[10/9/2020, 6:05:43 pm] [SmartThings-v2] INFO: INFO: Your plugin version is up-to-date
[10/9/2020, 6:05:43 pm] [SmartThings-v2] NOTICE: Sending Plugin Status to SmartThings | UpdateAvailable: false | newVersion: 2.3.8

Any ideas on what could be going wrong? I can still control all devices, see status, etc. Just can’t seem to add/remove new devices into or out of Homekit.

Please see 4 posts above. Since the migration to the new app there seam to be some DTH that dont work anymore with Homebridge and make the updates fail.

1 Like

Thanks, but I don’t think it’s a DTH issue. I only setup Homebridge after I migrated to the new app since it was horrible and slow. Everything was working fine when I was adding and removing devices then. There have been no changes to any of my custom DTH since then.

In any case, I finally got it to work by going into the Smartapp a few times and saving each time even if I made no changes. It eventually worked on the 4th or 5th try.


i’m new to Smartthings but have a decent amount of devices with several hubs in HomeKit.
Because of HomeKit i have a home bridge installation an a ioBroker installation as well.

From what I’ve read it should be possible to integrate Smartthings devices in HomeKit, but i’m looking for a solution the other way around.
Since I have alle devices in HomeKit running i’m looking for a solution to show all devices in Smartthings (if there is no native support like my Hue devices). For example i’ve got devices from Homematic (switches, thermostats, windows blinder etc.) and would love to see them in Smartthings.

Are there any ideas for showing devices this way?


Afaik homekit is a one way street

At least a switch should be possible?

Virtual switch in Smartthings - home bridge plugin - automations in HomeKit between virtual switch and native HomeKit switch…

I have never tried the virtual dimmer idea. but virtual switches do work. Virtual momentary buttons don’t seam to work anymore since the migration to the v3 app.
The SmartThings plugin also creates virtual switches for routines if that helps.

1 Like

I’ve done some testing with Alexa virtual switch as well with automations in HomeKit to “sync” two switches.
Must say… I don’t like either of them :slight_smile:

This is sad because my refrigerator does support Smartthings and I thought i could use my whole “HomeKit world” on this shiny screen… i can’t :frowning:

I assume this app needs to re-rewritten due to not grabbing the scenes on the new SmartThings app.

Any chance to see Samsungs Robot vacuum support added to homekit to control via switches?

love your work BTW