[RELEASE] Hank Four Button Scene Controller

Edge Driver Installation:

  1. Go to The Smartest House’s Edge Driver Channel and log in with your Samsung/ST account.

  2. Enroll your hub

  3. Click “Available Drivers” (If you still see the “Enroll” button then try clicking it again and if that doesn’t work load the page using the original invitation link again)

  4. Click the “Install” button next to the “Hank Scene Controller” driver.

  5. Wait a few minutes

  6. Join the device

There’s no need to use a custom driver for the One button model so the driver doesn’t support it.



All of the information below is for the old Groovy Handler which will stop working soon.

This is a device handler for the following devices:


Looks like a cool little remote

So, I bought one of these and the driver works great. I know I can just build a piston to control what the button pushes do, but is there a recommended smart app I could use instead? I’m using the Kyse Remote Controller smartapp for my Aeon Minimotes, but it doesn’t seem to see the buttons on the Nanomote. I’m contemplating replacing all my Lutron Connected Remotes with either the Nanomote or moving those lights over to Hubitat and using Pico Remotes, so I’m hoping to run some tests with the Nanomote to see if I like it.

You could use the built-in button controller SmartApp.

SmartLighting also lets you link button pushes to actions (including setting one button to toggle a device on / off).

Hi Kevin.
I’m pretty new to SmartThings. It there someplace that details step-by-step or could you walk me through it?


Thanks so much. Although I’ve only started and scratched the surface of SmartThings, the support of the Community is AWESOME


1 Like

I spent quite a few hours trying to get this device handler to work for a recently purchased Aeotech NanoMote Quad. I just wanted to share my experience in case it helps other users, or facilitates improvement to this device handler.

I purchased the NanoMote Quad device with the intent of using it to control lighting scenes. I attempted to use Smart Lighting to set up lighting automations, testing with both the Smarthings app, as well as the Classic app. Neither app was able to recognize the four discrete buttons on the NanoMote device as available triggers, and both apps are behaving as if there is only a single button (i.e. only one button can be assigned as a trigger in the app and pressing any button on the NanoMote device executes the single assigned action). Nothing I tried worked to change that result (including testing other Smart Apps such as CoRE).

After fumbling around IDE and both Smarthings apps for some time, I ended up trying out an Aeon WallMote hander, which seems to be working (for now) - all four buttons for both press and hold actions show up as available triggers in both Smart Lighting and CoRE. ([[RELEASE] Aeon WallMote Dual & Quad - 2 & 4 Button]). I’m not sure if this is a permanent solution though.

Appreciate any feedback if I’ve not set this device handler up properly. I would prefer to us this handler specifically written for the Nanomote if I can get it to work!

Was the custom handler installed before joining the device? If so, did you verify that ST assigned it this handler?

Tap the refresh tile, wake the device up, wait about 30 seconds and then open the device in the IDE and check to see if numberOfButtons shows 1 or 4.

If that doesn’t fix it then open live logging, push each button about 10 seconds apart, and post the live logging results. You should also post the device’s raw description which is shown in the IDE.

I wrote the handler last May using a beta version of the device so it’s possible they changed something in the firmware. If you’re still having problems and I’m unable to figure it out with the information I requested above then I’ll try to get a hold of the latest model or at least the latest firmware for it.


Thanks for the prompt reply. I originally added the device before adding the handler. I then added the handler in IDE and edited the device to select the correct handler.

That said, after switching to the WallMote handler and then now switching back to your NanoMote handler to troubleshoot further per your feedback, numberOfButtons has updated to 4 and I am now able to assign actions to each button individually. I have tested assigning a few different actions to press and hold events for the different buttons and it seems to be working well!

Thanks again for your reply and I really appreciate your contribution with this device handler.


1 Like

My Quad is not working. I have installed the device handler and the app.
The device type is “Aeotec NanoMote”

[4d0844bb-0ce4-423a-a464-bd9956678afc]8:16:23 PM: debug Button 4 pushed

[4d0844bb-0ce4-423a-a464-bd9956678afc]8:16:23 PM: debug Button 4 pushed

[4d0844bb-0ce4-423a-a464-bd9956678afc] 8:16:13 PM: debug Button 3 pushed

[4d0844bb-0ce4-423a-a464-bd9956678afc] 8:16:13 PM: debug Button 3 pushed

[4d0844bb-0ce4-423a-a464-bd9956678afc 8:16:04 PM: debug Button 2 pushed

[4d0844bb-0ce4-423a-a464-bd9956678afc] 8:15:58 PM: debug Button 1 pushed

Above is what I got from live logging.

| |Raw Description|zw:Ss type:1801 mfr:0371 prod:0102 model:0003 ver:1.02 zwv:4.61 lib:03 cc:5E,55,98,9F,6C sec:86,85,59,72,5A,73,80,84,5B,70,7A secOut:26 role:04 ff:9600 ui:9600|
| — | — |
|Current States|* [battery]: 86 %

  • [lastCheckIn]: 04/03/2019 08:16:23 PM
  • [lastAction]: PUSHED 4|

Thanks for any help

The log shows that it’s detecting button pushes so what isn’t working?

It is showing only a single rectangular panel saying Button with a circle in the middle and Standby under the circle.
When I go to custom automation, it only shows pressed and held.

My guess is:
It appear the SmartThings App is showing the SmartThings Button graphics.

The issue is usually one of these things:

If you added the handler after joining the device you need to manually change the type to the custom handler and wake up the device up so that it set the numberOfButtons attribute to 4.

The new mobile app doesn’t support custom handlers so I have very little control over how that app displays things and you’ll most likely need to use the Classic app to see the button status. In theory, it should work as expected in the new mobile application’s apps, but I haven’t tested that.

I added the device after adding the custom handler and it the IDE display it correct.
So the issue is the new SmartThings app, I do not use the Classic app.

Thank you.

The custom device creator in the new app doesn’t current work with multi-button devices. They’re supposed to be making some changes to the new app the handle multi component devices some time soon i think.

@ krlaframboise Kevin, thanks for your great work on the Aeotec NanoMote scene controller DTH. I bought one and got it running right away (call it NanoMote #1). I’m using press of Button 1 to set a “Watch TV” routine and hold of Button 1 to restore lighting after done watching TV.

I bought two more NanoMotes for our master bedroom nightstands to toggle the nightstand lights on and off. I just installed NanoMote #2 and I expected to see a list of two NanoMotes on the main “Button Controller” page and was pulling my hair out because I couldn’t see the new one. I FINALLY spotted the tiny arrow to the right of the “Button” label and the instruction “First, select your button device.” I think the UI would be better and more intuitive if you had a list of the button devices on your home screen.

Here’s my problem. I set up NanoMote #2 using the same DTH as I used for NanoMote #1. I set up Button 4 to toggle my nightstand light on and off. Then I noticed that the buttons I had configured for NanoMote #1 were now defined for NanoMote #2.

I need to have completely different button control configuration on NanoMote #2. Likewise, NanoMote #3 will be a slightly different button configuration from #2. On NanoMote #2, button 4 will toggle my nightstand light on/off. On NanoMote #3, button 4 will toggle my wife’s nightstand light on/off.

How can I do this? Do I need to install the Button Controller DTH three times?

Thanks again! You made the hardware product useful with the SmartThings hub. You have to wonder why Aeotec itself didn’t do this.

If you’ve joined 3 Nano Motes then you should see 3 devices listed in your device list.

Use the Button Controller SmartApp to set actions for the buttons of each device. I’m not sure if that app is available in the new mobile app so you might have to use the Classic mobile app.

Thanks. I am using the classic app. I have never upgraded to the new app. When I went to set up my second NanoMote device yesterday, it showed the same button configuration as my first, already-configured NanoMote device.