[OBSOLETE] Four button Tuya Zigbee device DTH (DTH link in post #7) (Same device from multiple brands: Zemismart, Yagusmart, Losonho , DYHF, etc)

Hy everyone!

I just received a new device: a 4 Gang Scenario Switch (https://www.aliexpress.com/item/1005001287093949.html?spm=2114.12010610.8148356.23.2cba43c2YjoePj&spm=a2g0o.store_home.slider_6000150411057.0). Basically, it’s a Tuya Zigbee device with four buttons that works separetely, each one supporting three values: single click, double click and press.

SmartThings hub recognized it as a thing, and the Zigbee Button DHT “sees” the four buttons correctly, but it don’t work. Is there a way to integrate it? Below are the infos exhibited on the device page.

Thanks in advance for any help or suggestion!

Thing Device Switch Lonsonho

  • Name: Thing

  • Label: Switch Lonsonho

  • Type: ZigBee Button

  • Version: Published

  • Zigbee Id: BC33ACFFFE28BA75

  • Device Network Id: 2FAF

  • Status: ONLINE

  • Hub: Hub SmartThings

  • Last Activity At: 2020-09-23 8:29 PM BRT

  • Date Created: 2020-09-23 6:27 PM BRT

  • Last Updated: 2020-09-23 8:46 PM BRT

  • Route: [This Device (2FAF) ↔ Hub SmartThings

  • Metrics: * Last Hop LQI: 255
    * Last Hop RSSI: -23
    * Received Messages From Device: 181
    * Received Messages From Device (Duplicates): 0
    * Messages Transmitted to Device: 153
    * Messages Transmitted to Device (Failures): 10
    * Updated Time: 2020-09-23 8:26 PM BRT

  • Data: * application: 42
    * endpointId: 01
    * manufacturer: _TZ3000_vp6clf9d
    * model: TS0044
    * zigbeeNodeType: SLEEPY_END_DEVICE

  • Raw Description: 01 0104 0000 01 04 0000 000A 0001 0006 01 0019

  • Firmware: Check Now

  • Current States * [supportedButtonValues]:

                                  [ "pushed", "held" ]
  • button: pushed

  • numberOfButtons: 4

  • battery:

  • button: pushed

  • numberOfButtons: 4

  • healthStatus:

  • DeviceWatch-Enroll:

  • checkInterval: 60 s

  • DeviceWatch-DeviceStatus:

  • Preferences (edit): Name Type Value
    holdTime number 2

  • Execution Location: Local

  • Events: List Events

  • In Use By


I would start with the default zigbee multibutton DTH and modify it as needed.


Thanks prjct92eh2, I’ll try this way. I’m just a noobie without coding skills, but I’m persistent! :yum:

If you haven’t already looked through this thread, it might be worthwhile if you’re going to be digging in to custom code. It’s pretty buggy right now.

Thanks a lot, Steven! Any help is very welcome, once I imagine that I’ll spend some nights without sleep in order to make this device work! I think that firstly I must found a way to make the device work, but in the sequence the adaptation to the new standarts will be necessary. :upside_down_face:

Hy guys! The EcoSmart 4-button Remote DHT partially works with the device, once just the “pushed” value is recognized through this DHT, and the buttons 2,3 and 4 don’t answer to the commands assigned, but if I don’t assign a command to it they reproduce the command assigned to button 1.

I downloaded its code from SmartThings GitHub, and now I just need to find a way to activate the values “double” and “held”, and perhaps use some tweak to reduce the delay beetwen the command given by the button and the action desired, but it is secondary. The main objective now is to make all the buttons responsive and make they accept the other values.

Some tip to help a noobie without coding skills?

Hi. I was looking for this DTH and found the information on a youtube video:

SMARTTHINGS - Instalando e Configurando o Interruptor sem fio Zigbee 4 botões

Here is the link to the Device handler. It works very well for the 3 states for the four buttons.

Device Handler Zemismart 4 button


Hi Emilio!

Thanks a lot, it is working flawlessly!


1 Like

Some input on this, that you might find helpful:

First feedback: The device handler link above (=“Zemismart 4 button”) works perfectly with the Tuya Sceneswitch 4-button device. It detects the 4 buttons individually.

The more advanced functionality (double-press or hold) is however not supported by the dev. handler. But this is only a little drawback, as the 4 buttons basically work.

Now some tips/tricks:

If you need to trigger a routine in Alexa follow this procedure:
a) Create a virtual switch in SmartThings (use the web interface and not the app) and use the device handler “Alexa Simulated Switch” (code is easily found on github).
b) Alexa will discover/“see” the virtual switch instantly and you can now base a routine on that switch going on/open (or off/closed). (In this way you build a “bridge” between SmartThings and Alexa that otherwise is not there.)
c) In SmartThings you assign this virtual switch to one of the 4 buttons, so this virtual switch changes from “closed” to “open” when the relevant button is pressed.
d) In SmartThings you also create an automation that resets the virtual switch with a delay of 10 secs. Then the virtual switch will always be ready for another press on the button.

Repeat steps a) through d) for all 4 buttons, so you have 4 virtual switches each corresponding to a separate button. Voila!

1 Like

Hello guys and thanks for providing the DH. Got an issue here: i can see the device in smartthings app and shows when a key is pressed but i dont get to assign the keys. When i open the device i just see a message that is connected.

1 Like

Got it guys. I just removed and readded the devices and it works


Has anyone tried to use 2 separate switches so you can use more buttons?

4 Gang Tuya ZigBee Wireless 12 Scene Switch Push Button Controller By battery 2MQTT Setup Automation Scenario for Tuya Devices|Switches| - AliExpress

bought this and it just doesnt seem to want to pair up in the Smartthings app at all - isnt even found ? How did others get it to pair ? I tried the bottom left button to get into pairing mode and the lights flash after 10 seconds


magically just paired all of a sudden - and works on each button as single, double and held - great little buy !

I found this DH works really well for 3 of the 4 buttons. Has this ever been updated to make all 4 buttoins work?

Hi, I have installed this device driver and it works for all 4 buttons with all 3 press types.

BUT - when I set ‘button 1 press’ to ‘turn on lamp 1’ it turns it off, and vice versa.

Does anyone have any idea how I correct this? I’ve read the device handler guide but can’t see how the actions you select are controlled by the device handler.

Thank you

hello everyone
i have installed one of these switches onto smartthings. it worked great the first time every button controlled as it said. Had to reinstall it again ,now the buttons 1-2 control everything for the four switches? buttons 3-4 will not work even though the device has function in every output Press/D press/and hold. Has anyone else had this problem ,if so how was it rectified
any advice would be appreciated. Thanks

What to do next? Where can i config the Buttons correctly? Tried Webcore, shows 32 Buttons … tested it, but it doens’t work. ABController … no reaction


I don’t know very well what you want to do and if you only want to use webcore, but you can use the quick controls, directly by pressing an action and you can control devices and scenes.

You can schedule automations with each of the button and actions.

To delete a quick control schedule, you have to go to automations and they appear at the end of the list. Select the one you want to delete and press delete

I just wanted to toggle some Plugs (Speaker, Lights etc) in my Kitchen.
I don’t use Webcore often, just tried it out.
Where can I choose which button to execute the corresponding scene?
There is no Option like: Button #1 press: …; hold: …; Button #2 press … and so on.
Do not find the menu to link the buttons to the scenes/rules.

To use quick controls:

To delete a quick control schedule, you have to go to automations and they appear at the end of the list. Select the one you want to delete and press delete