[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

I discovered a weird time trigger bug.

I had a piston that was triggered at midnight -5 minutes and it refused to fire but when I changed it to 11:55 pm it works fine.

New bug
Hi all
I don’t know what is going on, but since the update on Monday I have noticed some of my pistons are being cleared out. Today I walked into the kitchen however the Phillips Motion Sensor see the motion but my piston that is supposed to save lux levels is wiping out. If I go to CoRE and choose to rebuild the pistons they all come back. This is pretty weird. Anyone else seen this? The following pic is all that shows in the piston before a rebuild. The rebuild only seems to last a couple of hours. I have 25 pistons running with 4 paused. I have 5 of them setup to get lux levels from 5 different sensors and store the lux to a system variable (other variable storing pistons are fine)

My dashboard is no longer available - the app doesnt work, no routines are firing - I had enough from Smartthings constantly breaking a working setup

{“error”:true,“type”:“com.google.common.util.concurrent.UncheckedExecutionException”,“message”:“An unexpected error occurred.”}

This system is not fit for purpose period!

I just noticed one of my pistons wasn’t firing. I tried to open the CoRE SmartApp in the SmartThings app on my phone and nothing comes up except the remove button and “You are not authorized to perform this action”. My hub is on the latest firmware and I haven’t had a problem with anything until today. Is anyone else experiencing problems?

1 Like

try opening your dashboard URL … I get {“error”:true,“type”:“com.google.common.util.concurrent.UncheckedExecutionException”,“message”:“An unexpected error occurred.”}

cant access the smartapp at all nor is anything firing at the moment - restarted the hub, events are there but the app and associated dashboard is completely out of order … already dropped Ady a report on it …

1 Like

I just tried to go to the dashboard URL and I get the same error as you.
Thank you for letting me know you told Ady about it. I can submit a report
as well, but it sounds like the same problem. Hopefully there’s an easy fix.

I just checked my CoRE SmartApp version and it wasn’t the most recent. I just updated to the most current version and all seems to be fixed. My github integration didn’t seem to be working correctly, so I did it manually. Just wanted to let you know in case you haven’t tried updating yet.

thanks - same here - still odd as it was working fine 2hrs ago with a previous version …

I assume you’ve heard by now, but just in case… there was a SmartThings outage earlier this evening.

I can’t access CoRE either, and I woke up with non of my pistons working. Quite a shock! How does this get fixed? I went into the IDE and clicked “update” under the smart app but it hasn’t made any difference… Any ideas?

Mine also had ceased to function. "You are not authorized"
Updated from the repository, now back in business.

Same problem, can’t access the smart app and no pistons firing

UK users can’t have github integration in the IDE, so is there a solution to get CoRE working again? @ady624 help!

If you are not on the latest version, updating to latest may fix it. There was a problem with class size that ST and I addresses in one of the latest builds. Try updating and see if it works. It maybe that ST added some more code to their base breaking the size limit.

@ady624 I’ve just updated to version 3.169.20170104, but still no dice.
I’ve pm’d you some photos…

Updating to latest does seem to fix it. @Alwas had other problems that got fixed in the mean time. Next? :wink:


Ady is a Saviour and the closest thing I’ve seen yet to the Second Coming! Thank you!


Sorry if this is a dumb question, but I’m new to CoRE. I only have 2 (simple)pistons built at this time while I learn more about it’s capabilities (which seem to be endless). I still have a lot of things running off of Bruce’s Rule Machine and I need/want to convert everything over to CoRE once I become more familiar with how it works.
One of my pistons that typically fires at 6AM as a “wake up light” triggered off a motion sensor in my bedroom did not work this morning. When I attempt to access/edit it in the app, I get the dreaded “You are not authorized…”. However, I am able to access my second piston and edit it. When I access the dashboard, both are listed.
I had previously updated CoRE to the latest version, but I realized that I hadn’t published it (for me). I did that this morning. Any idea how to get this piston back or do I just need to remove & rebuild it?

Github on the IDE has been available in the UK for a a couple of month now…

1 Like

I know you are not looking at feature requests at this time but when you do, I’d like to see the ability to set RAW JSON data in the Web Request field. The ability to send only variables is not working for my application.

1 Like