[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

If you mean can the instances as below call each others piston, then the answer is no. But as @rangelsammon has said, you can call other pistons within the same instance of CoRE.

I tried that, but i do not get the list of Pistons from the other instance of CoRE…

So as an example in the first instance of CoRE called “CoRE Routines”, i have a piston call “All inside lights off”

In my second instance of CoRE called “CoRE - Inside Lights”, I have a piston called “All lights off at 8am” From this piston, i want to execute the piston from above. The advantage is if i add a light in the future i only do it in one place. (theoretically speaking).

I may call the “All inside lights off” piston from many other pistons.

Hope this explains the situation a bit better.



Ah… OK


This would be a nice feature request!

to me its a total disadvantage is pain to have more than one instance of core installed. Organization yes but thats it. no other advantage that i can think of

The only reason I did it was running CoRE for new pistons or amendments to them was getting slower and slower.
Everything has now speeded up.
Works for me.

1 Like

If you are using EchoSistant you can run a piston from all installs of CoRE… No problem at all.

Should be able to make a web call from the first instance / piston to the second instance / piston to execute it.

Blank dashboard in core.

Latest build.
Tried experimental, and Classic dashboard.
Enabled logging.
Tried expert mode and without.
Deleted all pistons and created a test one ”basic”
Deleted core from ST, and created it again.
Did numerous Outh reset.
Tried to log out and in again in the ST app.
The FAQ says I should be able to find some clue due to a ”corrupt” piston, but the log gives no errors.
Tried on android and apple, tried opening the dashboard in a browser on a pc.

It is blank no matter what I do, and I can’t find the error.
I am all out of options
@ady624 ?

Two issues to report:

I wanted to trigger an event on an attribute changing to a particular value however I’ve found that the trigger goes off every time the event that sets that value is called, regardless of whether the value was already the trigger value. I.e it’s not going off only when the value changes

Also I was trying to set a variable on the android version - and I keep getting that annoying you dont have permissions screen

Any ideas?

Is there any reason why I wouldn’t be able to use two instances of CoRE in a single SmartThings account (I’m only asking that, because it’s the only thing that comes to mind for this problem I’m having)?

I have two locations, and each has a hub (one is V1 and the other is V2).
I have CoRE running just fine on the old, V1 hub.
I installed it on the V2 hub in the second location, but it won’t allow me to create any Pistons.
I can build it out with all of the options I want, but when I click the last ‘Done’, it spins, and then gives this red error message,
“Error saving page”.

Then, if I click on ‘Simulate’, I get this error…
“You are not authorized to perform the requested operation.”

Any obvious things I should check on to figure this out?

IDE log, check for error line numbers.

1 Like

Thanks. Resolved. :slight_smile:

I checked live logging as you recommended (I know…I’m ‘that guy’…it’s kinda like when I ask people, “Did you reboot it yet?”), and found a line 8629 error.
Then I searched on that, and found a number of hits related to Time Zone.
So, I went to check on that, but it wasn’t obvious. So, I asked Google, and got this…

Then, I modified the map location for the second Location, and tried again…

It worked, and I can now create CoRE Pistons in my second hub.

Thanks! :slight_smile:


Seems to come up more often (time zone issue) the last few weeks.

1 Like

Yey, good thing you figured it out. I will try and get the elephant in the room pointed out with CoRE (SE). Could you please help me out in testing something on this thread? I think the installation instructions are on post 72 of that thread… install for both locations and then open the dashboard for each of the two in the same browser. From thereon you should be able to switch instances (hubs) from the dashboard itself.

1 Like

Sure thing.
So…I’ll go get it as per the instructions in post 72 (i.e. from the webCoRE repository on github).
Then, do you want me to read from where you linked to, where you say, “Anyone here with two hubs in two different locations?” ?

Install it in both locations, then open the dashboard of each, in the same browser. When opening the second one, you should be able to switch between the two from within the dashboard.

If using the mobile version, tap the hamburger menu and you should see the location \ core name.


Just getting back to this…

I installed both webCoRE and webCoRE Piston from your webCoRE repo, and published both ‘for me’.
Should I install both of them into both locations within the ST mobile app, or just webCoRE (not webCoRE Piston)?

UPDATE (I still want 411 on webCoRE Piston question above):
OK, I installed webCoRE into both locations, and can access both of them from the same dashboard (I can do this on my Android phone and in Windows).
Very cool! :slight_smile:

So…I forget if you already said, but how far along is it? Can I go ahead and use it and start creating rules/Pistons, or is it not quite ready yet?

He is building the framework for the UI now. It’s in very early alpha stages right now. You can play around with the pistons but there are placeholders in currently.

1 Like

Aha, thanks.
So, we can see sort of what it looks like, and how the different pages will operate, but they won’t result in any ‘real-world’ actions in our SmartThings system?

You got it. Details here and I think details on how to install it are around post 72. No need to alter URLs anymore, just open the dashboard.