[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

Sure thing.
So…I’ll go get it as per the instructions in post 72 (i.e. from the webCoRE repository on github).
Then, do you want me to read from where you linked to, where you say, “Anyone here with two hubs in two different locations?” ?

Install it in both locations, then open the dashboard of each, in the same browser. When opening the second one, you should be able to switch between the two from within the dashboard.

If using the mobile version, tap the hamburger menu and you should see the location \ core name.


Just getting back to this…

I installed both webCoRE and webCoRE Piston from your webCoRE repo, and published both ‘for me’.
Should I install both of them into both locations within the ST mobile app, or just webCoRE (not webCoRE Piston)?

UPDATE (I still want 411 on webCoRE Piston question above):
OK, I installed webCoRE into both locations, and can access both of them from the same dashboard (I can do this on my Android phone and in Windows).
Very cool! :slight_smile:

So…I forget if you already said, but how far along is it? Can I go ahead and use it and start creating rules/Pistons, or is it not quite ready yet?

He is building the framework for the UI now. It’s in very early alpha stages right now. You can play around with the pistons but there are placeholders in currently.

1 Like

Aha, thanks.
So, we can see sort of what it looks like, and how the different pages will operate, but they won’t result in any ‘real-world’ actions in our SmartThings system?

You got it. Details here and I think details on how to install it are around post 72. No need to alter URLs anymore, just open the dashboard.


I discovered a weird time trigger bug.

I had a piston that was triggered at midnight -5 minutes and it refused to fire but when I changed it to 11:55 pm it works fine.

New bug
Hi all
I don’t know what is going on, but since the update on Monday I have noticed some of my pistons are being cleared out. Today I walked into the kitchen however the Phillips Motion Sensor see the motion but my piston that is supposed to save lux levels is wiping out. If I go to CoRE and choose to rebuild the pistons they all come back. This is pretty weird. Anyone else seen this? The following pic is all that shows in the piston before a rebuild. The rebuild only seems to last a couple of hours. I have 25 pistons running with 4 paused. I have 5 of them setup to get lux levels from 5 different sensors and store the lux to a system variable (other variable storing pistons are fine)

My dashboard is no longer available - the app doesnt work, no routines are firing - I had enough from Smartthings constantly breaking a working setup

{“error”:true,“type”:“com.google.common.util.concurrent.UncheckedExecutionException”,“message”:“An unexpected error occurred.”}

This system is not fit for purpose period!

I just noticed one of my pistons wasn’t firing. I tried to open the CoRE SmartApp in the SmartThings app on my phone and nothing comes up except the remove button and “You are not authorized to perform this action”. My hub is on the latest firmware and I haven’t had a problem with anything until today. Is anyone else experiencing problems?

1 Like

try opening your dashboard URL … I get {“error”:true,“type”:“com.google.common.util.concurrent.UncheckedExecutionException”,“message”:“An unexpected error occurred.”}

cant access the smartapp at all nor is anything firing at the moment - restarted the hub, events are there but the app and associated dashboard is completely out of order … already dropped Ady a report on it …

1 Like

I just tried to go to the dashboard URL and I get the same error as you.
Thank you for letting me know you told Ady about it. I can submit a report
as well, but it sounds like the same problem. Hopefully there’s an easy fix.

I just checked my CoRE SmartApp version and it wasn’t the most recent. I just updated to the most current version and all seems to be fixed. My github integration didn’t seem to be working correctly, so I did it manually. Just wanted to let you know in case you haven’t tried updating yet.

thanks - same here - still odd as it was working fine 2hrs ago with a previous version …

I assume you’ve heard by now, but just in case… there was a SmartThings outage earlier this evening.

I can’t access CoRE either, and I woke up with non of my pistons working. Quite a shock! How does this get fixed? I went into the IDE and clicked “update” under the smart app but it hasn’t made any difference… Any ideas?

Mine also had ceased to function. "You are not authorized"
Updated from the repository, now back in business.

Same problem, can’t access the smart app and no pistons firing

UK users can’t have github integration in the IDE, so is there a solution to get CoRE working again? @ady624 help!

If you are not on the latest version, updating to latest may fix it. There was a problem with class size that ST and I addresses in one of the latest builds. Try updating and see if it works. It maybe that ST added some more code to their base breaking the size limit.