RELEASE (beta) - Xiaomi Honeywell Zigbee Smoke Detector

I’ve just got one of these and have it paired OK.
Just a question for you old hands with this device.
How did you test it? Button presses or only with smoke?
When you test does it show on the main app and in recently tab?
Anything else worth noting.
Thanks in advance.

As a workaround to the 8% battery issue I use inpier’s forked version (post #9 above)

and changed the function getBatteryResult(rawValue) from:

private Map getBatteryResult(rawValue) {
	//log.debug 'Battery'
	def linkText = getLinkText(device)

	//log.debug rawValue

	def result = [
		name: 'battery',
		value: '--'
	def volts = rawValue / 1
    def maxVolts = 100

	if (volts > maxVolts) {
				volts = maxVolts

    result.value = volts
	result.descriptionText = "${linkText} battery was ${result.value}%"

	return result


private Map getBatteryResult(rawValue) {
	log.debug 'Battery raw value: ' + rawValue
	def linkText = getLinkText(device)

	//log.debug rawValue

	def result = [
		name: 'battery',
		value: '--'
	//def battLevel = rawValue / 1
    def battLevel = rawValue * 10
    def maxBatt = 100

	if (battLevel > maxBatt) {
				battLevel = maxBatt

    log.debug 'Returning battery percentage as: ' + battLevel

    result.value = battLevel
	result.descriptionText = "${linkText} battery was ${result.value}%"

	return result

Not perfect but at least it reports as 80% and doesn’t nag about a low battery (percentage hasn’t changed in 3 months mind you)!

I have just got one of these connected direct into ST.
I’ve configured it into Smart Home Monitor and webCoRE but when I test it by button press or with smmoke I get nothing reporting through either app.
Anyone out there configured these through SHM or webCoRE successfully?
If so, how did you do it. I’m obviously missing something obvious.

@bobbles I’ll give it a go on the smart home monitor, just set it up whilst on the bus, I’ll test later when home and see what or what I don’t get :grin:

Update, nothing showed up for me on the smart home part of the st app, whilst the device said it was being tested and I got buzzing in my ears the smart home dashboard continued to let me know the house was safe from smoke :scream:

Thanks @KellyDarren for the response.
I’m not sure what to make of the lack of responses on here to my question.

  • Nobody is using these apart from us.
  • Nobody is integrating into SHM.
  • Nobody is integrating into webCoRE.
    Nobody cares. :disappointed_relieved:

Hi @bobbles, I made another DH for this.
Battery and SHM are both working fine for me and others who have tested.

If you do use my DH, I’d advise that you remove your device from the SMH and then delete the device. Start fresh adding a new thing and you should be golden.

You can get it here:

Thanks for this.
Just tested by holding in the button and my webCoRE piston fires OK.
Nothing in SHM events for the test but I don’t suppose there will be.
Will burn my toast tomorrow morning to see if it works for real OK. :wink:
Thanks again.


I did try to remove the old DH and use your newer DH but how long I should wait for all fields in the smartapp are shown? I can see the raw battery status getting updated constantly but not anything else

I tried to test my 5 devices today and I noticed that exept one, all my other 4 smoke detectors stopped communicating. I use the original DTH with modification to force the battery to 100%.
How did you solve similar problems?

You will only see battery checkins or actions (smoke test clear) in the log. The checkin was removed from here to double the real amount of actual notifications as this decice only check in on battery call, button press or smoke detection.

Regarding the other fields… the bottom will list the battery last change date if you go into settings and flick battery changed and then save.

All other fields… last smoke, last test etc will depend on when you evoke these actions.

I’m guessing that your devices lost contact with hub? I’ve not had any problem with mine dropping after pairing, but this is a classic xiaomi problem. If they pair well and report for a couple hours they are generally solid forever. If not… repair. If you have any zigbee repeaters in your network… best turn these of so that you xiaomi device is forced to pair with hub.

Seems I have some issue for the GUI on android but iOS version looks fine, I am not able to populate the smoke alarm testing in GUI by pressing 1 sec according to Xiaomi instructions I will keep try and see how it goes, thanks

normally to invoke the test state you press for at least 3 seconds (you’ll know its testing cause it physiscally starts to go through the very noisy test sequence). Tapping or pressing for 1 second will only force a checkin with the DH… so you should see a new battery reading in events and lastcheckin tile will update. The last smoke will only update in the event of actual smoke not in test. I’m on android, so if you want to paste a screeshot maybe i can help a little.

@foz333 This is what I got in android on LG v20 and I see voltage logged correctly and seems my test button works now when I hold it longer may be more than 3 seconds and it gives me a clear status as well

I find it strange you dont have any battery icon either.

If you go into settings (the cog at top) and flick battery changed over to right and hit save at top you should have info in bottom tile.

Last test should be updated whenever you press button for more than 3 seconds. I’ll double check the right version of the code is on the git when i get home.

Here is how it looks on my Samsung Galaxy…
Main screen

Settings screen

Not exactly sure why the battery icon cannot be shown correctly but fine on iPhone I recall I could get it displayed once correctly or so, I got an error going setting page too, the setting page is fine on iPhone though


I have updated the smartthings android app to latest version and problem solved

thats good news, i had quick check of code last night and couldnt see anything wrong so glad its just a ST app issue. Let me know if you run into any issues or have suggestions. Ive been working on trying to remotely trigger the alarm but its proving somewhat resistent to my charms.


Just an update, now have four working continuously for last 6 months or so. That’s using the original created DH.

However the other night I had a ‘scary ass’ moment when one of them triggered (at 01.50 hours) lights all went on and smoke indicator on the app went off. Panic mode i can tell you. Anyway - false alarm.

On the device in question, for a brief moment smoke was detected and then instantly cleared itself. It had cleared it self and the alarm wasn’t going by the time i went to check. Wondering has anyone else had an issue with this (not that once really is an issue) ?


Hi Mike,

This morning 5:30u the smoke detector gave a false alarm.

I checked the housing, no smoke, no fire.

I removed the battery and just reinstalled it, still false alarms.

Small bugs inside?!? Don’t know how to fix this.