SmartThings Community

[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule


( - Make your home your butler!) #102

Check the settings, the app only sends what it’s told. Alternatively, I suspect he may have multiple apps controlling the thermostat and should track it out from the SmartApp tab from the device page on his phone.

(Kevin) #103

Could anything WAKE IT up? I have heard of Pollster… not sure if valid here… anything else come to mind? It’s a CT100 that doesn’t use C-Wire… I can’t use it… it’s not there and not possible with setup I have… only a 2-wire system. I’d have to run a wire and haven’t the skill or knowledge and I have to watch funds for now.

(Kevin) #104

Also - Should the app have an Application State? Because when I look in IDE it doesn’t…

( - Make your home your butler!) #105

It’s a beaming device:

Battery powered nodes (FLiRS) have a battery saver feature in which the node will be awake for 1.5 seconds then sleep for 1.5 seconds. The Beam is a carrier that is transmitted for a preset period. The 2-way battery devices operate as follows: the radio turns off (to conserve battery) for 1.5 seconds and then wakes up for 1.5 seconds. If a carrier ‘Beam’ is detected the battery device will fully wake up, checks into the network with a broadcast to all the surrounding nodes. When the FLiRS device receives this broadcast, it responds with an “I do” and beams the command to that particular slave node. If it does not hear the beam command, it falls back to sleep and 1.5 seconds later starts the cycle over.

The hub supposed to transmit long enough to overlap with the beam to enable the device to wakeup. But I’ve seen this not happen with my CT-100’s sometimes (esp because my hub was a little far from the device). When I added some Z-Wave Light switches to my house (2-3 of them), I found a significant improvement in the communication quality.
Hence I was saying first reboot the hub, it makes a difference, (the hub firmware isn’t perfect yet). And if then if you can add 1 A/C Z-Wave Light switch/outlet which also doubles as a repeater about midway between the thermostat and hub and it should help.

(Kevin) #106

The hub is in a room just off the hallway where the thermostat is… prob 15 feet away tops. Would it matter if the door is open or closed? :smirk: I have GE switches very close… not sure if zwave… have to look. By reboot of hub do I have to remove battery or am I just pressing a reset button?

(Kevin) #107

There are 2 GE Zwave smart switches in the hallway… one is about 3 feet away from it. Other is about 5 feet away other direction.

( - Make your home your butler!) #108

Good question, I’m still on v1 hub because I’ve found to be more stable. So i guess remove power and battery.
EDIT: Also try doing a Z-Wave repair from hub utilities after rebooting it.

(Kevin) #109

ok thx… I’ve seen them say to run repair three times? Is that true? Like Wizard of Oz… lol

(Kevin) #110

Restart of hub via red button push FRIED the hub… they are sending replacement…

(Tom Eslick) #111

Hi, I am the colleague. I am using this device handler “rboy : Thermostat with Temperature, Humidity and Auto Time setting”. I am controlling 2 CT100 Thermostats with the 5-2 day scheduler. It is only changing one 50 degrees for cooling and heating.

( - Make your home your butler!) #112

Wow!! Can you elaborate what happened?

(Kevin) #113

I hit the red button…
I waited and saw red lights, then they went away…
Waited 30 mins… still INACTIVE.
Support had me pull out batteries and unplug for a min and plug in… I did that multiple times with and without batteries.
Only would flash red and go away and then nothing… no lights…

( - Make your home your butler!) #114

I guess that’s why it’s the big red button :wink: - poof!

( - Make your home your butler!) #115

I think you may have a communication issue with your second thermostat. Best way to confirm is check the events history for your thermostats and see if the app is sending the command to the thermostat. If you can see it in the events history then it’s communication.

( - Make your home your butler!) #116

###5-2 Day Thermostat with Remote Sensor - Version 3.1.2

  • Added fix for error if the hub location/timezone wasn’t specified. Now it’ll warn the user to add the hub location to that it can pick the correct timezone otherwise it’ll default to UTC timezone.

Thanks to DnCCrew for this step:

To set the hub Location, from smartphone app:

  1. Clicked on the 3 lines (top right corner)
  1. Clicked on gear icon (top right)
  2. Click area that says “Tap to set where home is on the map” and zoom in to correct location on map.

( - Make your home your butler!) #117

###5-2 Day Thermostat with Remote Sensor - Version 3.1.3

  • Added a heartbeat system to fix an issue with platform timing out the execution causing the app to stop working when the platform is under heavy stress

###NOTE: Do remember to ReInitialize the SmartApp (open and hit Done) after updating the code. Without this step the the new heartbeat system won’t start.

( - Make your home your butler!) #118

###5-2 Day Thermostat with Remote Sensor - Version 3.1.4

  • Another workaround to help fix the broken ST scheduler which can drop schedules sometimes

( - Make your home your butler!) #119

###5-2 Day Thermostat with Remote Sensor - Version 3.1.5

  • Choosing thermostats is optional now, allows users to temporarily disable the SmartApp without losing the settings


Does this use the new Ticker scheduling system?

( - Make your home your butler!) #121

Everything uses the new ticker. It’s the scheduling system for the entire platform.