SmartThings Community

[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

thermostat
climatecontrol
temperature
smartapp_hvac
rboyapps

(www.rboyapps.com - Make your home your butler!) #82

I can’t make out much from your post the formatting is messed up. Was it working and the suddenly stopped? (because it’s working fine here). If so then there’s a communication issue between your hub and thermostat, try resetting the hub (unplug) and thermostat (remove batteries).
Also keep in mind that the heat and cool are set only if the thermostat is in Auto mode otherwise only one is set.


(Ian Eicher) #83

ok, I think it is an auto mode issue. I can cycle through the modes in the device on the ST app, but it only does heat/cool/off. It will no longer cycle to auto. When in heat it will only update the cool setting.

All manual changes through the ST app work otherwise, so I don’t think this is a communication issue.


(www.rboyapps.com - Make your home your butler!) #84

I think your issue may lie with your SmartDevice for your thermostat. You may want to remove device and re pair it again and reinstall the code for your device.
You may also want to try to delete this SmartApp and start over maybe it’s corrupted.

The code itself appears to be working here so it’s sending the wrong setpoint it’s either a bad SmartApp install or a corrupted SmartDevice.


(www.rboyapps.com - Make your home your butler!) #85

Verion 2.1.1 - Added a workaround for ST platform timers dying randomly


(www.rboyapps.com - Make your home your butler!) #86

On request from users Released version 3.0.0 of the 5-2 Day Programmable Thermostat Scheduler.
This version now allows you to use a Remote Temperature Sensor (e.g. in a different room) to control the HVAC thermostat. This advanced version is available on the RBoy Server http://smartthings.rboyapps.com


(www.rboyapps.com - Make your home your butler!) #87

Folks please note - if you’re upgrading from an older version of this app you WILL need to re enter your settings in the SmartApp.


(www.rboyapps.com - Make your home your butler!) #88

Version 3.0.1

  • Timers are now more reliable
  • Added the ability to emulate a “Hold” button of a traditional thermostat, now any manual changes to the thermostat will remain until the next scheduled temperature change or until the mode changes

After updating to this version of the code please recheck all your settings, most importantly your Thermostat Operating Modes will need to be reentered.


(Johnathan Urschel) #89

So somebody explain this app to me please. Maybe I’m using the wrong app. I want it to be 73 degrees warm in my house all day every day during the winter and 73 degrees cool in my house all day every day during the summer. I don’t want a wake up leave, come home etc etc. I want the above with the ability to bump that 73 to 75 in the winter and the 73 down to 70 in the summer, etc. Wrong app or what? Because I can’t seem to keep my house around the 73 degree mark consistently without having to hit the refresh button on the smart app. Also why doesn’t configure work? Never seen it work.


(www.rboyapps.com - Make your home your butler!) #90

If you just want one temperature all day in summer and one in winter you don’t need this or any app. Just set your temperature in the thermostat or though your ST device and leave it there. it wont’ change.

What refresh button? Smart Apps don’t have a refresh button. I think you’re confusing a device with an app. This is an App. There is no UI to an App after install.

Once again there is no button to an App. I think you’re on the wrong thread.


(Johnathan Urschel) #91

Sorry I guess I mean the thermostat “thing” with the sliders etc. There is a refresh and configure.


(www.rboyapps.com - Make your home your butler!) #92

Version 3.0.2

  • Fixed a bug with app not honoring mode selection
  • Added ability to rename the smart app

(Brad) #93

RBoy - Thanks for updating the app for me, so quickly. 3.0.2 is working great now with mode selection!

Brad


(www.rboyapps.com - Make your home your butler!) #94

Folks please note if you’re using an external temperature sensor with the App, it will use the thermostat to 90F for heating and 50F for cooling until the external sensor temperature indicates that the desired temperature has been achieved after which it will be reversed to turn it off. This is normal behavior.


(www.rboyapps.com - Make your home your butler!) #95

Version 3.1.0
Only set the temperature on the thermostat (when in remote sensor mode) if the current temp is not the desired temperature. This is to save the thermostat battery.


(www.rboyapps.com - Make your home your butler!) #96

Version 3.1.1
Modes are now controlled by ST platform, app will only operate in designated modes (including turning off) to avoid conflict with other apps.
Make sure after updating that you reenter your mode settings again


(Kevin) #97

Ever since the platform issues this hasn’t been working very well… set points not getting changed… are you working on fixes due to new scheduler?


(www.rboyapps.com - Make your home your butler!) #98

Actually the fixes were to compensate for the old scheduler, the scheduler is supposed to have fixed any issues hence the workaround included should not be required with the new scheduler, however it still works as a backup just in case. If I’m missing something, that you’re specifically referring to some specific fix, let me know.

There are a couple of things that could be happening:

  1. Communication between the thermostat and hub isn’t reliable (try rebooting your hub)
  2. The scheduler is not firing on time - you can confirm this by looking at your smartapp details from the IDE (My Location -> SmartApps -> Scheduling), see when the last time it fired (v/s what you had programmed)

Do 1 and then check on 2. If you’re facing issues with 2 I would take proof of snapshot from the IDE page and report it to ST support and @slagle so they can look into it.


(Kevin) #99

It’s in the job history properly… seems to not set it though. I’ll get up early tomorrow and get IDE logging going before 6am and see what the logs say. It’s usually morning where it doesn’t set it… then I have RM a few minutes later check the state and if not heating it sets the setpoint. Harder to do at night because i can’t guarantee the state… there’s no trigger for setpoint in RM. I’ll check prior to 10pm tonight and see how it looks. I know last night it didn’t lower it at 10pm.

Question: Would removing and re-creating the whole app be any benefit?


(Fred Schmitthammer) #100

I have a colleague that his thermostat keeps being set to 50 degrees cooling every day when using this smartapp. He has the CT zwave thermostats.

Any suggestions?


(www.rboyapps.com - Make your home your butler!) #101

If your’e seeing in the history then it running and I would suspect a communication issue (happens all the time, if there aren’t enough active repeaters in the house esp with thermostats, if the thermostat isn’t in repeater mode (with C wire), it’s actually a beaming device, i.e. it sleeps and then wakes up and hence can miss some commands, even thought it shouldn’t. I saw this issue until I added a few powered z-wave device in the house and it fixed itself, infact now I moved to all C wire thermostats using the Venstar Add-a-Wire).
One thing would likely help is rebooting the hub (simplest fix).

No harm try it out.