Re adding mobile presence

I had to delete one of my iPhones as a mobile presence sensor. And I’m trying to re-add it however this is what I get:

I’ve tried logging out of the st app on all of my devices, deleted and reinstalled the app, deleted all smart apps that included that device…the device no longer is listed in the ide and it is no longer listed in my list of “things”, however when I try to re add it, it says that it is “already set up as a mobile presence device.”

Any suggestions?

Are you using separate accounts on each device? It’s possible with the latest security update that you can’t set up multiple devices with presence using the same email address.

Yes. I’m using two separate email accounts. I started having issues after the most recent app update

I’m having the same issue here. My wife’s iPhone stopped changing presence status about a week ago. After trying various things, I finally removed the phone from my device list and tried to re-add it. I also get the same alert that the phone is already setup as a mobile presence device.

I went into the IDE and made a copy of my iPhone as a new mobile presence device and set the Network ID to her previous Network ID in the hopes that it would fix it, but no dice. I now have both iPhones showing up in the “Family” tab of the app but hers doesn’t have a history and doesn’t change state between home and away. It is behaving as if the device I created in the IDE and the actual phone are not linked as one. I can do everything such as include it in rules and routines but it just acts as a dummy device that is always in the “Present/Arrived” state.

Any suggestions on how I can get Smartthings to recognize her phone again?

I am having the same exact issue! Wife’s and son’s phones not tracking. I removed them from the family list, then tried to re-add them. Same error message as OP.

We all use the same log-on.

I also got a new phone and it gives the same message when trying to add on the phone.

I’m having the same issue. The app was showing me being last present about 6 months ago. I realized that’s when I changed my phone and got a new phone. So on the new phone the presence sensor was not working so I removed that deadbeat own that thought I was last seen 6 months ago and now I can’t add myself back it says the phone its already on the list well clearly it is not .

Same issues as the ones stated above. Any resolutions Smartthings? I have found this hub to be a very difficult and average thing. Great customer service but most of the time not much resolution

This happened to me a while back. The problem was the phone is not necessarily connected to ST but the email associated with the phone. Solution was to go into the IDE and delete the mobile presence phone. Then log out of the App. Uninstall the App. Then log back in and try to add phone.

If you are logged in to multiple accounts, ipad, iphone, android…etc, the last one that you logged into will be the one that ST uses for presence. You have to log out off all of them.

I have done all of that and still no bueno. it’s obviously some sort of bug or it wouldn’t be happening to everyone as stated above. All identical behaviors

Got it!!!

Thank you. And how did you “get it” to help others that are having the same issue.

1 Like

I deleted the Smart Things App; re-downloaded it and had to add an account under my wife’s email address. It wasn’t set up that way in the past but it works now so not a big deal

1 Like

Oh, I got you. Thank you for the prompt reply!! Same thing I did here.

This worked for me also. I had to login to my phone (which could not be added again) with my wife’s account and add the phone again.

I have the same problem. Can’t re-add my phone to my own account as I get the already set up as a presence sensor. Deleted the app, logged out/in, tried it all, no good. Debating about doing a factory reset of the phone or factory reset of the smartthings hub and spending a hundred or so hours re-creating all the routines for each device in the house. Going to use my work email and send myself a link to join and try doing it that way, but seems a very Fu&*ed up thing to have to do to add my own phone to my own master account.

Hold off on doing that. Are you Android or IOS?

Is your phone added right now in SmartThings and it’s just not reporting status (present or away)? Or did you already remove it?

I’m iPhone. Invited myself to have guest access to my smartthings account using my work address, created a new account with the work email, logged in on that and now my presence comes and goes properly, but it’s not an ideal solution. I’ve removed the iphone from my master account and added it to my new account, to answer the second question. Previously, the app was reporting me as home, regardless of if I were home in Colorado or off in New York.

I also got a new phone which was not working for presence. I deleted the old phone, but continually got the “failed to create” message.

I opened the two SmartApps that used that phone device and clicked “Save” to update their device lists (just in case they were still trying to access it and it was getting stuck on that), and then I rebooted the phone. They were ActionTiles and webCoRE, just for the record.

After the reboot (Samsung Galaxy S8) I was able to recreate the mobile presence sensor on the phone.