Re-adding after forced deletion of z-wave device


(Druce MacFarlane) #1

I have now made the same mistake three times. I reset a z-wave device and needed to reconnect the device to the hub. I figured you couldn’t add it again if it was already there so I deleted it, and then force deleted it to get rid of it. After, I tried to re-add the devices but they never show up again. I am able to add other similar devices but can’t add these devices (one device is a lock, one wall switch and one light bulb).

I’ve tried repairing z-wave, general device exclusion and include/exclude hub. If factory reset each of the devices, but they never show up when trying to add them.

When you force delete, are you deleting them forever? Is there any way to fix this?


#2

If you force delete, you have to perform a general exclusion on the device to clear the old information from it, and then you should be able to re-add it, but it will re-add with a different network ID so you will have to redo any smartapp or core piston or routine that used it. The alternative is to use the Z wave replace utility, which will reassign the same network ID when you add the device back in, so that way you don’t have to change any of your smart apps.

Here’s how to do the general exclusion:

And here’s how to do the replace. ( note that the replace only works with Z wave devices, not zigbee).

But you can only do the replace if you haven’t deleted the device yet. Once you’ve deleted it, your only option is to do the general exclude and then add it as a new device


Aeotec Multisensor 6 won't stay connected
(Terry Grant) #3

I have the same issue with a Aeon Siren which I had to “force” remove because I thought it was locking my app. I have tried everything including help from ST support. When trying the device exclusion the app just spins and it doesn’t show up. It is removed from my device (does not show up) I have tried all variations of resets etc. It’s like it doesnt exist! Any help appreciated PS: The app has not locked since the removal of the siren


(Patrick McKinnon) #4

Same problem with my Aeon Minimote. I thought it was messed up because it wasn’t responding and couldn’t be removed, so I reset it. Turns out it was during SmartThings outage a few weeks ago, and wasn’t the device after all.

Now I can’t get general device exclusion to work, nor add it back. Guess I just have to chuck it in the garbage.

Thanks "Smart"Things.