Range fails at registering

I have a model NX60A6511SS range that won’t connect to Smartthings on Android. I’ve tried everything I can find on this forum ant the web.

  • All three add methods
  • Different Android device
  • Resetting the router and WiFi access point
  • adding the WiFi password 1111122222 to the [range] device on my Android
  • Checked network signal
    • full signal on my phone sitting next to the range
  • Clearing the Smartthings Data
  • Reinstalling the Smartthings app
  • Unplugging the range

I’ve tried the above multiple times in various orders. I’m sure there’s more steps I’ve tried that I forgot to mention here.

Tagging @SamsungZell

Oh, and I changed the WiFi channel on my router, and even tried disabling the router Firewall. All with no luck.

Are you using a Pixel device? Do you get an error code in the app?

1 Like

I know very little about that particular device, but just on general principles, we should Ask if your phone/tablet where you are trying to add the device is using a 2.4 GHz network, not a 5.0 GHz network.

It is very common that smart appliances and smart home devices will only work on 2.4 GHz Wi-Fi, not 5.0. That’s not a problem in daily operation, but during initial set up your phone/tablet will also have to be on 2.4 gigahertz in order to make the connection.

I don’t know for sure if that applies to this model, but it never hurts to have the phone/tablet on 2.4 GHz during initial Setup, so it’s worth checking. :thinking:

Yes Pixel. Initially I was not getting an error code, Just hanging at the Registering screen. My last few attempts have yielded the error code 15-200.

I also checked my router, and the range is showing up in the DHCP table, so it is able to connect to my router.

Yes, I confirmed that my phone is connected to the 2.4 GHz channel.

1 Like

Which version of the Android app are you running? There’s an updated version being released currently (v1.7.81.22) which I believe addresses this issue but we’ve seen problems onboarding appliances with Pixel devices in the previous app version.

1 Like

I am running 1.7.81.22.

I found another post that fixed the issue be removing an underscore from the SSID. I had a hyphen in the network password. When I removed the hyphen I was able to register the range.

Next question, how do I change the network settings on the stove, so I can see if it works with the hyphen now that it’s registered?

1 Like

Those instructions look like they’re for the original app. I have the newer Smartthings app. So for example the three lines for the menu bar are on the right not the left. Then there is no network settings option.

Is there something similar for the new app?

Hey there! @KenH60, Welcome to the Community! :slight_smile: I’m glad to hear that you were able to get the Range onboarded into the SmartThings Application.

As far as updating the WiFi, it used to be an option in the New ST App, However, the option detailed in the article above has since been removed from the Smart Things Application.

If you are using the Range connected to a Smart Things Hub this article may be of help: Change Wifi Settings - #2 by SamsungZell

If the symptom persists, please reach out to support for further assistance with updating the Wifi information.

You can reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
US: support@smartthings.com
UK support 0333 0000333
UK: support@smartthings.co.uk
CA: support@smartthings.ca

I hope this message finds you well!

^SamsungZell

1 Like

So, I just changed my WiFi SSID back to the original containing the hyphen. There’s too many other things on my network that I don’t want to reconnect…

Then I went back and tried to rediscover the range in Smartthings, thinking that it might work seeing that it had already registered my device. This time it failed with a 15-300. When I clicked on help, there was a number of possibilities including this one:

Blockquote * Check that the Wi-Fi network name uses only numbers and English letters, since unsupported characters could cause an issue

@SamsungZell

  1. If Samsung knows this, why don’t they flag an error as soon as I type in the network password?
  2. Why doesn’t Samsung support characters that every other Wi-Fi device in the world supports?
  3. Why didn’t I get the 15-300 error in the first place instead of the 15-200?

This is a triple fail Samsung. Any of the three options above would have saved me hours of troubleshooting.

@SamsungZell Thank you for the reply. I think you were posting your reply at the same time I was typing my detailed analysis above.

BTW I was looking to change the Wi-Fi settings on the Range, not my hub. Any thoughts on that? Would that also fail on the hyphen?

Thanks to all that have read so far through this thread. I know there’s a lot here, but I wanted to document everything, and maybe save someone a few headaches.

1 Like

Being that you are talking about an article on the Samsung support website, perhaps it should be removed or revised if it is no longer correct?

1 Like

As someone who has spent a lot of time on this, there is some good/bad news that should make fixing this relatively easy. As one who is fluent in the technology and also able to look in detail at the router tables, the good news is that if the problem is indeed with a hypen in the SSID name, this problem is in the Smartthings app and not the cooktop. The cooktop is fully able to register with the router using an SSID with a hypen in it and get an IP address. I can see the cooktop appear and disappear in the router’s DHCP tables: when I reset the cookstop (pressing the smartconnect button) the stove disappears from the routers tables (loses its IP address) and after registering the cooktop in the app in the app using the hyphenated SSID and giving the correct WiFi password, it is able to re-connect to the 2.4 GHz network and get a IP address, which is fully PINGable from any other device on the network, So the problem is not between the cooktop and the WiFi network. The problem is that something in the Smartthings (at least Android) app seems to then have problems actually adding the cooktop back as a set of known devices to the app for reasons that make no sense. It had no problem talking to the cooktop as it was able to give it the correct SSID and WPA2 password since the cooktop was able to fully re-register and connect to the WiFi network using the hyphenated SSID and successfully get an functioning IP address. So please simply fix the problem in the app that seems to have problems recognizing the fully functioning cooktop that is active on the network.