SmartThings Community

Quirky GE Outlink POTLK-WH01 POTLK-WH02 Outlet Device Type

potlk-wh01
potlk-wh02
wink
quirky
dth_outlet
#44

I tried last night and it kept reading “0 W”. I looked at the code and not sure why it doesn’t get the info it’s supposed to.

0 Likes

#45

You might want to try and re pair that outlet. The first time I installed it I had the same issue as you did. I ended up removing it and reconnecting it to the hub and that worked well.

0 Likes

(Michael MacDonald) #46

@Whiteknight - it worked!! I actually re-paired it and immediately changed the IDE to GE Zigbee Switch before assigning it a room or anything else.

Now I have a reasonably good tool in the HA Arsenal.

Thanks!!

0 Likes

#47

Good deal! Glad you got it working. Now if we could get it to report usage that would be great!

0 Likes

(Brad) #48

I had the same problem with mine that stopped working after messing around with device types. I completely lost the ability to control it and had to I re-pair it. The second time I immediately selected “ZigBee Switch” and it has stayed connected since.

However, I’ve had other problems and wanted to see if anyone has had the same. One problem now is that one of my ZigBee motion detectors (SmartThings) has stopped working a few times. I know its because of this switch because one of those times it failed was at the same time as when my outlet stopped working. The other times I reset it by pulling the batteries and it starts working again. This is not the first time a ZigBee device has done this when I added a new device to my network. It somehow fixes itself in a week or two. So maybe I can blame the whole mesh network thing on that?

However, the more concerning part for me is twice now the outlet has turned on by itself! Both those times I was in the SmartThings App doing other things, but I highly doubt I mistakenly turned it on as I was messing with other stuff. I am replacing my SmartThings plug with this to turn on and off my coffee. Since I have had SmartThings I have never mistakenly turned on my coffee, so I doubt I did it by accident. Anyone else had this device magically turn on or off on them?

Maybe I’ll try the GE ZigBee Switch if it happens again…

Brad

0 Likes

(Jason) #49

See:

In short you need to unplug ST hub and if you have V2 remove batteries for at Least 15 min then plug back in. It will take up to a day to rebuild the mesh.

Your issue with the outlet / motion is likely that the outlet was the only repeater that the motions sensor was on. So when the outlet came back up it was found again. You could reduce the odds of this happening again by using multiple repeaters at the same distance and rebuilding the mesh.

0 Likes

#50

I’ve been trying to debug this too and can see that it’s returning a value of 0 for power. I don’t think we have the correct in/out clusters for this device. I think a custom device type is in order. Time to do some reading of the zigbee HA library.

0 Likes

(Mitch Pond) #51

This outlet does not natively report power like the ST outlet. What it does report is cumulative energy usage. I have a device type that mostly works, and displays energy used and power (derived) but I can’t seem to figure out how Wink resets the cumulative kWh. I’ve done it, but it seems like it’s not an instantaneous reset, so I’ve had a hard time tracking down exactly what it was that I did to get it to reset. It’s on my list of things to finish (since I got a few on clearance) once work calms down a bit.

I can link to what I’d consider an alpha DTH, but it’s not complete and I’ve got it set up to be rather spammy right now… (tweak the reporting config to shut it up :slight_smile: )

6 Likes

#52

Awesome… thanks for sharing.

0 Likes

#53

Thanks Mitch!
is it possible to have the current watts or kwh in the room list overview?

0 Likes

(Nic Jansma) #54

Thank you a ton Mitch, your code has been a great help. I too had purchased a couple of these outlets on clearance, and I’m excited they are now reporting energy usage.

I took your code and made a few slight modifications. Primarily, it now reports “power” (instantaneous W) in addition to “energy” (kWh over time). You had already made these calculations, but I’ve added the “Power Meter” capability to ensure the device is exposing instantaneous usage too.

Thanks again!

1 Like

Canadian SmartThings User Group
(Mitch Pond) #55

Glad it’s working well for you! I hadn’t added the power meter capability yet since I wasn’t confident in its accuracy yet, but if it’s looking good then that’s great!

0 Likes

(Nic Jansma) #56

Yeah, as far as I can tell they’re accurate enough. I’ll put the outlets on a Kill-A-Watt soon to double-check, but they seem reasonable accurate based on what I have plugged into the sockets right now.

0 Likes

#57

I just added this code for my outlink’s and it seems to work correctly. Resetting the power meter would be nice as it does not update that frequently but it does work.

0 Likes

(Todd Whitehead) #58

Hi. I just installed this and turned on the light attached to the outlet and it shows
Energy used: 0.485kWh
Power: nu W

I assume that means null?

I tried refreshing, but no change.

I’d like to use this capability to tell when my washer is done, but if it takes a long time to update, that will not be very useful.

Any thoughts on what might be going on here? Should it update more frequently?

Thanks.

0 Likes

(Nic Jansma) #59

I’d recommend looking at the debug logs associated with the Device Type. In getInstantDemand() you should be able to see the calculations it’s making and determine why it’s null.

0 Likes

#60

That is what mine did, just took a few for it to read correctly.

0 Likes

#61

thanks for the work!

0 Likes

(Ray) #62

For me to get rid of the null. You have to plug something in that plug that’s drawing power then press refresh a couple of times. That solved 3 of my plugs.

Thank you guys for getting this working. Really appreciated!

0 Likes

(Jeff) #63

does the power reading update on its own for anyone? or you just have to press refresh to update the reading?
also the outlet doesn’t seem to update manual (pushing the button between outlets) changes to the state.

0 Likes