Question about Iris Smart Plug and new smartthings app

Recently I performed the upgrade to the new smartthings app when the banner appeared. Only issue so far is the new app not recognizing the device handler inuse.for my iris plug that makes it also an extender. If I log into my everything is good, it’s just with the new app. I tried searching the forums nut didn’t find anything about that. Any help is appreciated.

You can’t use the device with the new app yet. You were not upgraded to the new app, your ST account was migrated to a Samsung account. You can still use both apps.

Ok thanks so then continue to.use the old app.
Thanks again.

The zigbee plug portion of the iris plug works with default handler “SmartPower Outlet”. The zwave extending portion works with default handler “z-wave range extender”. Switch them to those and they will work in both apps. And the outlet will run locally, too.

I thought u can only use 1 device handler instead of 2.

The Iris 3210-L is unique in that it has a zigbee plug AND z-wave repeater in one unit. if you properly installed the plug for both the zigbee plug function and z-wave repeater function, you should have two devices in SmartThings for one physical outlet. Then you have one handler per smartthings device.

When I purchased the plug I used a dth that seemed to be what everyone was using and I never had any issue until.qe starting migrating to a samsung account.

your account login doesn’t force you to use the new app. You can still use classic. But if you want this to work in the new app, change the handler assigned to the devices in the IDE.

I’m still not able to get the z wave network heal to pass with the two range extenders. I’m suspecting they are only zigbee repeating for me. Any idea what could cause that?

Are they added as their own device? What error are you getting during the z-wave repair?

They are…i have 4 devices for 2 switches. The error is:

Network repair for Repeater 1 [09]: Failed to update mesh info


Network repair for Repeater 1 [09]: Failed to update route

I get the same thing for repeater 2.

yeah that’s not good. will probably have to exclude and re-pair to get those to work.

Yeah, that’s what I figured. I’ll just wait. Going to be porting everything to Hubitat soon and I really only bought them because of the zigbee repeater (and the fact that they were $9.50 at Lowes).

1 Like