Question About Amazon Echo and Adding SmartThings Switches


(Nathan Parker) #1

I just got the Amazon Echo. Now that I see how seamlessly it’s working switching on/off my current SmartThings switches and power outlets, it’s seriously considering me looking at buying some additional SmartThings switches and power outlets and installing them in my home so I can control them with my voice using my Amazon Echo.

However, when I first connected SmartThings to the Amazon Echo, I had to “approve” my current SmartThings switches/devices on my network, then do the discover so the Echo would find my devices and add them in.

If I purchase some additional switches/outlets/devices, will I have to do anything to first “approve” those devices in SmartThings with the Amazon Echo, or will simply running discover on the Echo find them all and bring them right in?

Thanks!


#2

You will have to approve the new ones, then do a discovery.

See step 10 in the community FAQ:


(Nathan Parker) #3

Sounds good. Thanks for the info! I was thinking I’d need to approve new devices and wasn’t sure where to look. Great tutorial and thanks for pointing that out!


(Dale C) #4

I have added three simulated switches now along with @MichaelS Alexa Helper so that Amazon Echo could control some routines. For some reason one of the switches Amazon doesn’t “see” even though it counts it when I do a device discovery. I can’t seem to find a way for Amazon Echo to read to me what the name of all the discovered devices are which would help me know what to say to Echo. I use the Amazon Echo app and I can see what it is supposed to be as “Good Night MBT”. When I originally setup the device I named it “Goodnight” but changed it to separate words but it didn’t help. When I manually trigger the simulated switch the built in ST Good Night routine is triggered via AlexaHelper so I think that side is fine? I just don’t know what name Echo discovered and wants me to say. I deleted it from the Alexa app and did the “forget” device. I removed it from Alexa Helper, I removed the virtual switch and re-added it. When I do a rediscovery with Alexa app it says it finds it (based on the device count increasing) but I can’t seem to turn it on by voice. Alexa just responds “Sorry, I couldn’t find a device or group name Good Night in profile”


(Micheal ) #5

I had this same problem…I believe I found the issue was that ‘good night’ simply couldn’t be used with Alexa as it was one of her key words. Changing the switch to ‘Night Mode’ worked and I use it every night…hope that helps.


(Nathan Parker) #6

Is there a way I can set the Amazon Echo where I could speak to it and arm the house before I’d leave (similar to the “Goodbye” routine, but I’d probably have to name it something else since that’s one of Alexa’s pre-programmed key phrases), then put a time delay where it’d arm the house after so many minutes of leaving? If so, how would I set that up?

Thanks!


(Dale C) #7

You hit it right on the head Michael. I made the change and it now works like a champ! Thanks! :grinning:


(Dale C) #8

Yes that is exactly what I do and it works like a champ. Since Amazon Echo can’t access the ST Goodbye! routine directly you need to setup a virtual switch (momentary button tile) and called it “Security System” I then use @MichaelS smart app called Alexa Helper so that the Amazon Echo can trigger the virtual switch by just saying “Alexa, turn on security system” One of the settings in the amazing Alexa Helper app is “Delay in minutes” which I set it to 1 minute. The other setting in Alexa Helper is when the virtual switch is triggered I then set the “Perform this routine” to Goodbye! which arms the system. If you haven’t done virtual switches with Amazon Echo yet @JDRoberts has an awesome tutorial FAQ: Using Echo to Change a Mode or Run a Routine that you can read here [DEPRECATED] 2015 Voice Assistant Run Routine FAQ--see 2017 FAQ instead It was really helpful for newbies like me.


(Micheal ) #9

My Alexa Helper app has that function…simply set a delay and it will trip a switch with a delay you specify. I have a virtual switch called security and when I am leaving say “turn on security” and it does it after 5 min. The latest version even can change you Smart Home Monitor without a routine.


(Dale C) #10

[quote=“MichaelS, post:9, topic:32329, full:true”]
My Alexa Helper app… The latest version even can change you Smart Home Monitor without a routine. [/quote]
What?! :open_mouth: You just keep getting it better and better. Updating now


(Nathan Parker) #11

Sounds good. I’ll bookmark this thread and look over everything when I have a free moment and see how to put my Echo to more good use!


(Nathan Parker) #12

Finally got around to doing this. I used the API to publish the Alexa Helper app code to me, and I installed the app in ST. I created the Button Tile named Security System. However, when I tap to create a new Alexa instance, the app doesn’t do anything. What do I need to do to resolve this? Thanks!


(Anmolsrepo) #13

Was just thinking of using another words but was curious to understand why it is not working. Thanks for your answer, I understand it might be something to do with Alexa’s reserved words.
I changed my sentence and utterance and now it all works.