Qubino flush relays? (DTH in post 13)

I have the “1”.

If all works well, I want to also buy the shutter ones too, to control some window blinds.

What device type did you use?

I tried it out, in a socket, and it works ok. It gets recognised as a generic “z-wave relay” device, so it only has the basic support of on/off. It’s missing the power usage/monitoring and other features.

How are you getting on with it? I just got the 1D and installed it in my garage door. It works fine but because of lack of official support, some of the features are missing. For example I should be able to configure the device by setting some parameters so that it acts like a momentary switch but I think I’m going to have to learn how to program a new devise type to get that up and running…

I never got one since few stores sell it here.
I took a chance with Fibaro FGS-222 instead. It does not officially support DC (talked to Fibaro support). But looks like it’s working feeding it with DC 24V and switching a DC 3V.
There’s probably some issue, small glitch or something with this since they refuse to say DC is supported.
FGS-221 support DC but hard to find in any stores. Guess it’s one it’s way out.

Maybe @tommysqueak can help you out.

If u gonna code maybe this one can be a help:

Best of luck

I just bought some of the Shutter and Dimmer switches as well from Qubino.

I haven’t had a chance to use the relays on a light switch yet and I think I’ll need a custom device handler. I wrote a handler for the some radiator valves I have, so I reckon I can take inspiration from the Fibaro ones and make some for the Qubinos. I’ll share what I have, when I get round to them (the apartment that they’re being installed in doesn’t have Internet access yet! That’s first :slight_smile:).

Hi Tom, did you get around to looking at the custom device handler yet? I have been pretty much flat out busy since May so sadly haven’t had the chance…

I got the Qubino 1 channel relay, but can’t get it to connect. Anyone who has tried it or have any tips?

Sorry Mark. I forgot about this!

I ended up go a different route with developing a thermostat handler for these relays, together with the temperature sensor. But before I went down that route, I think I got a handler working as a normal switch. Unfortunately I don’t have a relay setup to test with the handler as a normal switch.

I’ll find the code and share this evening.

Here’s a handler for the Qubino Flush 1 Relay. You can set the switch type - toggle or push button/momentary. Besides that, it does the basics of turn and off :slight_smile:

I’ve not been able to test it recently, as I converted this into a Thermostat style handler for the qubino to manage an electic radiator/s.

Let me know, if it works. I might be able to figure out some stuff, even without the qubino.

Thanks so much for this!

I just got a Qubino Flush Relay, but it’s the thermostat version. (Part number ZMNHID1). The switch does work just fine, but if the temperature reading is above the temperation setting, the relay won’t turn on, which is what you’d expect from a thermostat.

Are you at all able to add thermostat heat slider settings to this device handler? I’m trying to have a play with this myself so will share if I have any success.



That sounds like a different device handler for that type of module, as the regular just need the on/off functionality. Feel free to copy the handler code and turn it into one for the ZMNHID1.

I’m not sure how that module behaves or which settings it needs to operate. I know the Qubino’s a are pretty good on config and document it quite well.

Did it work for the 1D version (with the relay, ZMNHND1)?

Yes they work fine, I don’t see the energy though.

These devices are actually the best I have, they switch fast and update very fast in the app.

I have exactly the same problem. The manual states that you need to change the device parameter for input switch type from 0 to 1.

Did you ever figure out how to do this?

That should help as far as parameter configuration:

I have the tommysqueak : Qubino Flush 1 Relay mostly working with for my use case.
It has been super helpful.
I need a momentary switch like you would need for a garage door opener/close.
I am actually using for a low voltage light system called touchplate.
When I say it is mostly working…I can turn the lights on but it takes two clicks. (and the same to turn off)
It does not seem to be working like a push button.

Any thoughts on how I could set the configuration.

If you haven’t already tried it, there’s a config setting to switch the type of switch used. That might work.

Hi all, just wondering if anyone here could help me?I’m currently trying to connect a qubino flush 1 relay to my ST set up and cannot for the life of me get the relay to include when I try to add it as a thing. I have tried it in several different sockets to no avail and even wired it up on a long lead so I could hold it next to the hub. Still no joy!

I’m in the UK, using it on mains power. I may well be doing something dumb but would appreciate any suggestions.

Thanks all!

Great work! Any chance to get the ZMNHID1 thermostat working? I can only see the temperature with Relay handler but the switch does not seem to work as it should. It always shows OFF even when ON and kWh is now 0W but was working before.