Proximity location and size for presence


(Edward Reese) #1

So my house is not extremely large but the issue I am having is that presence is perfectly fine detected on the west side of the house but on the east where the bedrooms are we frequently lose presence. The hub was originally located in the living room on the west of the house but is now in the garage which is on the east. I moved it because of the issue but it had little effect on it.
When I tried to adjust the geo fence for my location I see that it covers the entire cull-de-sac, so I am well within no matter where I am in the house.
I have 2 wifi routers in the house, one on each side and the only thing that I could think of is that when my phone switches from one to the other that there is enough of a connection gap for the ST to think that I left.
I did notice it flip flopping frequently.
for example: I come and ST disarms. I go to the bedroom and ST arms/away because I left. I come back to the front(west) and the alarm goes off because now I triggered the motion detector.


#2

I’m sure that’s very frustrating. :disappointed_relieved: I Think it probably is the point where you shift from one router to the other. Your phone is losing connection and so the hub thinks you are away. Try the mobile troubleshooting steps and see if that helps at all.


( I hate Mondays) #3

I don’t think the hub assumes you are away because you are no longer connected to one wifi. It would have to receive a definitive gps location outside the home circle to determine that you are away. Issue may be with GPS signal. Try moving the circle towards the east. If that does not help, try enlarging it a little bit. Are there tall structures around you? Tall buildings, mountains? They can obscure GPS sattelites from view, affecting your precision, which in turn can place you at random locations around your real location, sometimes outside your circle. Roofing material? Wall material? Those could also affect the GPS signal in your house. Just a few years back, GPS wasn’t even functional inside the house… it works by triangulation, so the more sattelites your device “sees”, the better the precision.


(Dan) #4

If you’re using your phones for presence detection, the location of the hub has ZERO impact on it. If you use one of the ST battery operated presence detector key fobs, which are Zigbee, it makes a huge difference.

When using your phone, the ST App creates a geofence. If the phone thinks you’re inside the geofence, it sends a signal to the ST cloud directly, telling ST that you’re home. The hub is not involved in this at all.

Make your geofence larger, and bias it toward the side of your house where you’re having an issue.

Also, you state you have two routers in your house. Is one set up as a router and the other setup as an access point? If both are set up as routers, that could very easily be your issue. Make sure the second one is an access point, on the same LAN as the router. You do not want a double NAT scenario as WiFi networking is often used by a phone’s gps logic to help determine location. Having two networks in your home (i.e. double NAT) could easily confuse your phone as the second WiFi network would not be properly geo-located.


(Edward Reese) #5

Thanks, it was one of the first things I tried and everything checks out fine. it is frustrating especially when the kids wake up.


#6

If that were true it wouldn’t mark you as away when the phone is turned off. Like most location services, it uses a combination of GPS and Wi-Fi.


( I hate Mondays) #7

Never tried that, but I will. That would be awful, what if my battery dies overnight? I would expect GPS location to rely on facts rather than assumptions…


(Edward Reese) #8

there are no tall structure around here or anywhere close. it’s all residential. we do have mountains but they are about 4-5 miles to the north. I otherwise get got GPS. my phone can pinpoint me correctly and accurately here at home.
I already enlarged the circle to about a half a mile radius. much bigger than I like to but it was an attempt to solves this issue. for some reason I am having a hard time adjusting it now.
There are no unusual material in this house or odd structures. it’s a cement tile roof. the rest is wood, stucco and drywall. we don’t have the a/c and furnace in the attic either.


#9

Almost all GPS technology is based on assumptions unless you’re looking at military grade stuff. that’s why your phone can show your location as jumping from one place to another even when you don’t move at all – – it’s making assumptions based on the cell tower you connected to.

The following article is for iOS, but the android methodology is very similar, just a different database.

http://www.quepublishing.com/articles/article.aspx?p=1927378


( I hate Mondays) #10

By assumptions I meant, if you don’t know where the phone is, don’t assume it’s “away”. Even the GPS-assist by using cell towers is somewhat doing some sort of triangulation by looking at what towers are seen by the cell phone and their RSSI. That information can give a location, although quite broad in its error margins.

I would install an app on the phone that tracks GPS location and get an idea of what’s going on - is your phone “walking around” thinking you moved around, or is ST making assumptions on the lack of presence information from your phone?

After that, I’d try disabling the GPS-assist?


#11

There’s already an FAQ for troubleshooting mobile presence issues. The OP said they’ve already looked through that one, which is why I suspect it’s the dual routers that’s the issue. But for anyone else having trouble with phone presence, the FAQ is a good place to start. :sunglasses:


( I hate Mondays) #12

I’ve never had any issue whatsoever. Actually, I have one. One of my daughters has a friend who lives on the next street behind our house, but due to the neighborhood structure, we have to drive her there since there is no easy/short access path. Every time I take her there, my garage door opens because, well, I arrived home :smiley: I can’t move the circle forward because it then touches a street on which we may drive back and forth without coming home. So I have to disable my rule every time I go there, or close the garage. It’s one of those can’t-fix-them-all problems…


(Edward Reese) #13

the two wifi routers are actually setup as access points. neither does NAT. they use the same SSID on different channels.
the geo fence is very large, well beyond the house.


#14

Have you tried turning off one of the routers and walking around the house with the phone to see how ST responds?


(Dan) #15

If both routers are in true “Access Point” only mode (i.e. no NAT), what device is doing the routing within your home?

Try just disabling WiFi altogether on your phone as a test to see if the problem goes away.


(Edward Reese) #16

I just recently added the 2nd one because I thought that wifi might be an issue. with only the router in the front of the house coverage can be a little spotty in the back. unfortunately adding the second router had little to no effect on the issue. coverage is better but I am still away.
I think it is worth mentioning that this is rather sporadic. it happens often enough to be recreatable but it is in no way consistent. there are days where everything goes fine and days where everything is haywire.


#17

I’m sure that’s frustrating! Sometimes it seems worse when a problem only occurs occasionally because it can be harder to troubleshoot. The SmartThings app does keep mobile presence logs which support can look at and see if they can see anything that might help. So you can wait until a day when it is going flaky, and then follow the instructions below to send those logs to support.


(Edward Reese) #18

I will give it a shot