Problem with Wemo smartapp

So, I (apparently) had been using an “unofficial” smart app for my wemo devices, and I had my existing devices all integrated and working like a champ.

I recently bought a couple of new plugs and wanted to add them. I set up one and tried to add it to smartthings, but I got some error…

So, I removed that app, and decided to use the official app since it appears new since I tried last time.

It discovers my devices properly, and I can select them. But when I save I get “Unexpected error occurred” and the selects are unset.

Any ideas?

What smartapp were you using?

What was the error message?

What app? I am trying to figure if you are talking about a smartapp in ST or app on your mobile device.

Official app?

What type of wemo devices do you have… smart plugs, switches?

Did you try adding manually through marketplace: things: SmartThings lab?

Yea, I ended up going that route. Seems fine.

There is an old app in their git repo that I was using, apparently no longer works