Presence Timeout Can Be Set In Two Places, Which One Wins?


(Connel Hooley) #1

Using the SmartThings mobile app I can set the default timeout on my presence sensor to either 2, 3 or 5.

However I can also go into the online IDE and change a setting on my hub called “Presence Timeout”. I can seemingly set this to whatever value I like.

Why are there two settings for this and which one wins f they’re different values?


(Glen King) #2

I don’t see the setting in the mobile app. Where is it?

However, I set the timeout to 7 minutes in IDE… and that is what it’s doing. So presumably, IDE rules the roost.


(Dan) #3

It depends on what generation of ST key-fob presence detector you have. The original sensors use the IDE’s setting. The newer ones being sold today use the setting within the mobile app. ( IIRC :wink: )


(Connel Hooley) #4

Thanks for the reply.

If you got to the “My Home” screen to list all your devices, then click on a presence sensor, then click on the settings cog at the top right, the bottom option above the remove button allows you to specify a timeout for that device.

I’ve only just seen the setting in the IDE so I haven’t had a chance to experiment tweaking both the values yet but wondered if anyone in the forums had already knew.


(Connel Hooley) #5

Oh that’s good to know. Bit of a shame as the IDE setting allows more flexibility. I’m having a bit of a hard time getting my presence sensor to act reliably (even bought a power outlet to repeat the signal right next to where I leave my keys) and having a timeout greater than 5 minutes could’ve helped.


(Glen King) #6

Must be because I’ve been too paranoid to update the app recently, but on my iPad that option does not exist. The available options are
Give your device a name
Set device image
Remove


(Dan) #8

The option will only exist if you’re using a newish model of the ST Zigbee Keyfob Presence Detector. The older model (both in the oval and rectangular packaging) use a different Device Handler which does not expose that setting.