Android Smart Phone as a presence sensor still not reliable?!


#1

I set up my android phone (Samsung Note 5) as a presence sensor for my Smartthings hub. However, the only time it works is when I initially set it up (shows as arrived). But it never works after that. It often reports arriving or leaving several hours late, if that. Currently, it reports I’m at home even though I’m at work some 20 miles away (it’s been like this for several days now).

So, instead, I’ve been using Life360 and it’s been very accurate (I’d rather not use this app because it uses more battery).

My question is, anyone out there who is successfully and consistently using their Android phone as presence sensor? And if so, what is their setting?

I’ve tried all of the usual tweaking, including using “High Accuracy” and other location settings in the phone.

Thanks!


#2

I use 4 Android phones as presence sensors, all working great. Yeah, every blue moon one flakes out, but it’s almost always been related to a low battery, or an app update.

My geofence radius is about 1/4 mile, and my presence timeout is 2 minutes (changed via the IDE).

Samsung Note 5
Samsung Note 3
2 Samsung S4

Also have a Samsung tablet, spare S4, and an iPhone 7+. The iPhone is the worse one of the bunch.


#3

I have been running successfully for a very long time with the exception of a couple of things. I was part of account migration beta and it broke and then I replaced phone last week. I wrote up a whole big dissertation in two threads a couple of days ago.

I will tell you this. If you do not make the Geofence perimeter wide enough, it won’t work reliably. If you have left this the size of the default circle when you set it up in the Geofence settings, it will be unreliable. That’s one issue.

Here’s my suggestion. Go into the Settings and make the circle bigger. Mine is like 5 blocks away from home all the way around. Save those settings all the way thru.

Then open it again, and then move the perimeter to the left. Hint: if you click between the blue circle and the icon for a half second and release it will move you perimeter. Keep doing this until you are 5 miles away from your current location and then save save save. Wait a minute and see if it notified you that your device has left or look at it in things to see if it goes Away. If that works, then go back into Geofence and press the little reset button in the map which will put the blue dot back on your current location. Then press the blue dot for a second or so and the perimeter will reset around your Location. Do not adjust the circle size.

Then when that works, go take a drive for 10 minutes and make sure it changes to Away and then head home and see if it changes to Present.

I use my mobile presence to disarm ST, open the Garage door and unlock the door to inside.

Here is the link for my complete write up on Android and Mobile presence for New Phone and existing phone, but perform the test above first. That will show and tell if your ohine is going to be responsive to those changes I recommended and so did the previous poster:


(Bryce Miner) #4

Open up your map app when you are within your geofence and see where it thinks you are. My trouble shooting is with the maps app to make sure that is working.


#5

Thanks for all replies.

First, my map app accurately shows my location when I am inside the geofence. My presence timeout is set to 2 min.

And I followed the instructions of setting the circle wider (I made it about 1/4 mile). Then I moved the circle few miles to the left. But my phone still showed I was present at home. Did this a few times but the phone never left home.

What’s interesting is in the Smartthings app my phone’s activity is shown as present at 8:56PM while last activity in the IDE is 9:16PM. Shouldn’t these times match?

In any case, my phone does not respond as presence sensor even though the GPS is working fine based on the maps app.


#6

So read my full post on that other thread and go thru the instructions for Existing phone. With the 2.10 mobile app released it broke my phone for the first time in a year. Worst case, I ended up removing my phone. Before I removed my phone, I took a screenshot of the phone in Things on the SmartApps tab so I knew exactly where I needed to replace everything. After adding phone in again and setting the Geofence up to my liking, and adding the phone back to every Routine and SmartApp, (and a few hours of sleep) it was reporting the way it had all along.


#7

I read your full post and tried to follow the instructions there.

However, my phone is still only showing the initial arrival time of 10:02 PM last night and not updating at all even though I have left home and come back earlier today (about 5 miles away from my home).

I guess I will have to stick with Life360 until I can get this figured out. :frowning:


(Kirk Hilzinger) #8

I use a Samsung without issue…though with my detached
garage, I might increase the area to consider me
"home".


#9

I had a same issue on wife’s phone. Problem is a battery optimization.

Not sure what Android OS version you have, but on mine is:

  • Settings
  • Device Maintenance
  • Battery
  • Click on the Battery Usage
  • Click on the three dots in upper right corner - Optimize batter Usage
  • Select All Apps
  • Disable Smartthings.

Hope this works for you.


#10

Presence is not just working… aaarght…

I have two phones. I set my location like it should be. There’s no battery optimization, Smartthings gets all battery power till it ends. Status is “present” no matter what. According log hub knows time when presence trigger has been “installed” but doesn’t update it if device leaves its location. It does same thing with both android devices.


(Daniel Ionescu) #11

GPS set to HIGH ACCURACY?

I also have 2 S8 and both work without a hitch.


#12

Make sure that ST permissions have Contacts, Location and storage turned on. I’m sure it is because your Arrival is working as for Presence being detected when you arrive but check anyway.

Make your Geofence perimeter (the circle) slightly larger than it is now.

Also - Important - Modify the Routine for when you leave and change the Action Delay time from default of 10 minutes to 0 or 1.

Then get in the vehicle and drive away for 10 minutes.

For testing - I would just have just one phone in the “When Everyone Leaves” selection. You can add the other one later after you have tested that one phone works and presence is set to Not Present when you leave the Geofence perimeter.


#13

Hi, I installed presence sensor from smartapps. There is no setting for “action delay”. I also tried to configure home solution “custom” presence sensor. It works same way. Now it understands that I left home but notification (sms and push) comes 45minutes late. Yesterday I chat with ST support and they made some changes in my HUB but it didn’t help.
So… presence changes but notifications are sent way too late. That action delay setting might be important in this problem but I can’t find a way to change. (default 10min ?)


#14

Action delay would be used for you routines that use a presence sensor to execute. The presence timeout for you phone can be changed in the IDE. https://account.smartthings.com
Select you hub location then select view utilities.


#15

Ok. It was default. I asked “get presence timeout” and it says 2min. So default is 2min. That should be ok. Today was better day. At morning I left home. Sms and push came 30min later. Afer that my kid went to school and notification came 5min later. He came home and notification came 1min later. He left again and notification came 5min later. I came home and notification came at the door just right time.
Don’t know if this is normal behavior but at least it’s getting better.


#16

I’ve followed all the instructions here to make my Samsung Note 5 as a presence sensor yet it’s still not working reliably.

When I move my circle manually, the phone does recognize and says I’m away. And when I move the circle back to home, it says I’ve arrived. So I know that part is working. The problem is, later that day or next day it no longer works.

So I’ve been using Life360 as presence sensor and it works pretty well. However, I have to keep the Drive Detection on for it to work reliably but that tends to drain the battery.

I’m so envious of you guys who can use your phone as presence sensor!