Android Presence Timeout


(JIm) #1

It appears the minimum time for the system to notify that my android phone is not present is 2 minutes. Is there any way this could be shortened?


#2

There is a setting in the IDE under the hub utilities that is the presence time out. I’ve never changed it, but that sounds like it might do it, although that is global. Not sure if you meant for a given device or not.


(JIm) #3

That’s the setting I meant. Butbit appears the minimum is 2 minutes. I need sonething less.


(JIm) #5

Mine is set at 2 minutes not 5. So what determines the delay when my android device leaves its area? It seems to be about 2 minutes now which led me to believe that was the setting. I upped the setting to 5. I’ll see what it does next time I leave.


#7

I couldn’t find anything official, but seems like support gave this user feedback that it does. Don’t see any way to make lower than 2 min though.


#9

What is it you’re trying to accomplish? Maybe you could use Tasker and SharpTools and use wifi disconnect or location.


(Dan) #10

It was my understanding that the HUB’s Presence Sensor timeout is only for the SmartThings Zigbee-based key-fob-style Arrival Sensor device.

I have a push notification setup to notify me when any of our presence sensor devices arrive or depart. I have 2 ST zigbee sensors and 2 smartphones. As soon as the SmartPhones leave the Geofence, I get a push notification within about 5-10 seconds. Same for arrival. The zigbee based sensors definitely take longer due to the hub’s timeout setting, which I have set to three minutes to prevent false alarms.


(Bob) #11

I can say 100% that the 5 minute timer that keeps being mentioned has absolutely no effect on my
phone presence sensors.
If you want to prove this move your geofence location to 10 miles away for example.
Now save it.
If I then go into my wifes andriod and open up the ST app her presence changes to away immediately.
How do I know this? I’ve had lots of issues with mobile phone presence and have done lots of testing to prove whats been happening.
If you want to keep playing with the timer feel free to do so.


(JIm) #12

I’m not disagreeing with you, I just don’t know. There is definitely a delay from the time I leave the location area before ST acts on it. And it appeared to be about 2 minutes which led me to ask if that setting was what was controlling it.

So somewhere there must be some sort of built in delay and I would like it to be shorter.


#13

Maybe its your phone being slow to update location? Does it make a difference if you do it while app open and screen on? Is ST set to be exempt from doze?


(JIm) #14

Ok, here is ST’s support answer to the issue.

Hi There,
Thanks for writing into SmartThings support.
I will be happy to explain Presence Timeout for you.
Presence Timeout is simply used for mobile presence detection.
For instance, say Jim White’s Android leaves the Geofence around your home. It will not switch your phones Present/Not Present status to away until it has exited the geofence for 5 minutes. For those who may be having false presence events, it is often helpful to set this to a long time so that you can decrease false presence alerts.

Please let me know if you have any additional questions or concerns. I will be happy to help in any way that I can.
All my best,
Jonathan
SmartThings Support


(Brad) #15

I will correct the misinformation with the support team.

The presence timeout setting under Hub utilities only impacts the first generation of physical Arrival Sensor. That setting will not impact mobile presence or newer versions of the Arrival Sensor where the timeout is set in the device preferences of the mobile app.


(Bob) #16

Give this a try.


(JIm) #17

That being the case how do you set the timeout for Android Presence?


(Bob) #18

Automation -> Routines. Or maybe webCoRE.
Lots of ways.


(Bob) #19



(JIm) #20

Thanks for all the replies. It at least clears the air. It doesn’t solve my problem, but now I know where to not look.

I use Webcore to trigger things when I leave and when I return based on my mobile presence. The problem is it takes a couple minutes AFTER I leave the zone before it triggers. That is why I thought there was some built in delay for the presence. So I wanted that to be shorter. But it appears there is no way to change that, so I will manage.

Thanks again for all the helpful info.


(Dan) #21

If you want to evaluate Presence performance, it is probably best to set up a simple custom notification from within Smart Home Monitor. I have a custom monitoring rule in SHM that sends me a push notification each time a presence device either arrives or departs. By separating the logic into a standalone rule, you can then easily tell if the delay is coming from Presence or your custom webCoRE rule.


(Joshua Lyon (SharpTools.io Dashboard)) #22

If you are interested in going the Tasker + SharpTools route, there’s a great presence profile put together by a community member: